summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-proto/xcb-proto/xcb-proto-1.6.ebuild')
-rw-r--r--x11-proto/xcb-proto/xcb-proto-1.6.ebuild15
1 files changed, 14 insertions, 1 deletions
diff --git a/x11-proto/xcb-proto/xcb-proto-1.6.ebuild b/x11-proto/xcb-proto/xcb-proto-1.6.ebuild
index 20a43bf59c24..30019aabeded 100644
--- a/x11-proto/xcb-proto/xcb-proto-1.6.ebuild
+++ b/x11-proto/xcb-proto/xcb-proto-1.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-proto/xcb-proto/xcb-proto-1.6.ebuild,v 1.8 2010/05/12 18:17:54 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-proto/xcb-proto/xcb-proto-1.6.ebuild,v 1.9 2010/05/21 18:08:00 arfrever Exp $
PYTHON_DEPEND="2:2.5"
@@ -22,3 +22,16 @@ DEPEND="${RDEPEND}
pkg_setup() {
python_set_active_version 2
}
+
+src_install() {
+ x-modular_src_install
+ python_clean_installation_image
+}
+
+pkg_postinst() {
+ python_mod_optimize $(python_get_sitedir)/xcbgen
+}
+
+pkg_postrm() {
+ python_mod_cleanup $(python_get_sitedir)/xcbgen
+}