summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/afterstep')
-rw-r--r--x11-wm/afterstep/ChangeLog7
-rw-r--r--x11-wm/afterstep/afterstep-2.2.9.ebuild5
-rw-r--r--x11-wm/afterstep/files/afterstep-2.2.9-make_session_data_file.patch14
3 files changed, 23 insertions, 3 deletions
diff --git a/x11-wm/afterstep/ChangeLog b/x11-wm/afterstep/ChangeLog
index 3cc5547dd24b..5fe1794f232b 100644
--- a/x11-wm/afterstep/ChangeLog
+++ b/x11-wm/afterstep/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-wm/afterstep
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/afterstep/ChangeLog,v 1.89 2010/06/22 14:36:26 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/afterstep/ChangeLog,v 1.90 2010/06/22 16:10:08 ssuominen Exp $
+
+ 22 Jun 2010; Samuli Suominen <ssuominen@gentoo.org>
+ afterstep-2.2.9.ebuild,
+ +files/afterstep-2.2.9-make_session_data_file.patch:
+ Fix implicit declaration of function make_session_data_file wrt #308649.
22 Jun 2010; Jeroen Roovers <jer@gentoo.org> afterstep-2.2.9.ebuild:
Stable for HPPA (bug #306107).
diff --git a/x11-wm/afterstep/afterstep-2.2.9.ebuild b/x11-wm/afterstep/afterstep-2.2.9.ebuild
index b27c5920ad0b..e63cee02f355 100644
--- a/x11-wm/afterstep/afterstep-2.2.9.ebuild
+++ b/x11-wm/afterstep/afterstep-2.2.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/afterstep/afterstep-2.2.9.ebuild,v 1.8 2010/06/22 14:36:26 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/afterstep/afterstep-2.2.9.ebuild,v 1.9 2010/06/22 16:10:08 ssuominen Exp $
EAPI=2
inherit autotools flag-o-matic eutils
@@ -43,7 +43,8 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/AfterStep-${PV}
src_prepare() {
- epatch "${FILESDIR}"/no-alternatives-${PV}.patch
+ epatch "${FILESDIR}"/no-alternatives-${PV}.patch \
+ "${FILESDIR}"/${P}-make_session_data_file.patch
# Do not strip binaries, bug #252119
sed -e "/STRIP_BINARIES/s/-s//" \
diff --git a/x11-wm/afterstep/files/afterstep-2.2.9-make_session_data_file.patch b/x11-wm/afterstep/files/afterstep-2.2.9-make_session_data_file.patch
new file mode 100644
index 000000000000..2c2f8bfeee3d
--- /dev/null
+++ b/x11-wm/afterstep/files/afterstep-2.2.9-make_session_data_file.patch
@@ -0,0 +1,14 @@
+http://bugs.gentoo.org/308649
+
+asgtklookedit.c:658:3: warning: implicit declaration of function ‘make_session_data_file’
+
+--- libASGTK/asgtklookedit.c
++++ libASGTK/asgtklookedit.c
+@@ -28,6 +28,7 @@
+ #include "../libAfterStep/parser.h"
+ #include "../libAfterStep/freestor.h"
+ #include "../libAfterStep/mystyle.h"
++#include "../libAfterStep/session.h"
+ #include "../libAfterConf/afterconf.h"
+
+ #include <unistd.h>