summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/kahakai/kahakai-0.6.2_p20040306.ebuild')
-rw-r--r--x11-wm/kahakai/kahakai-0.6.2_p20040306.ebuild15
1 files changed, 9 insertions, 6 deletions
diff --git a/x11-wm/kahakai/kahakai-0.6.2_p20040306.ebuild b/x11-wm/kahakai/kahakai-0.6.2_p20040306.ebuild
index 40bf17994fd9..b0c4d4de8745 100644
--- a/x11-wm/kahakai/kahakai-0.6.2_p20040306.ebuild
+++ b/x11-wm/kahakai/kahakai-0.6.2_p20040306.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/kahakai/kahakai-0.6.2_p20040306.ebuild,v 1.3 2004/10/09 19:20:19 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/kahakai/kahakai-0.6.2_p20040306.ebuild,v 1.4 2005/02/20 10:46:29 usata Exp $
inherit eutils
@@ -25,7 +25,8 @@ RDEPEND="virtual/x11
dev-libs/boost"
DEPEND="${RDEPEND}
>=sys-devel/autoconf-2.57-r1
- >=sys-devel/automake-1.7.2"
+ >=sys-devel/automake-1.7.2
+ sys-devel/libtool"
S="${WORKDIR}/${PN}"
@@ -33,14 +34,16 @@ src_unpack() {
unpack ${A}
cd ${S}/src
epatch ${FILESDIR}/${P}-rubyscript-gentoo.diff
+ epatch ${FILESDIR}/${P}-compilation_fix.patch
}
src_compile() {
+ libtoolize --copy --force || die
./autogen.sh || die
econf \
- `use_enable ruby` \
- `use_enable xinerama` \
- `use_enable truetype xft` || die
+ $(use_enable ruby) \
+ $(use_enable xinerama) \
+ $(use_enable truetype xft) || die
emake || die
}