summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2014-07-17 14:56:01 +0400
committerAlexey Shvetsov <alexxy@gentoo.org>2014-07-17 14:56:01 +0400
commit9a5226a1e999c322e13f6838460cefd10c761599 (patch)
treece44cafc63554641ea0ad4a42a82c6d115703846
parentFix build (diff)
downloadalexxy-9a5226a1e999c322e13f6838460cefd10c761599.tar.gz
alexxy-9a5226a1e999c322e13f6838460cefd10c761599.tar.bz2
alexxy-9a5226a1e999c322e13f6838460cefd10c761599.zip
Add toxcore ebuild
Package-Manager: portage-2.2.10
-rw-r--r--net-libs/toxcore/metadata.xml13
-rw-r--r--net-libs/toxcore/toxcore-9999.ebuild39
2 files changed, 52 insertions, 0 deletions
diff --git a/net-libs/toxcore/metadata.xml b/net-libs/toxcore/metadata.xml
new file mode 100644
index 0000000..6c5a05d
--- /dev/null
+++ b/net-libs/toxcore/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>alexxy@gentoo.org</email>
+ <name>Alexey Shvetsov</name>
+ </maintainer>
+ <use>
+ <flag name="av">Adds support for audio and video.</flag>
+ <flag name="logging">Enables logging, useful for debugging.</flag>
+ <flag name="daemon">Enable the DHT Bootstrap Daemon</flag>
+ </use>
+</pkgmetadata>
diff --git a/net-libs/toxcore/toxcore-9999.ebuild b/net-libs/toxcore/toxcore-9999.ebuild
new file mode 100644
index 0000000..a273e67
--- /dev/null
+++ b/net-libs/toxcore/toxcore-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit git-r3 autotools-utils
+
+AUTOTOOLS_AUTORECONF="1"
+
+DESCRIPTION="The future of online communications"
+HOMEPAGE="https://tox.im"
+SRC_URI=""
+EGIT_REPO_URI=" git://github.com/irungentoo/toxcore
+ https://github.com/irungentoo/toxcore"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE="+av logging daemon static-libs"
+
+DEPEND="
+ dev-libs/libsodium
+ av? ( media-libs/libvpx media-libs/opus )
+ daemon? ( dev-libs/libconfig )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable av)
+ $(use_enable logging)
+ $(use_enable daemon)
+ $(use_enable static-libs static)
+ --disable-tests
+ --disable-testing
+ --program-transform-name='s:DHT_bootstrap:tox-dht-daemon:g'
+ )
+ autotools-utils_src_configure
+}