summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2011-06-26 14:38:18 +0200
committerChristoph Mende <angelos@gentoo.org>2011-06-26 14:38:18 +0200
commit76b669a8463ea78352e3a61f74e354eb3eb5dba1 (patch)
tree17c7961d05a5217ed87e81edf7597ae05e336be5
parentcorsixth: Initial import (diff)
downloadangelos-76b669a8463ea78352e3a61f74e354eb3eb5dba1.tar.gz
angelos-76b669a8463ea78352e3a61f74e354eb3eb5dba1.tar.bz2
angelos-76b669a8463ea78352e3a61f74e354eb3eb5dba1.zip
ircdotnet: Initial import
(Portage version: 2.2.0_alpha41/git/Linux x86_64, signed Manifest commit with key 84F20B43)
-rw-r--r--dev-dotnet/ircdotnet/Manifest14
-rw-r--r--dev-dotnet/ircdotnet/files/ircdotnet-0.4.0-disable-tests.patch13
-rw-r--r--dev-dotnet/ircdotnet/ircdotnet-0.4.0.ebuild35
-rw-r--r--dev-dotnet/ircdotnet/metadata.xml6
4 files changed, 68 insertions, 0 deletions
diff --git a/dev-dotnet/ircdotnet/Manifest b/dev-dotnet/ircdotnet/Manifest
new file mode 100644
index 0000000..ba6c5c2
--- /dev/null
+++ b/dev-dotnet/ircdotnet/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA256
+
+AUX ircdotnet-0.4.0-disable-tests.patch 680 RMD160 7b7738e348936f092f0c4535725e9bc880a09aa3 SHA1 e3f15c2917494d7e95665437d9b6fae147798aec SHA256 1b782a0526a5f2cb2eee24aca10cc6d464e4c0f7f1845c68caf2940de8373637
+DIST ircdotnet-0.4.0-src.zip 726688 RMD160 5952670663dd92c82b4536dc0b914bc5f1d7e2d8 SHA1 fc29e0ff80797e4a0ad9a8c30db3b5ed88aabfe9 SHA256 31caaf68d4f4a825b92d1c5da95b47e9ee1766455a6b8e5b6aaea2e4ba5cf789
+EBUILD ircdotnet-0.4.0.ebuild 763 RMD160 48a7806a85af5252a906f767ee8cdcee92476b25 SHA1 12fbf4db580d6060e49e293fba20c6bd7ecf3226 SHA256 4e44471221f0517cd5d9b9584fec227ab69a792b261c11b38b8347329686bf3d
+MISC metadata.xml 162 RMD160 8056876fd0119a9fcf1cf8e6a622173f9a2a41a6 SHA1 54fe1b9e689c641de2d237db03c8c38c6f7b6522 SHA256 c754e9c767b98b9894c12dd21b8ef1d01f2b5e58813a286f9a62f20078888d85
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.17 (GNU/Linux)
+
+iF4EAREIAAYFAk4HKDoACgkQmWq1bYTyC0M/bgEAu2IRb0HUts5Nkhr7hh1/zN/B
+S7THJ3kk2ia0Tge6DMMBAJaFaorga1weyKEpyHBTcVmSnY81LHdUtc5PUtVgWK0Y
+=gaMK
+-----END PGP SIGNATURE-----
diff --git a/dev-dotnet/ircdotnet/files/ircdotnet-0.4.0-disable-tests.patch b/dev-dotnet/ircdotnet/files/ircdotnet-0.4.0-disable-tests.patch
new file mode 100644
index 0000000..fea0c33
--- /dev/null
+++ b/dev-dotnet/ircdotnet/files/ircdotnet-0.4.0-disable-tests.patch
@@ -0,0 +1,13 @@
+diff --git a/src/IrcDotNet.sln b/src/IrcDotNet.sln
+index 0ff292b..4a209f4 100644
+--- a/src/IrcDotNet.sln
++++ b/src/IrcDotNet.sln
+@@ -10,8 +10,6 @@ Project("{2150E333-8FDC-42A3-9474-1A3956D46DE8}") = "Project", "Project", "{4C04
+ ..\README.txt = ..\README.txt
+ EndProjectSection
+ EndProject
+-Project("{FAE04EC0-301F-11D3-BF4B-00C04F79EFBC}") = "IrcDotNet.Tests", "IrcDotNet.Tests\IrcDotNet.Tests.csproj", "{0F93F768-3B81-499C-AF1B-7977254FA9ED}"
+-EndProject
+ Project("{2150E333-8FDC-42A3-9474-1A3956D46DE8}") = "Solution Items", "Solution Items", "{3E6A3748-68FD-42DD-A12E-9C275C08EF44}"
+ ProjectSection(SolutionItems) = preProject
+ IrcDotNet.vsmdi = IrcDotNet.vsmdi
diff --git a/dev-dotnet/ircdotnet/ircdotnet-0.4.0.ebuild b/dev-dotnet/ircdotnet/ircdotnet-0.4.0.ebuild
new file mode 100644
index 0000000..d107fd8
--- /dev/null
+++ b/dev-dotnet/ircdotnet/ircdotnet-0.4.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+inherit eutils mono multilib
+
+DESCRIPTION="a complete IRC (Internet Relay Chat) client library for the .NET
+Framework"
+HOMEPAGE="https://launchpad.net/ircdotnet"
+SRC_URI="http://launchpad.net/${PN}/0.4/${PV}/+download/${P}-src.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-lang/mono"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${P}-src
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-disable-tests.patch
+}
+
+src_compile() {
+ xbuild /target:Release src/IrcDotNet.sln || die
+}
+
+src_install() {
+ gacutil -i src/IrcDotNet/obj/Debug/IrcDotNet.dll \
+ -root "${ED}/usr/$(get_libdir)" \
+ -gacdir /usr/$(get_libdir) -package ${PN}
+}
diff --git a/dev-dotnet/ircdotnet/metadata.xml b/dev-dotnet/ircdotnet/metadata.xml
new file mode 100644
index 0000000..1bb9c56
--- /dev/null
+++ b/dev-dotnet/ircdotnet/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+</pkgmetadata>
+