summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2012-07-20 12:32:03 +0200
committerChristoph Mende <angelos@gentoo.org>2012-07-20 12:32:03 +0200
commitea36307497e05ad1cb877213894b8b5170a25b13 (patch)
treed9bd5f87f4bbcf677f90d792ab16df24d5a513cd /x11-libs/libido/libido-0.3.4.ebuild
parentbamf: Version bump (diff)
downloadangelos-ea36307497e05ad1cb877213894b8b5170a25b13.tar.gz
angelos-ea36307497e05ad1cb877213894b8b5170a25b13.tar.bz2
angelos-ea36307497e05ad1cb877213894b8b5170a25b13.zip
libido: Version bump, drop gtk2 with its ubuntu specific functions
Diffstat (limited to 'x11-libs/libido/libido-0.3.4.ebuild')
-rw-r--r--x11-libs/libido/libido-0.3.4.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11-libs/libido/libido-0.3.4.ebuild b/x11-libs/libido/libido-0.3.4.ebuild
new file mode 100644
index 0000000..0a44a61
--- /dev/null
+++ b/x11-libs/libido/libido-0.3.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+inherit eutils
+
+MY_PN=${PN/lib}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Widgets and other objects used for indicators"
+HOMEPAGE="https://launchpad.net/ido"
+SRC_URI="http://launchpad.net/ido/0.3/${PV}/+download/${MY_P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:3"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS=( AUTHORS )
+
+src_install() {
+ default
+ find "${ED}" -type f -name "*.la" -exec rm -rf {} + || die
+}