summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/valadoc/valadoc-9999.ebuild')
-rw-r--r--dev-util/valadoc/valadoc-9999.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/dev-util/valadoc/valadoc-9999.ebuild b/dev-util/valadoc/valadoc-9999.ebuild
index 3e50c2b..3cd0d2b 100644
--- a/dev-util/valadoc/valadoc-9999.ebuild
+++ b/dev-util/valadoc/valadoc-9999.ebuild
@@ -2,8 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
-inherit autotools git-2
+EAPI=5
+VALA_MIN_API_VERSION=0.16
+inherit autotools git-2 vala
DESCRIPTION="a documentation generator for Vala source code"
HOMEPAGE="https://live.gnome.org/Valadoc"
@@ -15,7 +16,7 @@ SLOT="0"
KEYWORDS=""
IUSE=""
-RDEPEND="dev-lang/vala:0.14
+RDEPEND="$(vala_depend)
>=dev-libs/glib-2.12:2
>=dev-libs/libgee-0.5:0
>=media-gfx/graphviz-2.16
@@ -27,7 +28,7 @@ DEPEND="${RDEPEND}
DOCS=( AUTHORS MAINTAINERS THANKS )
src_configure() {
- VALAC="$(type -p valac-0.14)" econf --disable-static
+ econf --disable-static
}
src_install() {