summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ross <aross@gentoo.org>2006-10-03 09:35:02 +0000
committerAndrew Ross <aross@gentoo.org>2006-10-03 09:35:02 +0000
commit99cacf034f6707c252db666e7cd3b3e6106f61ab (patch)
treeaa3bbc53b51615debc6ed0203dbd689811bd6e98
parentAllow compilation with gcc-4.1 (bug #147876) without breaking hardened (diff)
downloadaross-99cacf034f6707c252db666e7cd3b3e6106f61ab.tar.gz
aross-99cacf034f6707c252db666e7cd3b3e6106f61ab.tar.bz2
aross-99cacf034f6707c252db666e7cd3b3e6106f61ab.zip
Trim leftover code from supporting unstable. Update HOMEPAGE.
svn path=/; revision=17
-rw-r--r--app-emulation/xen/Manifest8
-rw-r--r--app-emulation/xen/xen-3.0.2-r1.ebuild34
2 files changed, 12 insertions, 30 deletions
diff --git a/app-emulation/xen/Manifest b/app-emulation/xen/Manifest
index 83cd582..ccbfc37 100644
--- a/app-emulation/xen/Manifest
+++ b/app-emulation/xen/Manifest
@@ -23,10 +23,10 @@ MD5 a3c0c26c30ce1271b439661b68ca9e74 files/xendomains-init 1671
RMD160 e2dbb7b4da5ff8be60532e5a393988f47f28c036 files/xendomains-init 1671
SHA256 19aac7da0ba103ae800ed10b7d151912b3a9476edf63c3651073a197ea291e49 files/xendomains-init 1671
DIST xen-3.0.2-src.tgz 4933621 RMD160 34e4431a981891319f8a5ea0c3f604e7d8d7d7af SHA1 b7e797048b516f8b385afd3da9ae2eded1b8033a SHA256 f18ffab16a457fa721d11933c75f8288f6958c88c2669857c7c11d5107ba2951
-EBUILD xen-3.0.2-r1.ebuild 2973 RMD160 bd47c868aad14e66d072650c1d8ade3d7edd890c SHA1 b1d8832349844e1b381dc8e18bad30909c6a8ff3 SHA256 c7543ef2104c4186e480583d4594efc02d6e23d15a0b798edcf6462aa9106af6
-MD5 f5d31584ae2a495cd6482afbcc89ba8c xen-3.0.2-r1.ebuild 2973
-RMD160 bd47c868aad14e66d072650c1d8ade3d7edd890c xen-3.0.2-r1.ebuild 2973
-SHA256 c7543ef2104c4186e480583d4594efc02d6e23d15a0b798edcf6462aa9106af6 xen-3.0.2-r1.ebuild 2973
+EBUILD xen-3.0.2-r1.ebuild 2513 RMD160 de1bf27d680c6fca08040d08595ce8aebf3e71d2 SHA1 1baf5e3e35ee86d8e958b8d32b1fb12207f8a97d SHA256 b5f532a44bdcdb4258e89abd8a9752a3b534d9a17a3a7c9bfc4a40e052691f5b
+MD5 a5d26c8799ac4141a64d7bdf05213ab2 xen-3.0.2-r1.ebuild 2513
+RMD160 de1bf27d680c6fca08040d08595ce8aebf3e71d2 xen-3.0.2-r1.ebuild 2513
+SHA256 b5f532a44bdcdb4258e89abd8a9752a3b534d9a17a3a7c9bfc4a40e052691f5b xen-3.0.2-r1.ebuild 2513
EBUILD xen-3.0.2.ebuild 2593 RMD160 b39ee760f76df5a62c1bc259b0b87eba40a4b336 SHA1 4d3efa5f481f588360205fd9e086e2890e2af8fa SHA256 d8c525fde493ac1110957d5ff13fbb3bd4dd57ebe2ab5605192176ddc4b055b3
MD5 c8f3f22e2059173683d3d5495c7e8f04 xen-3.0.2.ebuild 2593
RMD160 b39ee760f76df5a62c1bc259b0b87eba40a4b336 xen-3.0.2.ebuild 2593
diff --git a/app-emulation/xen/xen-3.0.2-r1.ebuild b/app-emulation/xen/xen-3.0.2-r1.ebuild
index 9ea9e82..145446f 100644
--- a/app-emulation/xen/xen-3.0.2-r1.ebuild
+++ b/app-emulation/xen/xen-3.0.2-r1.ebuild
@@ -4,21 +4,15 @@
inherit mount-boot flag-o-matic
-DESCRIPTION="The Xen virtual machine monitor"
-HOMEPAGE="http://xen.sourceforge.net"
-if [[ ${PV} == *_p* ]]; then
- XEN_UNSTABLE="xen-unstable-${PV#*_p}"
- SRC_URI="mirror://gentoo/${XEN_UNSTABLE}.tar.bz2"
- S="${WORKDIR}/${XEN_UNSTABLE}"
-else
- SRC_URI="http://www.cl.cam.ac.uk/Research/SRG/netos/xen/downloads/${P}-src.tgz"
- S="${WORKDIR}/xen-${PV}"
-fi
+DESCRIPTION="The Xen hypervisor"
+HOMEPAGE="http://www.xensource.com/xen/xen/"
+SRC_URI="http://www.cl.cam.ac.uk/Research/SRG/netos/xen/downloads/${P}-src.tgz"
+S="${WORKDIR}/xen-${PV}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="debug custom-cflags pae hardened"
+IUSE="debug custom-cflags pae"
DEPEND="sys-devel/dev86"
RDEPEND=""
@@ -27,9 +21,9 @@ RESTRICT="test"
pkg_setup() {
if [[ -z ${XEN_TARGET_ARCH} ]] ; then
- if use x86 ; then
+ if use x86; then
export XEN_TARGET_ARCH="x86_32"
- elif use amd64 ; then
+ elif use amd64; then
export XEN_TARGET_ARCH="x86_64"
else
die "Unsupported architecture!"
@@ -65,7 +59,7 @@ src_compile() {
use pae && myopt="${myopt} pae=y"
if use custom-cflags; then
- filter-flags -fPIE -fstack-protector
+ filter-flags -fPIE -fstack-protector -fstack-protector-all
else
unset CFLAGS
fi
@@ -80,11 +74,6 @@ src_install() {
make DESTDIR="${D}" ${myopt} install-xen \
|| die "install failed"
-
- # for upstream change tracking
- if [[ -n ${XEN_UNSTABLE} ]]; then
- dodoc "${S}"/XEN-VERSION
- fi
}
pkg_postinst() {
@@ -95,13 +84,6 @@ pkg_postinst() {
einfo "Note: xen tools have been moved to app-emulation/xen-tools;"
einfo "you need to install that package to manage your domains."
- if [[ -n ${XEN_UNSTABLE} ]]; then
- echo
- einfo "This is a snapshot of the xen-unstable tree."
- einfo "Please report bugs in xen itself (and not the packaging) to"
- einfo "bugzilla.xensource.com"
- fi
-
if use pae; then
echo
einfo "This is a PAE build of Xen. It will *only* boot PAE kernels!"