summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2010-06-09 21:54:46 +0000
committerThilo Bangert <bangert@gentoo.org>2010-06-09 21:54:46 +0000
commite52f51115892a76b0e0a1fcce52c73bada3ce4d7 (patch)
tree30e680c478e3feffe6c85473224aed1bf05e2fc7
parentUCT IMS client (diff)
downloadbangert-e52f51115892a76b0e0a1fcce52c73bada3ce4d7.tar.gz
bangert-e52f51115892a76b0e0a1fcce52c73bada3ce4d7.tar.bz2
bangert-e52f51115892a76b0e0a1fcce52c73bada3ce4d7.zip
gypsy
svn path=/ebuilds/; revision=111
-rw-r--r--sci-geosciences/gypsy/ChangeLog10
-rw-r--r--sci-geosciences/gypsy/Manifest4
-rw-r--r--sci-geosciences/gypsy/gypsy-0.8.ebuild28
-rw-r--r--sci-geosciences/gypsy/metadata.xml22
4 files changed, 64 insertions, 0 deletions
diff --git a/sci-geosciences/gypsy/ChangeLog b/sci-geosciences/gypsy/ChangeLog
new file mode 100644
index 0000000..80e03e3
--- /dev/null
+++ b/sci-geosciences/gypsy/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-geosciences/gypsy
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*gypsy-0.8 (09 Jun 2010)
+
+ 09 Jun 2010; Thilo Bangert <bangert@gentoo.org> +gypsy-0.8.ebuild,
+ +metadata.xml:
+ ebuild by myself
+
diff --git a/sci-geosciences/gypsy/Manifest b/sci-geosciences/gypsy/Manifest
new file mode 100644
index 0000000..32f67a1
--- /dev/null
+++ b/sci-geosciences/gypsy/Manifest
@@ -0,0 +1,4 @@
+DIST gypsy-0.8.tar.gz 488063 RMD160 563f5788d5426d355e51e33faf219cea0bdf3bfb SHA1 b34bb550108dd7ca0f8eff1e96fb07e4a8109efd SHA256 1986a58189614a950725c3bc7d05faa3b84695f35cb696326f340ef87fc3acaa
+EBUILD gypsy-0.8.ebuild 594 RMD160 0b22095cbb5ee089da4ab61bd8b393fbca0058e5 SHA1 dba39b0695192aaf17e0b884a20d4f2a8c6504dd SHA256 6595eb2000598b7940ecc69802019ea02f63af77ff4c1511936f28bdd2116c4b
+MISC ChangeLog 254 RMD160 1ea040c7c1ddf708e55aa860b8a285b515fab970 SHA1 eeb9611f6f9653a1c0ee7deece20720358075b91 SHA256 8324eb8223a1bf08f1e312d12736ecd8328bdb2c30e407f029ffe8146a0ac9eb
+MISC metadata.xml 1722 RMD160 2b7b6f2421d8dbbc060415750942be6e0dee8452 SHA1 a1da565037d5ad8afec78c3c2deb4814e7e018f9 SHA256 bd2aba2dedc8c84597bef99deaf2d0287eaa8dc9d2aa559e33136b2a72c80d91
diff --git a/sci-geosciences/gypsy/gypsy-0.8.ebuild b/sci-geosciences/gypsy/gypsy-0.8.ebuild
new file mode 100644
index 0000000..fa24dd3
--- /dev/null
+++ b/sci-geosciences/gypsy/gypsy-0.8.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+DESCRIPTION="Gypsy is a GPS multiplexing daemon."
+HOMEPAGE="http://gypsy.freedesktop.org/wiki/"
+SRC_URI="http://gypsy.freedesktop.org/releases/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="bluetooth"
+
+RDEPEND="sys-apps/dbus
+ dev-libs/glib:2
+ bluetooth? ( net-wireless/bluez )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ econf $(use_enable bluetooth )
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+}
diff --git a/sci-geosciences/gypsy/metadata.xml b/sci-geosciences/gypsy/metadata.xml
new file mode 100644
index 0000000..eb84513
--- /dev/null
+++ b/sci-geosciences/gypsy/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>bangert@gentoo.org</email>
+</maintainer>
+<longdescription lang="en">
+Without some sort of multiplexing system, a GPS device can only safely be accessed by one client. In a server situation this may not cause any problems, but on modern desktop which could potentially have multiple location aware devices, this could be an issue.
+
+Gypsy hides the tricky details of parsing NMEA from the client applications, passing the data as simple values for the clients to use.
+
+Gypsy uses D-Bus to notify clients about location changes, sitting on the system bus, issuing signals as the GPS data changes. This design allows clients to only be notified about the changes they care about and ignore the rest. Gypsy has fine grained signals, so a client only interested in position changes will not be woken up for any other changes like, for example, satellite detail changes.
+
+Gypsy is designed to be usable on all manner of systems, from low powered devices (such as Nokia N810 and Openmoko Neo) to regular high powered desktop systems. As the signals it emits are fine grained applications are woken up only when they absolutely need to be, keeping power requirements to a minimum.
+
+Gypsy was designed to fix the numerous design flaws found in GPSD.
+
+Included with Gypsy is libgypsy which is a GObject based C wrapper for the D-Bus API making writing clients very simple, although any language with D-Bus bindings can be used to write a Gypsy client (See simple-gps-python.py in the Gypsy sources for an example written in Python)
+</longdescription>
+</pkgmetadata>
+