summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2005-12-04 22:30:00 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2005-12-04 22:30:00 +0000
commit63c8fed2802bdb8aed9a48c2dd3a42d51d0802b7 (patch)
treec413e9484c19bce5c8cb16ba9701ab091dd9d3d5 /net-libs
parentDeleted outdated gcc snapshot (diff)
downloadbetelgeuse-63c8fed2802bdb8aed9a48c2dd3a42d51d0802b7.tar.gz
betelgeuse-63c8fed2802bdb8aed9a48c2dd3a42d51d0802b7.tar.bz2
betelgeuse-63c8fed2802bdb8aed9a48c2dd3a42d51d0802b7.zip
Added libssh2
svn path=/; revision=98
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libssh2/Manifest3
-rw-r--r--net-libs/libssh2/files/digest-libssh2-0.121
-rw-r--r--net-libs/libssh2/files/libssh2-0.12-banner-wait.patch23
-rw-r--r--net-libs/libssh2/libssh2-0.12.ebuild23
4 files changed, 50 insertions, 0 deletions
diff --git a/net-libs/libssh2/Manifest b/net-libs/libssh2/Manifest
new file mode 100644
index 0000000..36dd77a
--- /dev/null
+++ b/net-libs/libssh2/Manifest
@@ -0,0 +1,3 @@
+MD5 b2ed5c2b1c61718cc94be21e8e3a1e3f files/digest-libssh2-0.12 64
+MD5 2d8553d8736bc8d6ff6cb9676213e604 files/libssh2-0.12-banner-wait.patch 675
+MD5 e83aa95a24a1681a167ea9866eed92fd libssh2-0.12.ebuild 513
diff --git a/net-libs/libssh2/files/digest-libssh2-0.12 b/net-libs/libssh2/files/digest-libssh2-0.12
new file mode 100644
index 0000000..b2a5ada
--- /dev/null
+++ b/net-libs/libssh2/files/digest-libssh2-0.12
@@ -0,0 +1 @@
+MD5 4071c9739614acec0954f14c974ba93c libssh2-0.12.tar.gz 138591
diff --git a/net-libs/libssh2/files/libssh2-0.12-banner-wait.patch b/net-libs/libssh2/files/libssh2-0.12-banner-wait.patch
new file mode 100644
index 0000000..6b9b8ed
--- /dev/null
+++ b/net-libs/libssh2/files/libssh2-0.12-banner-wait.patch
@@ -0,0 +1,23 @@
+diff -urb libssh2-0.11/src/session.c libssh2-0.11-jmk/src/session.c
+--- libssh2-0.11/src/session.c 2005-06-27 17:24:29.000000000 -0500
++++ libssh2-0.11-jmk/src/session.c 2005-11-10 20:27:34.000000000 -0600
+@@ -95,12 +95,19 @@
+ {
+ char banner[256];
+ int banner_len = 0;
++ int wait_count = 0;
+
+ while ((banner_len < sizeof(banner)) &&
+ ((banner_len == 0) || (banner[banner_len-1] != '\n'))) {
+ char c = '\0';
+ int ret;
+
++ wait_count++;
++
++ /* If server is not responding, don't wait in loop forever */
++ if (wait_count > 1000)
++ return 1;
++
+ ret = recv(session->socket_fd, &c, 1, LIBSSH2_SOCKET_RECV_FLAGS(session));
+
+ if ((ret < 0) && (ret != EAGAIN)) {
diff --git a/net-libs/libssh2/libssh2-0.12.ebuild b/net-libs/libssh2/libssh2-0.12.ebuild
new file mode 100644
index 0000000..c660e8c
--- /dev/null
+++ b/net-libs/libssh2/libssh2-0.12.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils base
+
+DESCRIPTION="Library implementing the SSH2 protocol."
+HOMEPAGE="http://www.libssh2.org"
+SRC_URI="mirror://sourceforge/libssh2/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="dev-libs/openssl sys-libs/zlib"
+
+PATCHES="${FILESDIR}/${P}-banner-wait.patch"
+
+src_install() {
+ make DESTDIR=${D} install || die "running make install failed"
+ dodoc README
+}