summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2015-11-18 23:58:43 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2015-11-18 23:58:43 +0000
commit8cdf2deb9b28bb8c7507ed0199a475870d950713 (patch)
tree6921f7b14b78b6182a807005fd7feef81f3d5f64
parentdev-libs/starpu: version bump (diff)
downloadbicatali-8cdf2deb9b28bb8c7507ed0199a475870d950713.tar.gz
bicatali-8cdf2deb9b28bb8c7507ed0199a475870d950713.tar.bz2
bicatali-8cdf2deb9b28bb8c7507ed0199a475870d950713.zip
sci-libs/netcdf-fortran: version bump
Package-Manager: portage-2.2.25
-rw-r--r--sci-libs/netcdf-fortran/Manifest1
-rw-r--r--sci-libs/netcdf-fortran/metadata.xml14
-rw-r--r--sci-libs/netcdf-fortran/netcdf-fortran-4.4.2.ebuild53
3 files changed, 68 insertions, 0 deletions
diff --git a/sci-libs/netcdf-fortran/Manifest b/sci-libs/netcdf-fortran/Manifest
new file mode 100644
index 0000000..8883ae9
--- /dev/null
+++ b/sci-libs/netcdf-fortran/Manifest
@@ -0,0 +1 @@
+DIST netcdf-fortran-4.4.2.tar.gz 1007725 SHA256 ad6249b6062df6f62f81d1cb2a072e3a4c595f27f11fe0c5a79726d1dad3143b SHA512 5479f369edd31b593a5dfa540edf4fe19890c26e8a6fcd23c3f8696eccc81de9f7ee8c85356f1da4891d71f1bf095fd0e0c74e4597b259bae0258e6ccf1b31d0 WHIRLPOOL 707c06a088fdde17d7b191e71ecedc67bab8646f1241c3220e7c7433e6cf04ee57a3974df9a6fee354080eb0c883e8c2fce6cd309b96a2a7f49cf22ebe4d1e11
diff --git a/sci-libs/netcdf-fortran/metadata.xml b/sci-libs/netcdf-fortran/metadata.xml
new file mode 100644
index 0000000..1c9a839
--- /dev/null
+++ b/sci-libs/netcdf-fortran/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ NetCDF (network Common Data Form) is an interface for scientific
+ data access and a freely-distributed software library that provides an
+ implementation of the interface. The netCDF library also defines a
+ machine-independent format for representing scientific data.
+ Together, the interface, library, and format support the creation,
+ access, and sharing of scientific data.
+ This is the FORTRAN 77 and 90 library on top of the C library.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-libs/netcdf-fortran/netcdf-fortran-4.4.2.ebuild b/sci-libs/netcdf-fortran/netcdf-fortran-4.4.2.ebuild
new file mode 100644
index 0000000..fea4f21
--- /dev/null
+++ b/sci-libs/netcdf-fortran/netcdf-fortran-4.4.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+FORTRAN_STANDARD="77 90 2003"
+
+inherit autotools-utils fortran-2
+
+DESCRIPTION="Scientific library and interface for array oriented data access"
+HOMEPAGE="http://www.unidata.ucar.edu/software/netcdf/"
+SRC_URI="ftp://ftp.unidata.ucar.edu/pub/netcdf/${P}.tar.gz"
+
+LICENSE="UCAR-Unidata"
+SLOT="0/5"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples static-libs"
+
+RDEPEND="sci-libs/netcdf"
+DEPEND="${RDEPEND}
+ dev-lang/cfortran
+ doc? ( app-doc/doxygen[dot] )
+"
+
+src_prepare() {
+ # use system cfortran
+ rm libsrc/cfortran.h || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --docdir="${EPREFIX}/usr/share/doc/${PF}"
+ --disable-extra-example-tests
+ --enable-f03
+ $(use_enable doc dot)
+ $(use_enable doc doxygen)
+ )
+ autotools-utils_src_configure
+}
+
+src_test() {
+ autotools-utils_src_test -j1
+}
+
+src_install() {
+ autotools-utils_src_install
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}