summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Savchenko <bircoph@gentoo.org>2021-12-15 05:59:33 +0300
committerAndrew Savchenko <bircoph@gentoo.org>2021-12-15 06:31:33 +0300
commitbf581c33b7b59fe862c4c023d833e49d0ee50d76 (patch)
treeb13f044bae7b92e4c658cba00806f611a1ad6acc
parentapp-i18n/uim: drop bootstrap version (diff)
downloadbircoph-bf581c33b7b59fe862c4c023d833e49d0ee50d76.tar.gz
bircoph-bf581c33b7b59fe862c4c023d833e49d0ee50d76.tar.bz2
bircoph-bf581c33b7b59fe862c4c023d833e49d0ee50d76.zip
app-text/cuneiform: in the main tree now
Signed-off-by: Andrew Savchenko <bircoph@gentoo.org>
-rw-r--r--app-text/cuneiform/Manifest1
-rw-r--r--app-text/cuneiform/cuneiform-1.1.0-r2.ebuild62
-rw-r--r--app-text/cuneiform/files/abs-types_cast.patch14
-rw-r--r--app-text/cuneiform/files/c-assert.diff83
-rw-r--r--app-text/cuneiform/files/charset-signedness.patch90
-rw-r--r--app-text/cuneiform/files/cuneiform.1166
-rw-r--r--app-text/cuneiform/files/graphicsmagick.diff43
-rw-r--r--app-text/cuneiform/files/libm.diff25
-rw-r--r--app-text/cuneiform/files/minmax.patch59
-rw-r--r--app-text/cuneiform/metadata.xml14
-rw-r--r--dev-util/symlookup/Manifest1
-rw-r--r--dev-util/symlookup/metadata.xml12
-rw-r--r--dev-util/symlookup/symlookup-0.5.2.ebuild26
-rw-r--r--dev-util/symlookup/symlookup-9999.ebuild27
-rw-r--r--profiles/categories1
15 files changed, 0 insertions, 624 deletions
diff --git a/app-text/cuneiform/Manifest b/app-text/cuneiform/Manifest
deleted file mode 100644
index 48272d2..0000000
--- a/app-text/cuneiform/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST cuneiform-linux-1.1.0.tar.bz2 26388511 SHA256 577e0d054de72086c33b4e8ae15033657776509b9a7af6eb272888eefcbdbbad SHA512 82395f43aae9f4b1301fb47b8d46613affb0ccb09c92d64ac3d77a593618cd56824225b0306176e4d8b90eb468abf6b9f534e97f28dabd4bba81cb7977b79b56 WHIRLPOOL 90823a056dbf61738fbd8cd7cdd739e32bd571f39bab3ff8e8548cf6359c683a1f0f481cf416292504ee4bb277ed7d5b1edb98f5741a6cf97877cacc2646a70f
diff --git a/app-text/cuneiform/cuneiform-1.1.0-r2.ebuild b/app-text/cuneiform/cuneiform-1.1.0-r2.ebuild
deleted file mode 100644
index faed1b8..0000000
--- a/app-text/cuneiform/cuneiform-1.1.0-r2.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils versionator
-
-PV_MAJ=$(get_version_component_range 1-2)
-MY_P=${PN}-linux-${PV}
-
-DESCRIPTION="An enterprise quality OCR engine by Cognitive Technologies"
-HOMEPAGE="https://launchpad.net/cuneiform-linux"
-SRC_URI="https://launchpad.net/${PN}-linux/${PV_MAJ}/${PV_MAJ}/+download/${MY_P}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-IUSE="debug graphicsmagick"
-
-RDEPEND="
- !graphicsmagick? ( media-gfx/imagemagick:= )
- graphicsmagick? ( media-gfx/graphicsmagick:= )"
-DEPEND="${RDEPEND}"
-
-S=${WORKDIR}/${MY_P}
-
-DOCS=( readme.txt )
-PATCHES=(
- "${FILESDIR}/c-assert.diff"
- "${FILESDIR}/libm.diff"
- "${FILESDIR}/abs-types_cast.patch"
- "${FILESDIR}/charset-signedness.patch"
- "${FILESDIR}/minmax.patch"
-)
-
-src_prepare(){
- if use graphicsmagick; then
- PATCHES+=( "${FILESDIR}/graphicsmagick.diff" )
- else
- sed -e 's/GraphicsMagick/ImageMagick/g' \
- -e 's/fBgm/fBImageMagick/g' \
- "${FILESDIR}/${PN}.1" > "${PN}.1" || die
- fi
- cmake-utils_src_prepare
-
- # respect LDFLAGS
- sed -i 's:\(set[(]CMAKE_SHARED_LINKER_FLAGS "[^"]*\):\1 $ENV{LDFLAGS}:' \
- cuneiform_src/CMakeLists.txt || die "failed to sed for LDFLAGS"
-
- # Fix automagic dependencies / linking
- if use graphicsmagick; then
- sed -i "s:find_package(ImageMagick COMPONENTS Magick++):#DONOTFIND:" \
- cuneiform_src/CMakeLists.txt \
- || die "Sed for ImageMagick automagic dependency failed."
- fi
-}
-
-src_install() {
- cmake-utils_src_install
- doman "${PN}.1"
-}
diff --git a/app-text/cuneiform/files/abs-types_cast.patch b/app-text/cuneiform/files/abs-types_cast.patch
deleted file mode 100644
index 578553e..0000000
--- a/app-text/cuneiform/files/abs-types_cast.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-std::abs() overload is not happy with int32_t
---- cuneiform-linux-1.1.0/cuneiform_src/Kern/rimage/sources/main/cricontrol.cpp.orig 2011-04-19 16:49:57.000000000 +0400
-+++ cuneiform-linux-1.1.0/cuneiform_src/Kern/rimage/sources/main/cricontrol.cpp 2017-09-05 12:55:11.908311163 +0300
-@@ -594,8 +594,8 @@
- return FALSE;
- }
-
-- wNewHeight = (mbMarginsFlag ? abs(mrMargins.rmBottomMarg - mrMargins.rmTopMarg) : mpSourceDIB->GetLinesNumber());
-- wNewWidth = (mbMarginsFlag ? abs(mrMargins.rmLeftMarg - mrMargins.rmRightMarg) : mpSourceDIB->GetLineWidth());
-+ wNewHeight = (mbMarginsFlag ? abs(static_cast<int>(mrMargins.rmBottomMarg - mrMargins.rmTopMarg)) : mpSourceDIB->GetLinesNumber());
-+ wNewWidth = (mbMarginsFlag ? abs(static_cast<int>(mrMargins.rmLeftMarg - mrMargins.rmRightMarg)) : mpSourceDIB->GetLineWidth());
- mpSourceDIB->GetResolutionDPM( &wXResolution, &wYResolution);
-
- if ( !mpDestinationDIB->CreateDIBBegin( wNewWidth, wNewHeight, BitCount) )
diff --git a/app-text/cuneiform/files/c-assert.diff b/app-text/cuneiform/files/c-assert.diff
deleted file mode 100644
index 0abf1b1..0000000
--- a/app-text/cuneiform/files/c-assert.diff
+++ /dev/null
@@ -1,83 +0,0 @@
-Description: Use the standard C assert() macro, rather than custom Cuneiform
- one.
-Author: Jakub Wilk <jwilk@debian.org>
-Forwarded: no
-Last-Update: 2011-04-30
-
---- a/cuneiform_src/Kern/lns32/src/myassert.h
-+++ b/cuneiform_src/Kern/lns32/src/myassert.h
-@@ -60,6 +60,8 @@
- BC++, v3.1 was used as base
- */
-
-+#include <assert.h>
-+
- #ifdef __MYASSERT_H
- # Error: Do not specify MYASSERT.H directly - use SLANG.H. Postnikov.
- #else
-@@ -73,45 +75,3 @@
- #else
- # define WRONG() (assert(0),FALSE)
- #endif
--
--#ifdef __cplusplus
--extern "C" {
--#endif
--
--#ifndef MY_DEBUG_LEVEL
-- void __assertfail( char *__msg,
-- char *__cond,
-- char *__file,
-- int __line);
--#else
-- void my_assert_fail(const char *cond, const char *__file, int __line);
--#endif
--
--
--#ifdef __cplusplus
--}
--#endif
--
--#undef assert
--
--#ifdef NDEBUG
--# define assert(p) ((void)0)
--#else
--# ifdef _Windows
--# define _ENDL
--# else
--# define _ENDL "\n"
--# endif
-- #ifdef MY_DEBUG_LEVEL
-- # define assert(p) \
-- ((p)) ? \
-- (void)0 : \
-- (void) my_assert_fail( #p, __FILE__, __LINE__)
-- #else
-- # define assert(p) \
-- ((p) ? \
-- (void)0 : \
-- (void) __assertfail( "Assertion failed: %s, file %s, line %d" _ENDL, \
-- #p, __FILE__, __LINE__ ) )
-- #endif
--#endif
---- a/cuneiform_src/Kern/std/CMakeLists.txt
-+++ b/cuneiform_src/Kern/std/CMakeLists.txt
-@@ -3,7 +3,6 @@
- add_library(std32 ${LIBTYPE}
- src/std.cpp
- #src/Std.rc
--src/stdassrt.cpp
- src/stdbits.cpp
- src/stdconsl.cpp
- src/stderror.cpp
---- a/cuneiform_src/Kern/lns32/CMakeLists.txt
-+++ b/cuneiform_src/Kern/lns32/CMakeLists.txt
-@@ -14,7 +14,6 @@
- src/lns.cpp
- src/lnscheck.cpp
- src/lnsini.cpp
--src/myassert.cpp
- src/procline.cpp
- src/puanso.cpp
- src/rbambuk.cpp
diff --git a/app-text/cuneiform/files/charset-signedness.patch b/app-text/cuneiform/files/charset-signedness.patch
deleted file mode 100644
index 983af11..0000000
--- a/app-text/cuneiform/files/charset-signedness.patch
+++ /dev/null
@@ -1,90 +0,0 @@
-char may be signed on unsigned depending on arch and compiler,
-since upper table needs to be set for cp12* charsets, we need
-unsigned char unconditionally
---- cuneiform-linux-1.1.0/cuneiform_src/Kern/include/utf8-tables.h.orig 2011-04-19 16:49:57.000000000 +0400
-+++ cuneiform-linux-1.1.0/cuneiform_src/Kern/include/utf8-tables.h 2017-09-05 16:53:26.627848057 +0300
-@@ -68,7 +68,7 @@
- #endif
-
-
--const char win1250_to_utf8[][4] = {
-+const unsigned char win1250_to_utf8[][4] = {
- {0, 0, 0, 0},
- {1, 0, 0, 0},
- {2, 0, 0, 0},
-@@ -328,7 +328,7 @@
- };
-
-
--const char win1251_to_utf8[][4] = {
-+const unsigned char win1251_to_utf8[][4] = {
- {0, 0, 0, 0},
- {1, 0, 0, 0},
- {2, 0, 0, 0},
-@@ -587,7 +587,7 @@
- {209, 143, 0, 0},
- };
-
--const char win1252_to_utf8[][4] = {
-+const unsigned char win1252_to_utf8[][4] = {
- {0, 0, 0, 0},
- {1, 0, 0, 0},
- {2, 0, 0, 0},
-@@ -847,7 +847,7 @@
- };
-
-
--const char win1254_to_utf8[][4] = {
-+const unsigned char win1254_to_utf8[][4] = {
- {0, 0, 0, 0},
- {1, 0, 0, 0},
- {2, 0, 0, 0},
-@@ -1107,7 +1107,7 @@
- };
-
-
--const char win1257_to_utf8[][4] = {
-+const unsigned char win1257_to_utf8[][4] = {
- {0, 0, 0, 0},
- {1, 0, 0, 0},
- {2, 0, 0, 0},
---- cuneiform-linux-1.1.0/cuneiform_src/Kern/rout/src/codetables.cpp.orig 2017-09-05 17:49:05.000000000 +0300
-+++ cuneiform-linux-1.1.0/cuneiform_src/Kern/rout/src/codetables.cpp 2017-09-05 17:49:38.263100712 +0300
-@@ -937,13 +937,13 @@
- * codepage.
- */
-
--const char * getUTF8Str(const unsigned char in, const int codepage) {
-+const unsigned char * getUTF8Str(const unsigned char in, const int codepage) {
- switch(codepage) {
- case 1250 : return win1250_to_utf8[in];
- case 1251 : return win1251_to_utf8[in];
- case 1252 : return win1252_to_utf8[in];
- case 1254 : return win1254_to_utf8[in];
- case 1257 : return win1257_to_utf8[in];
-- default : return "?";
-+ default : return reinterpret_cast<const unsigned char*>("?");
- }
- }
---- cuneiform-linux-1.1.0/cuneiform_src/Kern/rout/src/rout_own.h.orig 2011-04-19 16:49:57.000000000 +0400
-+++ cuneiform-linux-1.1.0/cuneiform_src/Kern/rout/src/rout_own.h 2017-09-05 17:22:32.078758198 +0300
-@@ -458,7 +458,7 @@
- void ResetCodeTables();
- Bool UpdateActiveCodeTable();
- long GetCodePage();
--const char * getUTF8Str(const unsigned char in, const int codepage);
-+const unsigned char * getUTF8Str(const unsigned char in, const int codepage);
-
- //*****************************************************************
- // Rout.cpp
---- cuneiform-linux-1.1.0/cuneiform_src/Kern/rout/src/text.cpp.orig 2011-04-19 16:49:57.000000000 +0400
-+++ cuneiform-linux-1.1.0/cuneiform_src/Kern/rout/src/text.cpp 2017-09-05 17:23:01.388753649 +0300
-@@ -310,7 +310,7 @@
- *gMemCur++ = c2;
- }
- else {
-- const char *utfchar;
-+ const unsigned char *utfchar;
- utfchar = getUTF8Str((char )c2, GetCodePage());
- int i;
- for(i=0; utfchar[i] != '\0' ;i++){
diff --git a/app-text/cuneiform/files/cuneiform.1 b/app-text/cuneiform/files/cuneiform.1
deleted file mode 100644
index 93fd250..0000000
--- a/app-text/cuneiform/files/cuneiform.1
+++ /dev/null
@@ -1,166 +0,0 @@
-.TH CUNEIFORM 1 "2010-09-14" "1.0.0" "multi-language OCR system"
-
-.SH NAME
-cuneiform \- multi-language OCR system
-
-.SH SYNOPSIS
-\fBcuneiform\fR [\-\-dotmatrix] [\-\-fax] [\-\-singlecolumn] [\-f \fIformat\fR] [\-l \fIlanguage\fR] [\-o \fIoutput\fR] \fIinput\fR
-
-.SH DESCRIPTION
-Cuneiform is an OCR system. In addition to text recognition it also does layout analysis and text format recognition. Cuneiform supports several languages.
-
-.SH OPTIONS
-.IP "\fB\-\-dotmatrix\fR" 4
-Use recognition mode optimized for text printed with a dot matrix printer.
-.IP "\fB\-\-fax\fR" 4
-Use recognition mode optimized for text that has been faxed.
-.IP "\fB\-\-singlecolumn\fR" 4
-Disable page layout analysis and assumes that the image consists of only one column of text.
-.IP "\fB\-f\fR \fIformat\fR" 4
-Select output format. The following formats are available:
-\fBhtml\fR (HTML format),
-\fBhocr\fR (hOCR HTML format),
-\fBnative\fR (native Cuneiform 2000),
-\fBrtf\fR (RTF format),
-\fBsmarttext\fR (plain text with TeX paragraphs),
-\fBtext\fR (plain text).
-The default is plain text.
-.IP "\fB\-l\fR \fIlanguage\fR" 4
-By default Cuneiform recognizes English text. To change the language use the command line switch \fB\-l\fR followed by a language code (typically an ISO 639-2 three-letter code). The following languages are supported:
-.TS
-ll.
-T{
-\fBbul\fR
-T} T{
-Bulgarian
-T}
-T{
-\fBcze\fR
-T} T{
-Czech
-T}
-T{
-\fBdan\fR
-T} T{
-Danish
-T}
-T{
-\fBdut\fR
-T} T{
-Dutch
-T}
-T{
-\fBeng\fR
-T} T{
-English
-T}
-T{
-\fBest\fR
-T} T{
-Estonian
-T}
-T{
-\fBfra\fR
-T} T{
-French
-T}
-T{
-\fBger\fR
-T} T{
-German
-T}
-T{
-\fBhrv\fR
-T} T{
-Croatian
-T}
-T{
-\fBhun\fR
-T} T{
-Hungarian
-T}
-T{
-\fBita\fR
-T} T{
-Italian
-T}
-T{
-\fBlav\fR
-T} T{
-Latvian
-T}
-T{
-\fBlit\fR
-T} T{
-Lithuanian
-T}
-T{
-\fBpol\fR
-T} T{
-Polish
-T}
-T{
-\fBpor\fR
-T} T{
-Portugese
-T}
-T{
-\fBrum\fR
-T} T{
-Romanian
-T}
-T{
-\fBrus\fR
-T} T{
-Russian
-T}
-T{
-\fBruseng\fR
-T} T{
-mixed Russian/English
-T}
-T{
-\fBslv\fR
-T} T{
-Slovenian
-T}
-T{
-\fBspa\fR
-T} T{
-Spanish
-T}
-T{
-\fBsrp\fR
-T} T{
-Serbian
-T}
-T{
-\fBswe\fR
-T} T{
-Swedish
-T}
-T{
-\fBtur\fR
-T} T{
-Turkish
-T}
-T{
-\fBukr\fR
-T} T{
-Ukrainian
-T}
-.TE
-.
-.IP "\fB\-o\fR \fIoutput\fR" 4
-If you do not define an output file with the \fB\-o\fR switch, Cuneiform writes the result to a file \[oq]cuneiform-out.\fIformat\fR\[cq]. The file extension depends on your output format.
-
-.SH INPUT FORMAT
-Cuneiform can process any single-page image that GraphicsMagick knows how to open. Please consult the \fBgm\fR(1) manual page for the comprehensive list of supported image formats.
-
-.SH HOMEPAGE
-More information about cuneiform can be found at <\fIhttp://launchpad.net/cuneiform-linux/\fR>.
-
-.SH AUTHOR
-cuneiform was written by Cognitive Technologies and Jussi Pakkanen <\fIjpakkane@gmail.com\fR>.
-.PP
-This manual page was written by Daniel Baumann <\fIdaniel@debian.org\fR>, for the Debian project (but may be used by others).
diff --git a/app-text/cuneiform/files/graphicsmagick.diff b/app-text/cuneiform/files/graphicsmagick.diff
deleted file mode 100644
index 265190f..0000000
--- a/app-text/cuneiform/files/graphicsmagick.diff
+++ /dev/null
@@ -1,43 +0,0 @@
-Description: Use GraphicsMagick instead of ImageMagick.
-Author: Jakub Wilk <jwilk@debian.org>
-Forwarded: not-needed
-Last-Update: 2011-01-21
-
---- a/cuneiform_src/cli/cuneiform-cli.cpp
-+++ b/cuneiform_src/cli/cuneiform-cli.cpp
-@@ -341,6 +341,10 @@
- Magick::InitializeMagick("");
- #endif
-
-+#ifdef USE_MAGICK
-+ Magick::InitializeMagick("");
-+#endif
-+
- dib = read_file(infilename);
- if(!dib) // Error msg is already printed so just get out.
- return 1;
---- a/cuneiform_src/CMakeLists.txt
-+++ b/cuneiform_src/CMakeLists.txt
-@@ -34,15 +34,16 @@
-
- add_definitions(-D_USE_RVERLINE_)
-
--find_package(ImageMagick COMPONENTS Magick++)
--if(ImageMagick_Magick++_FOUND)
-+include(FindPkgConfig)
-+pkg_check_modules(GraphicsMagick QUIET GraphicsMagick++)
-+if(GraphicsMagick_FOUND)
- set(USE_MAGICK TRUE)
-- include_directories(${ImageMagick_Magick++_INCLUDE_DIR})
-- message(STATUS "ImageMagick++ found at ${ImageMagick_Magick++_INCLUDE_DIR}.")
-- set(cli_ext_libs ${ImageMagick_Magick++_LIBRARY})
-+ include_directories(${GraphicsMagick_INCLUDE_DIRS})
-+ message(STATUS "GraphicsMagick++ found at ${GraphicsMagick_INCLUDE_DIRS}.")
-+ set(cli_ext_libs ${GraphicsMagick_LIBRARIES})
- else()
- set(USE_MAGICK FALSE)
-- message(STATUS "ImageMagick++ not found. Only uncompressed BMP images supported.")
-+ message(STATUS "GraphicsMagick++ not found. Only uncompressed BMP images supported.")
- endif()
-
- configure_file(${CMAKE_CURRENT_SOURCE_DIR}/Kern/include/config.h.in ${CMAKE_CURRENT_BINARY_DIR}/Kern/include/config.h)
diff --git a/app-text/cuneiform/files/libm.diff b/app-text/cuneiform/files/libm.diff
deleted file mode 100644
index 0ab16d5..0000000
--- a/app-text/cuneiform/files/libm.diff
+++ /dev/null
@@ -1,25 +0,0 @@
-Description: Link the leo and r35 libraries with libm.
-Author: Dmitrijs Ledkovs <dmitrij.ledkov@ubuntu.com>, Jakub Wilk <jwilk@debian.org>
-Forwarded: no
-Last-Update: 2011-07-04
-
---- a/cuneiform_src/Kern/leo/CMakeLists.txt
-+++ b/cuneiform_src/Kern/leo/CMakeLists.txt
-@@ -23,6 +23,7 @@
- msk32
- r3532
- std32
-+m
- )
-
- library_hook(leo32)
---- a/cuneiform_src/Kern/r35/CMakeLists.txt
-+++ b/cuneiform_src/Kern/r35/CMakeLists.txt
-@@ -3,6 +3,6 @@
-
- set_property(TARGET r3532 PROPERTY COMPILE_DEFINITIONS __R35__)
-
--target_link_libraries(r3532 mmx32 std32 cfcompat)
-+target_link_libraries(r3532 mmx32 std32 cfcompat m)
-
- library_hook(r3532)
diff --git a/app-text/cuneiform/files/minmax.patch b/app-text/cuneiform/files/minmax.patch
deleted file mode 100644
index 625dc9b..0000000
--- a/app-text/cuneiform/files/minmax.patch
+++ /dev/null
@@ -1,59 +0,0 @@
-min and max functions are part of stdlib, having them as defines
-breaks libstdc++ internals.
---- cuneiform-linux-1.1.0/cuneiform_src/Kern/include/minmax.h.orig 2017-09-05 22:47:42.245551111 +0300
-+++ cuneiform-linux-1.1.0/cuneiform_src/Kern/include/minmax.h 2017-09-05 22:48:57.433930220 +0300
-@@ -60,6 +60,10 @@
- * code use them without proper includes which lead to link errors.
- */
-
-+//#ifdef __cplusplus
-+//#include <algorithm>
-+//#endif
-+
- #ifndef MIN
- #define MIN(a,b) (((a)>(b))?(b):(a))
- #endif
-@@ -67,6 +71,8 @@
- #define MAX(a,b) (((a)>(b))?(a):(b))
- #endif
-
-+#ifndef __cplusplus
-+
- #ifndef min
- #define min(a,b) (((a)>(b))?(b):(a))
- #endif
-@@ -74,4 +80,5 @@
- #define max(a,b) (((a)>(b))?(a):(b))
- #endif
-
-+#endif // __cplusplus
- #endif
---- cuneiform-linux-1.1.0/cuneiform_src/Kern/rcutp/sources/main/rcutp_func.cpp.orig 2011-04-19 16:49:57.000000000 +0400
-+++ cuneiform-linux-1.1.0/cuneiform_src/Kern/rcutp/sources/main/rcutp_func.cpp 2017-09-05 23:37:11.405501024 +0300
-@@ -902,8 +902,8 @@
- if(l1<0 || r1<0) return -1;
- if(i>0)
- {
-- minl=MIN(minl,l1); minr=min(minr,r1);
-- maxl=MAX(maxl,l1); maxr=max(maxr,r1);
-+ minl=MIN(minl,l1); minr=MIN(minr,r1);
-+ maxl=MAX(maxl,l1); maxr=MAX(maxr,r1);
- }
- else
- {
---- cuneiform-linux-1.1.0/cuneiform_src/Kern/rcutp/sources/main/rcutp_mainfunc.cpp.orig 2011-04-19 16:49:57.000000000 +0400
-+++ cuneiform-linux-1.1.0/cuneiform_src/Kern/rcutp/sources/main/rcutp_mainfunc.cpp 2017-09-05 23:53:03.816381210 +0300
-@@ -73,13 +73,6 @@
-
- extern int16_t minrow,bbs1,bbs2,bbs3,bbs4,Nb1,Nb2,Nb3;
- extern uchar language;
--#ifndef max
--#define MAX(a,b) (((a) > (b)) ? (a) : (b))
--#endif
--
--#ifndef min
--#define MIN(a,b) (((a) < (b)) ? (a) : (b))
--#endif
-
- extern int16_t up_position,dw_position;
- uchar MemForCutPoints[65536];
diff --git a/app-text/cuneiform/metadata.xml b/app-text/cuneiform/metadata.xml
deleted file mode 100644
index f8160b9..0000000
--- a/app-text/cuneiform/metadata.xml
+++ /dev/null
@@ -1,14 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>bircoph@gentoo.org</email>
- <name>Andrew Savchenko</name>
- </maintainer>
- <longdescription lang="en">
- Cuneiform is an multi-language OCR system.
- </longdescription>
- <upstream>
- <remote-id type="launchpad">cuneiform-linux</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-util/symlookup/Manifest b/dev-util/symlookup/Manifest
deleted file mode 100644
index e4333d8..0000000
--- a/dev-util/symlookup/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST symlookup-0.5.2.tar.xz 47672 SHA256 2b26d2b97b30c834e0ee7110fc9f8f140334507310f67a11ed6ee3a3d90debaa SHA512 cd1899498bd073ab3afd625716f585ade17ebd0802802a451fb237e91458730907dc53cede251ebcf815a81ef0d310bd61fb931742093a3bcd030cb0f0fc97f5 WHIRLPOOL b228b2b4afdd3245c0fd01f899508dc3b81ba66cdb63f4b52e59806307bf6d4b0edfa18215d3f8f2a8ed6a61b08684b5b26449a6bda248cf8f57fec38972e373
diff --git a/dev-util/symlookup/metadata.xml b/dev-util/symlookup/metadata.xml
deleted file mode 100644
index 5cca89b..0000000
--- a/dev-util/symlookup/metadata.xml
+++ /dev/null
@@ -1,12 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="person">
- <email>bircoph@gentoo.org</email>
- <name>Andrew Savchenko</name>
-</maintainer>
-<use>
- <flag name='portage'>Enable support for Portage database queries.</flag>
- <flag name='rpm'>Enable support for RPM database queries. May be useful if <pkg>app-arch/rpm</pkg> is used to install packages outside of portage</flag>
-</use>
-</pkgmetadata>
diff --git a/dev-util/symlookup/symlookup-0.5.2.ebuild b/dev-util/symlookup/symlookup-0.5.2.ebuild
deleted file mode 100644
index 1fb2015..0000000
--- a/dev-util/symlookup/symlookup-0.5.2.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-DESCRIPTION="Utility for searching of object files containing requested symbols"
-HOMEPAGE="http://symbol-lookup.sourceforge.net/"
-SRC_URI="mirror://sourceforge/symbol-lookup/${P}.tar.xz"
-KEYWORDS="~x86 ~amd64"
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="+portage rpm"
-
-DEPEND="
- dev-libs/elfutils
- portage? ( sys-apps/portage )
- rpm? ( app-arch/rpm )
-"
-RDEPEND="${DEPEND}"
-
-src_configure() {
- local myconf="--disable-strip --enable-cflags"
- use portage || myconf+=" --disable-portage"
- use rpm || myconf+=" --disable-rpm"
- econf ${myconf}
-}
diff --git a/dev-util/symlookup/symlookup-9999.ebuild b/dev-util/symlookup/symlookup-9999.ebuild
deleted file mode 100644
index 836fa2e..0000000
--- a/dev-util/symlookup/symlookup-9999.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-inherit subversion
-
-DESCRIPTION="Utility for searching of object files containing requested symbols"
-HOMEPAGE="http://symbol-lookup.sourceforge.net/"
-ESVN_REPO_URI="svn://svn.code.sf.net/p/symbol-lookup/code/trunk"
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="+portage rpm"
-
-DEPEND="
- dev-libs/elfutils
- portage? ( sys-apps/portage )
- rpm? ( app-arch/rpm )
-"
-RDEPEND="${DEPEND}"
-
-src_configure() {
- local myconf="--disable-strip --enable-cflags"
- use portage || myconf+=" --disable-portage"
- use rpm || myconf+=" --disable-rpm"
- econf ${myconf}
-}
diff --git a/profiles/categories b/profiles/categories
index b5119d6..a90e351 100644
--- a/profiles/categories
+++ b/profiles/categories
@@ -1,4 +1,3 @@
-app-text
app-vim
dev-python
dev-util