summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/ati-stream-sdk/Manifest2
-rw-r--r--dev-util/ati-stream-sdk/ati-stream-sdk-2.3-r1.ebuild35
-rw-r--r--licenses/AMD-OCL157
-rw-r--r--profiles/package.mask1
4 files changed, 183 insertions, 12 deletions
diff --git a/dev-util/ati-stream-sdk/Manifest b/dev-util/ati-stream-sdk/Manifest
index fa28365..43928c3 100644
--- a/dev-util/ati-stream-sdk/Manifest
+++ b/dev-util/ati-stream-sdk/Manifest
@@ -1,5 +1,5 @@
AUX Makefile 2297 RMD160 cb547b9644ae1f1e013f5627fca57d1b47173cde SHA1 8c7308662ab9ba793c285d5fe6a14b8262875c59 SHA256 17fddeaea2c5d94ed0ee01bf4317a9f20f141ea68a92f78ae4c8b7a36fc6c9bd
DIST ati-stream-sdk-v2.3-lnx32.tgz 49912168 RMD160 07c045de3118531472672e9ef7b3763cb32f7d68 SHA1 972bdbe6942e52411a2f041720348e857f17c388 SHA256 07fd15a51a678c4378767f61466daf9da21d0bab6088a97a70136dd8c976aca6
DIST ati-stream-sdk-v2.3-lnx64.tgz 78659015 RMD160 57af36f62e590ae54cb9d43b880735979b77466c SHA1 43c94e5126563fe3fa4cb92fb6dd20f12864a86d SHA256 f92537d1fc306af0bff1441af4669bf2fa668654b12d9fb53a3a872dc8826cad
-EBUILD ati-stream-sdk-2.3-r1.ebuild 1785 RMD160 a49779dcf7c9cc2c759edd252a8de82fb2b4731a SHA1 78f96f8730fb3da67dc6939a646567bf82174217 SHA256 b1f1607754f6ca3cb4784242dd260a9e8a6738d08fc7923dbf02ecdd9ee576aa
+EBUILD ati-stream-sdk-2.3-r1.ebuild 2283 RMD160 895b4b104aff70c3bdfcb9cee4bbb460d65c9538 SHA1 3861f98499025bd4d74bbddd0f862e634911f47b SHA256 30f925eba989538ac81801bf734670b03da0100f7cd271767259161c0c4a989a
MISC metadata.xml 301 RMD160 1ef0179dbe53f24768e976ab60f6ae0e8ca9e672 SHA1 fba668cb8711ac2bcc6b7bfc113a1a513c69b0be SHA256 55f555e646e9d04c8975a736b9a5b3f1d8ea110446c18e988a3b884d0dca33b7
diff --git a/dev-util/ati-stream-sdk/ati-stream-sdk-2.3-r1.ebuild b/dev-util/ati-stream-sdk/ati-stream-sdk-2.3-r1.ebuild
index 4a993c0..c6e51d7 100644
--- a/dev-util/ati-stream-sdk/ati-stream-sdk-2.3-r1.ebuild
+++ b/dev-util/ati-stream-sdk/ati-stream-sdk-2.3-r1.ebuild
@@ -13,26 +13,28 @@ SRC_URI=" \
amd64? ( http://download2-developer.amd.com/amd/Stream20GA/${MY_P}-lnx64.tgz ) \
x86? ( http://download2-developer.amd.com/amd/Stream20GA/${MY_P}-lnx32.tgz )"
-LICENSE="AMD GPL-1 as-is"
+LICENSE="AMD-OCL"
SLOT="0"
KEYWORDS=""
IUSE="examples doc multilib"
RESTRICT="strip fetch"
RDEPEND="media-libs/freeglut
+ examples? ( media-libs/glew )
x11-drivers/ati-drivers
- examples? ( media-libs/glew )"
+ !dev-util/nvidia-cuda-sdk
+ !dev-util/nvidia-cuda-toolkit"
QA_EXECSTACK="opt/${PN}/lib*/libatiocl??.so"
S="${WORKDIR}/${MY_P}"
-pkg_nofetch() {
+pkg_nofetch(){
ewarn "Proprietary software. Download at"
ewarn "http://developer.amd.com/gpu/AMDAPPSDK/downloads/Pages/default.aspx"
ewarn "and move it to distfiles"
}
-src_unpack() {
+src_unpack(){
default_src_unpack
mv ${MY_P}-lnx* ${MY_P} || die
@@ -46,15 +48,19 @@ src_prepare(){
fi
}
-src_compile() { true; }
+src_compile(){ true; }
-src_install() {
+src_install(){
local DEST=/opt/${PN}
rm include/GL/{glext.h,glut.h} || die
if use amd64; then
emake DESTDIR="${D}" ARCH="amd64" install || die "Install failed";
+ if use multilib; then
+ emake DESTDIR="${D}" ARCH="x86" install-lib \
+ || die "Multilib install failed"
+ fi
else
emake DESTDIR="${D}" ARCH="x86" install || die "Install failed";
fi
@@ -62,10 +68,9 @@ src_install() {
cat > "${T}/99${PN}" << EOF
PATH=${DEST}/bin
ROOTPATH=${DEST}/bin
-LDPATH=${DEST}/$(get_libdir)
-LD_LIBRARY_PATH=${DEST}/$(get_libdir)
+LDPATH=${DEST}/lib
EOF
- doenvd "${T}/99${PN}"
+ doenvd "${T}/99${PN}" || die
if use examples; then
insinto ${DEST}/examples
@@ -75,6 +80,16 @@ EOF
fi
if use doc; then
- dodoc docs/opencl/*
+ dodoc docs/opencl/* || die
fi
}
+
+pkg_postinst(){
+ elog "If you want to be able to compile without passing"
+ elog "-I /opt/ati-stream-sdk/include to gcc, please set"
+ elog "C_INCLUDE_PATH and CPLUS_INCLUDE_PATH to that directory"
+ elog
+ elog "Also, if you do not want to pass -L /opt/ati-stream-sdk/lib/x86(_64)"
+ elog "to gcc for every use of -lOpenCL, add that directory to"
+ elog "LD_LIBRARY_PATH."
+}
diff --git a/licenses/AMD-OCL b/licenses/AMD-OCL
new file mode 100644
index 0000000..5d2015b
--- /dev/null
+++ b/licenses/AMD-OCL
@@ -0,0 +1,157 @@
+Do not load this Software until you have
+carefully read and agreed to the following terms and conditions. This is a
+legal agreement ("Agreement") between you (either an individual or an entity)
+(you or "Licensee") and Advanced Micro Devices, Inc. ("AMD"). If Licensee
+does not agree to the terms of this Agreement, do not install or use this
+Software or any portion thereof. By loading or using this software that may
+include associated media, printed Software, and online or electronic
+documentation or any portion thereof that is made available to install
+("Software"), Licensee agrees to all of the terms of this Agreement.
+
+1. License. The software accompanying this License (hereinafter "Software"),
+regardless of the form in which it is distributed, is licensed to you by
+Advanced Micro Devices, Inc. You own the medium on which the Software is
+recorded, but Advanced Micro Devices, Inc. and, if applicable, its Licensors
+(referred to collectively as "AMD") retain title to the Software and
+related documentation. You may:
+a) make a copy of the Software in machine-readable form for backup purposes.
+You must reproduce on such copy AMD's copyright notice and any other
+proprietary legends that were on the original copy of the Software;
+b) transfer all your license rights in the Software to a third party
+provided you must also transfer a copy of this License, the backup copy of
+the Software and the related documentation and provided the other party reads
+and agrees to accept the terms and conditions of this License. Upon such
+transfer your license is then terminated; and
+c) make and distribute copies of the Software within your organization,
+provided that you agree to include all copyright legends and other legal
+notices that may appear in the Software, as well as this Software License
+Agreement in its entirety, in each copy of the Software that is made or
+distributed.
+
+2. Restrictions. The Software contains copyrighted and patented material,
+trade secrets and other proprietary material. In order to protect them, and
+except as permitted by applicable legislation, you may not:
+a) decompile, reverse engineer, disassemble or otherwise reduce the Software
+to a human-perceivable form;
+b) modify, network, rent, lend, loan, distribute or create derivative works
+based upon the Software in whole or in part; or
+c) electronically transmit the Software from one computer to another or over
+a network or otherwise transfer the Software except as permitted by this
+License.
+
+3 OWNERSHIP AND COPYRIGHT OF SOFTWARE: The Software is owned by AMD and is
+protected by United States and foreign intellectual property laws (e.g. patent
+and copyright laws) and international treaty provisions. Licensee will not
+remove the copyright notice from the Software. Licensee agrees to prevent
+any unauthorized copying of the Software. All title and copyrights in and
+to the Software, all copies thereof (in whole or in part, and in any form),
+and all rights therein shall remain vested in AMD. Except as expressly
+provided herein, AMD does not grant any express or implied right to Licensee
+under AMD patents, copyrights, trademarks, or trade secret information. All
+rights in and to the Software not expressly granted to Licensee in this
+Agreement are reserved to AMD.
+
+4. SUPPORT: Under this Agreement, AMD is under no obligation to assist in
+the use of this Software, to provide support to licensees of the Software, or
+to provide maintenance, correction, modification, enhancement, or upgrades to
+the Software. AMD may provide such support, maintenance, correction,
+modification, enhancement or upgrades in a media determined by AMD and AMD
+shall have no obligation to notify Licensee thereof. Additionally, such
+support, maintenance, correction, modification, enhancement, or upgrades shall
+be considered part of the Software, and shall be subject to this Agreement.
+
+5. Termination. This License is effective until terminated. You may
+terminate this License at any time by destroying the Software, related
+documentation and all copies thereof. This License will terminate
+immediately without notice from AMD if you fail to comply with any provision
+of this License. Upon termination you must destroy the Software, related
+documentation and all copies thereof.
+
+6. Government End Users. If you are acquiring the Software on behalf of any
+unit or agency of the United States Government, the following provisions
+apply. The Government agrees the Software and documentation were developed
+at private expense and are provided with "RESTRICTED RIGHTS". Use,
+duplication, or disclosure by the Government is subject to restrictions as
+set forth in DFARS 227.7202-1(a) and 227.7202-3(a) (1995), DFARS
+252.227-7013(c)(1)(ii) (Oct 1988), FAR 12.212(a)(1995), FAR 52.227-19, (June
+1987) or FAR 52.227-14(ALT III) (June 1987),as amended from time to time.
+In the event that this License, or any part thereof, is deemed inconsistent
+with the minimum rights identified in the Restricted Rights provisions, the
+minimum rights shall prevail.
+
+7. EXPORT ASSURANCES: Licensee agrees and certifies that neither the
+Software, nor any direct product thereof will be exported, directly or
+indirectly, into any country prohibited by the United States Export
+Administration Act and the regulations thereunder without the required
+authorization from the United States government nor will it be used for any
+purpose prohibited by the same.
+
+8. No Other License. No rights or licenses are granted by AMD under this
+License, expressly or by implication, with respect to any proprietary
+information or patent, copyright, trade secret or other intellectual property
+right owned or controlled by AMD, except as expressly provided in this
+License.
+
+9. Additional Licenses. DISTRIBUTION OR USE OF THE SOFTWARE WITH AN
+OPERATING SYSTEM MAY REQUIRE ADDITIONAL LICENSES FROM THE OPERATING SYSTEM
+VENDOR.
+
+10. Disclaimer of Warranty on Software. You expressly acknowledge and agree
+that use of the Software is at your sole risk. The Software and related
+documentation are provided "AS IS" and without warranty of any kind and AMD
+EXPRESSLY DISCLAIMS ALL WARRANTIES, EXPRESS AND IMPLIED, INCLUDING, BUT NOT
+LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A
+PARTICULAR PURPOSE. AMD DOES NOT WARRANT THAT THE FUNCTIONS CONTAINED IN THE
+SOFTWARE WILL MEET YOUR REQUIREMENTS, OR THAT THE OPERATION OF THE SOFTWARE
+WILL BE UNINTERRUPTED OR ERROR-FREE, OR THAT DEFECTS IN THE SOFTWARE WILL BE
+CORRECTED. THE ENTIRE RISK AS TO THE RESULTS AND PERFORMANCE OF THE
+SOFTWARE IS ASSUMED BY YOU. FURTHERMORE, AMD DOES NOT WARRANT OR MAKE ANY
+REPRESENTATIONS REGARDING THE USE OR THE RESULTS OF THE USE OF THE SOFTWARE
+OR RELATED DOCUMENTATION IN TERMS OF THEIR CORRECTNESS, ACCURACY,
+RELIABILITY, CURRENTNESS, OR OTHERWISE. NO ORAL OR WRITTEN INFORMATION OR
+ADVICE GIVEN BY AMD OR AMD'S AUTHORIZED REPRESENTATIVE SHALL CREATE A
+WARRANTY OR IN ANY WAY INCREASE THE SCOPE OF THIS WARRANTY. SHOULD THE
+SOFTWARE PROVE DEFECTIVE, YOU (AND NOT AMD OR AMD'S AUTHORIZED
+REPRESENTATIVE) ASSUME THE ENTIRE COST OF ALL NECESSARY SERVICING, REPAIR
+OR CORRECTION. THE SOFTWARE IS NOT INTENDED FOR USE IN MEDICAL, LIFE SAVING
+OR LIFE SUSTAINING APPLICATIONS. SOME JURISDICTIONS DO NOT ALLOW THE
+EXCLUSION OF IMPLIED WARRANTIES, SO THE ABOVE EXCLUSION MAY NOT APPLY TO YOU.
+
+11. Limitation of Liability. UNDER NO CIRCUMSTANCES INCLUDING NEGLIGENCE,
+SHALL AMD, OR ITS DIRECTORS, OFFICERS, EMPLOYEES OR AGENTS, BE LIABLE TO YOU
+FOR ANY INCIDENTAL, INDIRECT, SPECIAL OR CONSEQUENTIAL DAMAGES (INCLUDING
+DAMAGES FOR LOSS OF BUSINESS PROFITS, BUSINESS INTERRUPTION, LOSS OF BUSINESS
+INFORMATION, AND THE LIKE) ARISING OUT OF THE USE, MISUSE OR INABILITY TO USE
+THE SOFTWARE OR RELATED DOCUMENTATION, BREACH OR DEFAULT, INCLUDING THOSE
+ARISING FROM INFRINGEMENT OR ALLEGED INFRINGEMENT OF ANY PATENT, TRADEMARK,
+COPYRIGHT OR OTHER INTELLECTUAL PROPERTY RIGHT, BY AMD, EVEN IF AMD OR AMD'S
+AUTHORIZED REPRESENTATIVE HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH
+DAMAGES. SOME JURISDICTIONS DO NOT ALLOW THE LIMITATION OR EXCLUSION OF
+LIABILITY FOR INCIDENTAL OR CONSEQUENTIAL DAMAGES, SO THE ABOVE LIMITATION OR
+EXCLUSION MAY NOT APPLY TO YOU. AMD will not be liable for 1) loss of, or
+damage to, your records or data or 2) any damages claimed by you based on any
+third party claim. In no event shall AMD's total liability to you for all
+damages, losses, and causes of action (whether in contract, tort (including
+negligence) or otherwise) exceed the amount paid by you for the Software.
+
+12. Controlling Law and Severability. This License shall be governed by and
+construed under the laws of the state of California without reference to its
+conflict of law principles. In the event of any conflicts between foreign
+law, rules, and regulations, and United States law, rules, and regulations,
+United States rules and regulations shall prevail and govern. The United
+Nations Convention on Contracts for the International Sale of Goods shall not
+apply to this License. If for any reason a court of competent jurisdiction
+finds any provision of this License or portion thereof, to be unenforceable,
+that provision of the License shall be enforced to the maximum extent
+permissible so as to effect the intent of the parties, and the remainder of
+this License shall continue in full force and effect.
+
+13. Complete Agreement. This License constitutes the entire agreement
+between the parties with respect to the use of the Software and the related
+documentation, and supersedes all prior or contemporaneous understandings or
+agreements, written or oral, regarding such subject matter. No amendment to
+or modification of this License will be binding unless in writing and signed
+by a duly authorized representative of AMD.
+
+This software may be used for any purpose but may not be re-sold in original
+or modified form.
diff --git a/profiles/package.mask b/profiles/package.mask
index 8bc6804..dc7e99b 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -1,3 +1,2 @@
>=dev-libs/botan-1.9
-dev-util/ati-stream-sdk
sys-kernel/c1pher-sources