summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjolexa <olex0003@umn.edu>2009-03-02 19:45:32 -0600
committerjolexa <olex0003@umn.edu>2009-03-02 19:45:32 -0600
commit4ecec27a69032d42e21ea14fd25a382d78aae8c2 (patch)
treed57464ee98b630fda6cf9f4924b563ef19f34154
parentadd ~amd64 kw (diff)
downloaddarkside-4ecec27a69032d42e21ea14fd25a382d78aae8c2.tar.gz
darkside-4ecec27a69032d42e21ea14fd25a382d78aae8c2.tar.bz2
darkside-4ecec27a69032d42e21ea14fd25a382d78aae8c2.zip
Initial commit of a cvs snapshot ebuild of dev-lang/icon
-rw-r--r--dev-lang/icon/Manifest5
-rw-r--r--dev-lang/icon/files/icon-9.4.99_p20090302-flags.patch40
-rw-r--r--dev-lang/icon/files/tests-9.4.99_p20090302.patch113
-rw-r--r--dev-lang/icon/icon-9.4.99_p20090302.ebuild110
-rw-r--r--dev-lang/icon/metadata.xml6
5 files changed, 274 insertions, 0 deletions
diff --git a/dev-lang/icon/Manifest b/dev-lang/icon/Manifest
new file mode 100644
index 0000000..fad3a70
--- /dev/null
+++ b/dev-lang/icon/Manifest
@@ -0,0 +1,5 @@
+AUX icon-9.4.99_p20090302-flags.patch 1183 RMD160 d674104b018321699c27d37fba8d83e749d5b9d5 SHA1 a530f1b44d98c55cf03ced6b42af0e39237524b6 SHA256 111473f317e3f1b16f2ebeff37f382f59dde5a015f9e5545415a6a4356197791
+AUX tests-9.4.99_p20090302.patch 3851 RMD160 33071267794691c567d093400ffa47b7fcca21e2 SHA1 aff8e571f86a9eafc6d25d638ebc779a6f4264c0 SHA256 aedbd150e726736cbe5f2846b1d54c33f3eb9b1480c3352043e88e8a5886d027
+DIST icon.v9.4.99_p20090302src.tgz 3358108 RMD160 1722a1bf80ade149e1565aa1b4110de830703f1e SHA1 db4cd7ec6055fe11cf5125fe63812302932728d8 SHA256 b22a72f098aafa9b81e1fc623dca2a77b63bf62e55346b01e1201ab54b7fd77e
+EBUILD icon-9.4.99_p20090302.ebuild 2907 RMD160 50ac7fb1ada02a536df825668ca7d8746cd5d2ee SHA1 bf5b85cfac2f72a3c1c029d58cb4ae41ef01e4f1 SHA256 e0425c6adeb51ff8151555c115c47201c9295fecfd4f5a65a66792794a7d1b4b
+MISC metadata.xml 244 RMD160 b2f04edcd2d3ff57e0ba36211770eaec51e4c6c6 SHA1 c8d47ce6a7ee64cc3d86fa9fea8c0293a5e0a905 SHA256 7955bac417b9aab6461e2601288d7ec454b34f1a3fa8df15b9d335dd087241b8
diff --git a/dev-lang/icon/files/icon-9.4.99_p20090302-flags.patch b/dev-lang/icon/files/icon-9.4.99_p20090302-flags.patch
new file mode 100644
index 0000000..e4988c2
--- /dev/null
+++ b/dev-lang/icon/files/icon-9.4.99_p20090302-flags.patch
@@ -0,0 +1,40 @@
+--- icon.v9.4.99_p20090302src/src/common/Makefile
++++ icon.v9.4.99_p20090302src/src/common/Makefile
+@@ -8,7 +8,7 @@
+ common: doincl $(OBJS) gpxmaybe
+
+ doincl: doincl.c ../h/arch.h
+- $(CC) $(CFLAGS) -o doincl doincl.c
++ $(CC) $(CFLAGS) $(LDFLAGS) -o doincl doincl.c
+ -./doincl -o ../../bin/rt.h ../h/rt.h
+
+ patchstr: patchstr.c
+@@ -29,7 +29,7 @@
+ ../h/typedefs.h ../h/mproto.h ../h/cpuconf.h
+
+ ../h/arch.h: infer.c
+- $(CC) $(CFLAGS) -o infer infer.c
++ $(CC) $(CFLAGS) $(LDFLAGS) -o infer infer.c
+ ./infer >../h/arch.h
+
+ identify.o: ../h/version.h
+@@ -46,7 +46,7 @@
+
+ # for rswitch, $(CFLAGS) is deliberately omitted (-O may cause problems)
+ rswitch.o: ../h/define.h ../h/arch.h $(RSW)
+- $(CC) -c $(RSW)
++ $(CC) $(CFLAGS) -O0 -c $(RSW)
+
+
+ # The following section is needed if changes are made to the Icon grammar,
+--- icon.v9.4.99_p20090302src/src/runtime/Makefile
++++ icon.v9.4.99_p20090302src/src/runtime/Makefile
+@@ -39,7 +39,7 @@
+
+ iconx: $(OBJS)
+ cd ../common; $(MAKE)
+- $(CC) $(RLINK) -o iconx $(OBJS) $(XL) $(RLIBS) $(TL)
++ $(CC) $(LDFLAGS) $(RLINK) -o iconx $(OBJS) $(XL) $(RLIBS) $(TL)
+ cp iconx ../../bin
+ strip $(SFLAGS) ../../bin/iconx$(EXE)
+
diff --git a/dev-lang/icon/files/tests-9.4.99_p20090302.patch b/dev-lang/icon/files/tests-9.4.99_p20090302.patch
new file mode 100644
index 0000000..8daae20
--- /dev/null
+++ b/dev-lang/icon/files/tests-9.4.99_p20090302.patch
@@ -0,0 +1,113 @@
+diff -uprN icon.v9.4.99_p20090302src.orig/tests/general/io.icn icon.v9.4.99_p20090302src/tests/general/io.icn
+--- icon.v9.4.99_p20090302src.orig/tests/general/io.icn 2002-03-11 14:21:18.000000000 -0700
++++ icon.v9.4.99_p20090302src/tests/general/io.icn 2006-04-01 10:35:14.590948251 -0700
+@@ -6,7 +6,7 @@ procedure main()
+ local L, f, m, n, t1, t2
+
+ L := [&input, &output, &errout,
+- m := open("/etc/motd") | stop("no /etc/motd"),
++ m := open("/etc/gentoo-release") | stop("no /etc/gentoo-release"),
+ n := open("/dev/null", "w") | stop("no /dev/null")]
+ L := sort(L)
+ every f := !L do
+@@ -21,10 +21,10 @@ procedure main()
+ every write(!&input) \ 2
+
+ write()
+- write("flush /etc/motd: ", image(flush(m)) | "FAILED")
+- write("close /etc/motd: ", image(close(m)) | "FAILED")
+- write("close /etc/motd: ", image(close(m)) | "FAILED")
+- write("flush /etc/motd: ", image(flush(m)) | "FAILED")
++ write("flush /etc/gentoo-release: ", image(flush(m)) | "FAILED")
++ write("close /etc/gentoo-release: ", image(close(m)) | "FAILED")
++ write("close /etc/gentoo-release: ", image(close(m)) | "FAILED")
++ write("flush /etc/gentoo-release: ", image(flush(m)) | "FAILED")
+
+ write()
+ write("flush /dev/null: ", image(flush(n)) | "FAILED")
+diff -uprN icon.v9.4.99_p20090302src.orig/tests/general/io.std icon.v9.4.99_p20090302src/tests/general/io.std
+--- icon.v9.4.99_p20090302src.orig/tests/general/io.std 2002-03-11 14:21:18.000000000 -0700
++++ icon.v9.4.99_p20090302src/tests/general/io.std 2006-04-01 10:35:31.071362086 -0700
+@@ -2,7 +2,7 @@ file: &errout
+ file: &input
+ file: &output
+ file: file(/dev/null)
+-file: file(/etc/motd)
++file: file(/etc/gentoo-release)
+
+ aaa
+ bbbb
+@@ -13,10 +13,10 @@ ffffffff
+ ggggggggg
+ hhhhhhhhhh
+
+-flush /etc/motd: file(/etc/motd)
+-close /etc/motd: file(/etc/motd)
+-close /etc/motd: file(/etc/motd)
+-flush /etc/motd: file(/etc/motd)
++flush /etc/gentoo-release: file(/etc/gentoo-release)
++close /etc/gentoo-release: file(/etc/gentoo-release)
++close /etc/gentoo-release: file(/etc/gentoo-release)
++flush /etc/gentoo-release: file(/etc/gentoo-release)
+
+ flush /dev/null: file(/dev/null)
+ close /dev/null: file(/dev/null)
+@@ -109,7 +109,7 @@ file(sed 's/^/=()= /' io.icn)
+ > =()= local L, f, m, n, t1, t2
+ > =()=
+ > =()= L := [&input, &output, &errout,
+-> =()= m := open("/etc/motd") | stop("no /etc/motd"),
++> =()= m := open("/etc/gentoo-release") | stop("no /etc/gentoo-release"),
+ > =()= n := open("/dev/null", "w") | stop("no /dev/null")]
+
+ file(ls io.i?n io.d?t io.s?d)
+diff -uprN icon.v9.4.99_p20090302src.orig/tests/general/kwds.std icon.v9.4.99_p20090302src/tests/general/kwds.std
+--- icon.v9.4.99_p20090302src.orig/tests/general/kwds.std 2002-07-10 18:29:28.000000000 -0600
++++ icon.v9.4.99_p20090302src/tests/general/kwds.std 2006-04-01 10:35:37.103317654 -0700
+@@ -20,8 +20,10 @@
+ &features: ASCII
+ &features: co-expressions
+ &features: environment variables
++ &features: event monitoring
+ &features: keyboard functions
+ &features: large integers
++ &features: multiple programs
+ &features: pipes
+ &features: system function
+ &input: &input
+diff -uprN icon.v9.4.99_p20090302src.orig/tests/general/nargs.std icon.v9.4.99_p20090302src/tests/general/nargs.std
+--- icon.v9.4.99_p20090302src.orig/tests/general/nargs.std 2001-12-06 15:54:01.000000000 -0700
++++ icon.v9.4.99_p20090302src/tests/general/nargs.std 2006-04-01 10:35:43.282223496 -0700
+@@ -15,7 +15,7 @@
+ 1 delay
+ 2 delete
+ -2 detab
+- 2 display
++ 3 display
+ 1 dtor
+ -2 entab
+ 0 errorclear
+@@ -43,12 +43,12 @@
+ 4 match
+ 2 member
+ 1 move
+- 1 name
++ 2 name
+ 1 numeric
+ 1 ord
+ 1 pop
+ 1 pos
+- 2 proc
++ 3 proc
+ 1 pull
+ -2 push
+ -2 put
+@@ -79,7 +79,7 @@
+ 2 trim
+ 1 type
+ 4 upto
+- 1 variable
++ 3 variable
+ 1 where
+ -1 write
+ -1 writes
diff --git a/dev-lang/icon/icon-9.4.99_p20090302.ebuild b/dev-lang/icon/icon-9.4.99_p20090302.ebuild
new file mode 100644
index 0000000..ef56ea6
--- /dev/null
+++ b/dev-lang/icon/icon-9.4.99_p20090302.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/icon/icon-9.4.3-r4.ebuild,v 1.1 2008/10/06 20:24:45 truedfx Exp $
+
+RESTRICT="mirror"
+
+inherit eutils flag-o-matic multilib toolchain-funcs
+
+#MY_PV=${PV//./}
+SRC_URI="http://dev.gentooexperimental.org/~darkside/distfiles/icon/icon.v${PV}src.tgz"
+HOMEPAGE="http://www.cs.arizona.edu/icon/"
+DESCRIPTION="very high level language"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="X iplsrc"
+
+S="${WORKDIR}/icon.v${PV}src"
+
+DEPEND="X? ( x11-proto/xextproto
+ x11-proto/xproto
+ x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/libXt )
+ sys-devel/gcc"
+
+src_unpack() {
+ unpack ${A}
+
+ epatch "${FILESDIR}"/${P}-flags.patch
+
+ # Patch the tests so that they do not fail
+ # The following files in tests/standard are patched..
+ # io.icn - change /etc/motd to /etc/gentoo-release
+ # io.std - change /etc/motd to /etc/gentoo-release
+ # kwds.std - add two lines for the two new added keywords
+ # nargs.std - a couple of functions picked up additional parameters
+# epatch "${FILESDIR}/tests-${PV}.patch"
+
+ # do not prestrip files
+ echo ${S}
+ find "${S}"/src -name 'Makefile' | xargs sed -i -e "/strip/d" || die
+}
+
+src_compile() {
+ # select the right compile target. Note there are many platforms
+ # available
+ local mytarget;
+ if [[ ${CHOST} == *-darwin* ]]; then
+ mytarget="macintosh"
+ else
+ mytarget="linux"
+ fi
+
+ if use X; then
+ emake X-Configure name=${mytarget} -j1 || die
+ else
+ emake Configure name=${mytarget} -j1 || die
+ fi
+
+ echo "#define MultiThread 1" >> src/h/define.h
+ echo "#define EventMon 1" >> src/h/define.h
+ echo "#define Eve 1" >> src/h/define.h
+
+ append-flags $(test-flags -fwrapv)
+
+ emake -j1 CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die "Make Failed"
+}
+
+src_test() {
+ make Samples || die "Samples failed"
+ make Test || die "Test failed"
+}
+
+src_install() {
+ dodir /usr
+ dodir /usr/bin
+ dodir /usr/$(get_libdir)
+
+ make Install dest="${D}/usr/$(get_libdir)/icon" || die "Make install failed"
+ dosym /usr/$(get_libdir)/icon/bin/icont /usr/bin/icont
+ dosym /usr/$(get_libdir)/icon/bin/iconx /usr/bin/iconx
+ dosym /usr/$(get_libdir)/icon/bin/icon /usr/bin/icon
+ dosym /usr/$(get_libdir)/icon/bin/vib /usr/bin/vib
+
+ cd "${S}/man/man1"
+ doman icont.1
+ doman icon.1
+ rm -rf "${D}"/usr/$(get_libdir)/icon/man
+
+ cd "${S}/doc"
+ dodoc *.txt *.sed ../README
+ # dohtml ignores all anything except .html files, no use here
+ mkdir -p "${D}"/usr/share/doc/${PF}/html
+ cp -dpR *.htm *.gif *.jpg *.css "${D}"/usr/share/doc/${PF}/html
+ rm -rf "${D}"/usr/$(get_libdir)/icon/{doc,README}
+
+ # optional Icon Programming Library
+ if use iplsrc; then
+ cd "${S}"
+ dodir /usr/$(get_libdir)/icon/ipl
+ rm ipl/BuildBin
+ rm ipl/BuildExe
+ rm ipl/CheckAll
+ rm ipl/Makefile
+ insinto /usr/$(get_libdir)/icon
+ doins -r ipl
+ fi
+}
diff --git a/dev-lang/icon/metadata.xml b/dev-lang/icon/metadata.xml
new file mode 100644
index 0000000..8595a9c
--- /dev/null
+++ b/dev-lang/icon/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>lang-misc</herd>
+<use><flag name='iplsrc'>install the icon programming library source</flag></use>
+</pkgmetadata>