aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/git/git-9999.ebuild')
-rw-r--r--dev-util/git/git-9999.ebuild150
1 files changed, 0 insertions, 150 deletions
diff --git a/dev-util/git/git-9999.ebuild b/dev-util/git/git-9999.ebuild
deleted file mode 100644
index 75f8da9..0000000
--- a/dev-util/git/git-9999.ebuild
+++ /dev/null
@@ -1,150 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/git/git-1.3.3.ebuild,v 1.2 2006/05/21 01:18:44 ferdy Exp $
-
-inherit python toolchain-funcs eutils elisp-common git
-
-EGIT_REPO_URI="git://git.kernel.org/pub/scm/git/git.git"
-
-DOC_VER=${PV}
-
-DESCRIPTION="GIT - the stupid content tracker"
-HOMEPAGE="http://kernel.org/pub/software/scm/git/"
-SRC_URI=""
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="curl doc emacs mozsha1 ppcsha1 webdav X"
-
-DEPEND="dev-libs/openssl
- sys-libs/zlib
- !app-misc/git
- curl? ( net-misc/curl )
- webdav? ( dev-libs/expat )
- app-text/asciidoc
- app-text/xmlto"
-RDEPEND="${DEPEND}
- dev-lang/perl
- >=dev-lang/python-2.3
- app-text/rcs
- X? ( dev-lang/tk )"
-
-# This is needed because for some obscure reasons future calls to make don't
-# pick up these exports if we export them in src_unpack()
-exportmakeopts() {
- local myopts
-
- if use mozsha1 ; then
- myopts="${myopts} MOZILLA_SHA1=YesPlease"
- elif use ppcsha1 ; then
- myopts="${myopts} PPC_SHA1=YesPlease"
- fi
-
- if use curl ; then
- use webdav || myopts="${myopts} NO_EXPAT=YesPlease"
- else
- myopts="${myopts} NO_CURL=YesPlease"
- use webdav && ewarn "USE=webdav only matters with USE=curl. Ignoring."
- fi
-
- myopts="${myopts} WITH_SEND_EMAIL=YesPlease"
-
- # Older python versions need own subproccess.py
- python_version
- [[ ${PYVER} < 2.4 ]] && myopts="${myopts} WITH_OWN_SUBPROCESS_PY=YesPlease"
-
- use elibc_uclibc && myopts="${myopts} NO_ICONV=YesPlease"
-
- export MY_MAKEOPTS=${myopts}
-}
-
-src_unpack() {
- git_src_unpack
- cd ${S}
-
- sed -i \
- -e "s:^\(CFLAGS = \).*$:\1${CFLAGS} -Wall:" \
- -e "s:^\(LDFLAGS = \).*$:\1${LDFLAGS}:" \
- -e "s:^\(CC = \).*$:\1$(tc-getCC):" \
- -e "s:^\(AR = \).*$:\1$(tc-getAR):" \
- Makefile || die "sed failed"
-
- exportmakeopts
-}
-
-src_compile() {
- emake \
- ${MY_MAKEOPTS} \
- prefix=/usr \
- || die "make failed"
- emake \
- doc \
- ${MY_MAKEOPTS} \
- prefix=/usr \
- || die "make doc failed"
-
- if use emacs ; then
- elisp-compile contrib/emacs/{,vc-}git.el || die "emacs modules failed"
- fi
-}
-
-src_install() {
- emake \
- install \
- ${MY_MAKEOPTS} \
- DESTDIR="${D}" \
- prefix=/usr \
- || die "make install failed"
- emake \
- install-doc \
- ${MY_MAKEOPTS} \
- DESTDIR="${D}" \
- prefix=/usr \
- mandir='$(prefix)/share/man' \
- || die "make install-doc failed"
-
- use X || rm "${D}"/usr/bin/gitk
-
- dodoc README COPYING Documentation/SubmittingPatches
- dodoc Documentation/technical/*
-
- prepman
-
- if use emacs ; then
- insinto "${SITELISP}"
- doins contrib/emacs/{,vc-}git.el*
- elisp-site-file-install "${FILESDIR}"/70git-gentoo.el
- fi
-
- newinitd "${FILESDIR}"/git-daemon.initd git-daemon
- newconfd "${FILESDIR}"/git-daemon.confd git-daemon
-}
-
-src_test() {
- cd "${S}"
- make ${MY_MAKEOPTS} test || die "tests failed"
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
- einfo
- einfo "If you want to import arch repositories into git, consider using the"
- einfo "git-archimport command. You should install dev-util/tla before"
- einfo
- einfo "If you want to import cvs repositories into git, consider using the"
- einfo "git-cvsimport command. You should install >=dev-util/cvsps-2.1 before"
- einfo
- einfo "If you want to import svn repositories into git, consider using the"
- einfo "git-svnimport command. You should install dev-util/subversion before"
- einfo
- einfo "If you want to use the included CVS server you will need to install"
- einfo "dev-perl/DBI and dev-perl/DBD-SQLite"
- einfo
-}
-
-pkg_postrm() {
- # regenerate site-gentoo if we are merged USE=emacs and unmerged
- # USE=-emacs
- has_version virtual/emacs && elisp-site-regen
-}