summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Scherbaum <dertobi123@gentoo.org>2009-05-17 11:51:02 +0000
committerTobias Scherbaum <dertobi123@gentoo.org>2009-05-17 11:51:02 +0000
commitb4ca3f10cd0ebb5a9f1a43d1ac57a3e5df6a0209 (patch)
tree2279dda04fd8d6e3fb5faa395405d301c383781b /sys-apps/cpqarrayd/cpqarrayd-2.3.ebuild
parentmake idoutils (diff)
downloaddertobi123-b4ca3f10cd0ebb5a9f1a43d1ac57a3e5df6a0209.tar.gz
dertobi123-b4ca3f10cd0ebb5a9f1a43d1ac57a3e5df6a0209.tar.bz2
dertobi123-b4ca3f10cd0ebb5a9f1a43d1ac57a3e5df6a0209.zip
Move from gentoo-de overlay to this shiny new place, also bump to 2.3
svn path=/; revision=50
Diffstat (limited to 'sys-apps/cpqarrayd/cpqarrayd-2.3.ebuild')
-rw-r--r--sys-apps/cpqarrayd/cpqarrayd-2.3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sys-apps/cpqarrayd/cpqarrayd-2.3.ebuild b/sys-apps/cpqarrayd/cpqarrayd-2.3.ebuild
new file mode 100644
index 0000000..b379e48
--- /dev/null
+++ b/sys-apps/cpqarrayd/cpqarrayd-2.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/cpqarrayd/cpqarrayd-2.2.ebuild,v 1.1 2006/04/01 09:14:07 dertobi123 Exp $
+
+DESCRIPTION="Compaq Arraycontroller Daemon"
+HOMEPAGE="http://www.strocamp.net/opensource/cpqarrayd.php"
+SRC_URI="http://www.strocamp.net/opensource/compaq/downloads/${P}.tar.gz"
+
+IUSE="snmp"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="snmp? ( net-analyzer/net-snmp )"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ econf \
+ $(use_enable snmp snmptrap ) \
+ || die "Configure failed"
+
+ emake || die "Make failed"
+}
+
+src_install() {
+ einstall
+
+ dodoc NEWS AUTHORS README
+
+ newinitd "${FILESDIR}"/cpqarrayd.init cpqarrayd
+ newconfd "${FILESDIR}"/cpqarrayd.confd cpqarrayd
+}