summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/ndoutils/ndoutils-1.4_beta3.ebuild')
-rw-r--r--net-analyzer/ndoutils/ndoutils-1.4_beta3.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/net-analyzer/ndoutils/ndoutils-1.4_beta3.ebuild b/net-analyzer/ndoutils/ndoutils-1.4_beta3.ebuild
new file mode 100644
index 0000000..e6e8083
--- /dev/null
+++ b/net-analyzer/ndoutils/ndoutils-1.4_beta3.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-plugins-snmp/nagios-plugins-snmp-0.5.5.ebuild,v 1.1 2007/06/07 06:43:34 dertobi123 Exp $
+
+MY_P=${P/_beta/b}
+
+DESCRIPTION="Nagios addon to store Nagios data in a MySQL database"
+HOMEPAGE="http://www.nagios.org"
+SRC_URI="mirror://sourceforge/nagios/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="dev-db/mysql"
+RDEPEND="${DEPEND}
+ >=net-analyzer/nagios-core-2.7"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ enewgroup nagios
+ enewuser nagios -1 /bin/bash /var/nagios/home nagios
+}
+
+src_compile() {
+ econf \
+ --prefix=/usr/nagios \
+ --sysconfdir=/etc/nagios \
+ --enable-mysql \
+ --disable-pgsql || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ dodir /usr/nagios/bin
+ cp ${S}/src/{file2sock,log2ndo,ndo2db-2x,ndomod-2x.o,sockdebug} ${D}/usr/nagios/bin
+
+ dodir /usr/nagios/share/
+ cp -R ${S}/db ${D}/usr/nagios/share
+
+ chown -R nagios:nagios ${D}/usr/nagios || die "Failed chown of ${D}/usr/nagios"
+ chmod 750 ${D}/usr/nagios/bin/{file2sock,log2ndo,ndo2db-2x,ndomod-2x.o,sockdebug} || "Failed chmod"
+
+ dodoc README REQUIREMENTS TODO UPGRADING Changelog "docs/NDOUTILS DB Model.pdf" "docs/NDOUtils Documentation.pdf"
+
+cat << EOF > "${T}"/55-ndoutils-revdep
+SEARCH_DIRS="/usr/nagios/bin"
+EOF
+
+ insinto /etc/revdep-rebuild
+ doins "${T}"/55-ndoutils-revdep
+}