summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Huettel (dilfridge) <dilfridge@gentoo.org>2015-07-19 17:21:49 +0200
committerAndreas K. Huettel (dilfridge) <dilfridge@gentoo.org>2015-07-19 17:22:38 +0200
commit0f578ea2af316600c4f4601cb9118833b8d85bdf (patch)
tree5e5730f2ccb2ccdccafebd95f6d4b343083ad5bc /media-gfx
parent[ur-profile] add some useflags for the armadillo (diff)
downloaddilfridge-0f578ea2af316600c4f4601cb9118833b8d85bdf.tar.gz
dilfridge-0f578ea2af316600c4f4601cb9118833b8d85bdf.tar.bz2
dilfridge-0f578ea2af316600c4f4601cb9118833b8d85bdf.zip
[media-gfx/album] copy from main tree
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/album/Manifest2
-rw-r--r--media-gfx/album/album-4.07.ebuild40
-rw-r--r--media-gfx/album/metadata.xml9
3 files changed, 51 insertions, 0 deletions
diff --git a/media-gfx/album/Manifest b/media-gfx/album/Manifest
new file mode 100644
index 0000000..0baf295
--- /dev/null
+++ b/media-gfx/album/Manifest
@@ -0,0 +1,2 @@
+DIST album-4.07.tar.gz 619238 SHA256 eed9a3abe206397afaf21f445178845aa38159f359dc0dffd3174dd8b26ae0e8 SHA512 dde914a8a0f0dd5896d069ad22c47db645f1acefc9c2d1a7047862185e3b96b0c4fb2c9681d8838eaf3de40b49082b9c06d848340aa92ecb8f398d9fd31273ba WHIRLPOOL 2fbcf5ce69a45b8b1005e2aa4642be17066eea74f5a9573ac074106595eedf1d69bc72135ae1939e80400c98afd4347964662d6380cf629046317dfd6bc1b4e0
+DIST data-4.05.tar.gz 6468036 SHA256 e1ee211d652f886494b84e957cd9a2f34b8a6b1fb3adad320484a62ce30debc6 SHA512 a7c577df6d10dc2db53fa6d469d2cf9c5115de99df47e79f31ecc0b009bd12e654e4ca7b9e6e78abe90a8a87d5f52ca9946a2d632e3f219d9bcb5ab7838ce42e WHIRLPOOL 00831d65b611652301310b743276cdd5434a9702c8a92a220267aa8ccf28783aaef7e9de57f8493f446e261c14eb7020ea4edd1a2dfdf4942d17f88c051b6800
diff --git a/media-gfx/album/album-4.07.ebuild b/media-gfx/album/album-4.07.ebuild
new file mode 100644
index 0000000..406220c
--- /dev/null
+++ b/media-gfx/album/album-4.07.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/album/album-4.07.ebuild,v 1.3 2012/09/30 18:05:38 armin76 Exp $
+
+EAPI=4
+
+DESCRIPTION="HTML photo album generator"
+HOMEPAGE="http://MarginalHacks.com/Hacks/album/"
+SRC_URI="http://marginalhacks.com/bin/album.versions/${P}.tar.gz
+ http://marginalhacks.com/bin/album.versions/data-4.05.tar.gz"
+
+LICENSE="marginalhacks"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 x86"
+IUSE="doc ffmpeg plugins themes"
+
+DEPEND=""
+RDEPEND="dev-lang/perl
+ media-gfx/imagemagick
+ media-gfx/jhead
+ ffmpeg? ( virtual/ffmpeg )"
+
+src_install() {
+ dobin album
+ doman album.1
+ dodoc License.txt CHANGELOG
+ use doc && dohtml -r Docs/*
+
+ dodir /usr/share/album
+ insinto /usr/share/album
+ cd ..
+ doins -r lang
+ use themes && doins -r Themes
+ use plugins && doins -r plugins
+}
+
+pkg_postinst() {
+ elog "For some optional tools please browse:"
+ elog "http://MarginalHacks.com/Hacks/album/tools/"
+}
diff --git a/media-gfx/album/metadata.xml b/media-gfx/album/metadata.xml
new file mode 100644
index 0000000..f99fc2d
--- /dev/null
+++ b/media-gfx/album/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>graphics</herd>
+<use>
+ <flag name="plugins">Install optional plugins</flag>
+ <flag name="themes">Install optional themes</flag>
+</use>
+</pkgmetadata>