summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/e2fsprogs/e2fsprogs-1.46.3-r100.ebuild')
-rw-r--r--sys-fs/e2fsprogs/e2fsprogs-1.46.3-r100.ebuild139
1 files changed, 0 insertions, 139 deletions
diff --git a/sys-fs/e2fsprogs/e2fsprogs-1.46.3-r100.ebuild b/sys-fs/e2fsprogs/e2fsprogs-1.46.3-r100.ebuild
deleted file mode 100644
index e8d1ce6..0000000
--- a/sys-fs/e2fsprogs/e2fsprogs-1.46.3-r100.ebuild
+++ /dev/null
@@ -1,139 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit flag-o-matic systemd toolchain-funcs multilib-minimal udev usr-ldscript
-
-DESCRIPTION="Standard EXT2/EXT3/EXT4 filesystem utilities and libraries"
-HOMEPAGE="http://e2fsprogs.sourceforge.net/"
-SRC_URI="https://www.kernel.org/pub/linux/kernel/people/tytso/e2fsprogs/v${PV}/${P}.tar.xz
- elibc_mintlib? ( mirror://gentoo/${PN}-1.42.9-mint-r1.patch.xz )"
-
-LICENSE="GPL-2 BSD"
-SLOT="0"
-#KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="cron fuse lto nls static-libs +threads elibc_FreeBSD"
-
-RDEPEND="
- >=sys-apps/util-linux-2.16
- cron? ( sys-fs/lvm2[-device-mapper-only(-)] )
- fuse? ( sys-fs/fuse:0 )
- nls? ( virtual/libintl )
- !sys-libs/com_err
- !sys-libs/ss
- !sys-libs/e2fsprogs-libs
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- nls? ( sys-devel/gettext )
- virtual/pkgconfig
- sys-apps/texinfo
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.40-fbsd.patch
- "${FILESDIR}"/${PN}-1.42.13-fix-build-cflags.patch #516854
-
- # Upstream patches (can usually removed with next version bump)
-)
-
-src_prepare() {
- if [[ ${CHOST} == *-mint* ]] ; then
- PATCHES+=( "${WORKDIR}"/${PN}-1.42.9-mint-r1.patch )
- fi
-
- default
-
- cp doc/RelNotes/v${PV}.txt ChangeLog || die "Failed to copy Release Notes"
-
- # # Get rid of doc -- we don't use them. This also prevents a sandbox
- # # violation due to mktexfmt invocation
- # rm -r doc || die "Failed to remove doc dir"
-}
-
-multilib_src_configure() {
- # Keep the package from doing silly things #261411
- export VARTEXFONTS="${T}/fonts"
-
- # needs open64() prototypes and friends
- append-cppflags -D_GNU_SOURCE
-
- local myeconfargs=(
- --with-root-prefix="${EPREFIX}"
- $(use_with cron crond-dir "${EPREFIX}/etc/cron.d")
- --with-systemd-unit-dir="$(systemd_get_systemunitdir)"
- --with-udev-rules-dir="${EPREFIX}$(get_udevdir)/rules.d"
- --enable-symlink-install
- --enable-elf-shlibs
- $(tc-has-tls || echo --disable-tls)
- $(use_enable fuse fuse2fs)
- $(use_enable nls)
- --disable-fsck
- --disable-uuidd
- $(use_enable lto)
- $(use_with threads pthread)
- )
-
- # we use blkid/uuid from util-linux now
- if use kernel_linux ; then
- export ac_cv_lib_{uuid_uuid_generate,blkid_blkid_get_cache}=yes
- myeconfargs+=( --disable-lib{blkid,uuid} )
- fi
-
- ac_cv_path_LDCONFIG=: \
- ECONF_SOURCE="${S}" \
- CC="$(tc-getCC)" \
- BUILD_CC="$(tc-getBUILD_CC)" \
- BUILD_LD="$(tc-getBUILD_LD)" \
- econf "${myeconfargs[@]}"
-
- if [[ ${CHOST} != *-uclibc ]] && grep -qs 'USE_INCLUDED_LIBINTL.*yes' config.{log,status} ; then
- eerror "INTL sanity check failed, aborting build."
- eerror "Please post your ${S}/config.log file as an"
- eerror "attachment to https://bugs.gentoo.org/show_bug.cgi?id=81096"
- die "Preventing included intl cruft from building"
- fi
-}
-
-multilib_src_compile() {
- emake V=1 COMPILE_ET=compile_et MK_CMDS=mk_cmds
-}
-
-multilib_src_install() {
- # need to set root_libdir= manually as any --libdir options in the
- # econf above (i.e. multilib) will screw up the default #276465
- emake \
- STRIP=: \
- root_libdir="${EPREFIX}/usr/$(get_libdir)" \
- DESTDIR="${D}" \
- install
-
- einstalldocs
-
- insinto /etc
- doins "${FILESDIR}"/e2fsck.conf
-
- # Move shared libraries to /lib/, install static libraries to
- # /usr/lib/, and install linker scripts to /usr/lib/.
- gen_usr_ldscript -a e2p ext2fs com_err ss $(usex kernel_linux '' 'uuid blkid')
-
- # configure doesn't have an option to disable static libs :/
- if ! use static-libs ; then
- find "${ED}" -name '*.a' -delete || die
- fi
-}
-
-multilib_src_test() {
- if multilib_is_native_abi; then
- emake V=1 check
- fi
-}
-
-multilib_src_install_all() {
- # Package installs same header twice -- use symlink instead
- dosym et/com_err.h /usr/include/com_err.h
-
- einstalldocs
-}
-