summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2011-11-02 23:22:47 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2011-11-02 23:52:08 +0100
commitefd66a7c2d2a4d8c86ee6026ce87e1fa1c1743c9 (patch)
tree0176578c185a93cd564604cf361187e03a74d51b /app-backup
parentmetadata: enable thin-manifests (diff)
downloadeva-efd66a7c2d2a4d8c86ee6026ce87e1fa1c1743c9.tar.gz
eva-efd66a7c2d2a4d8c86ee6026ce87e1fa1c1743c9.tar.bz2
eva-efd66a7c2d2a4d8c86ee6026ce87e1fa1c1743c9.zip
app-backup/deja-dup: bump to 20.1
* Bump to EAPI 4 * Use versionator to not be bothered changing 18 to 20 * Do not have USE=debug * Do not have la files due to nautilus extension * Update dependencies according to configure.ac and NEWS * Drop unrecognized configure switches * LINGUAS handling is broken
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/deja-dup/Manifest1
-rw-r--r--app-backup/deja-dup/deja-dup-20.1.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/app-backup/deja-dup/Manifest b/app-backup/deja-dup/Manifest
new file mode 100644
index 0000000..4a632e8
--- /dev/null
+++ b/app-backup/deja-dup/Manifest
@@ -0,0 +1 @@
+DIST deja-dup-20.1.tar.bz2 1266551 RMD160 1506b0d1056ffcfd2d817a113e4a92010b9896a1 SHA1 068f1bc31eebdad6906a448a68c9b73a9257e7e8 SHA256 c47db5e83e7079da7232b05c6109cd13af0cc6c3f956f4e91a473a66288ce75f
diff --git a/app-backup/deja-dup/deja-dup-20.1.ebuild b/app-backup/deja-dup/deja-dup-20.1.ebuild
new file mode 100644
index 0000000..c64464c
--- /dev/null
+++ b/app-backup/deja-dup/deja-dup-20.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/deja-dup/deja-dup-18.1.1.ebuild,v 1.3 2011/06/29 20:16:29 jlec Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2 versionator
+
+MAJORV="$(get_major_version ${PV})"
+
+DESCRIPTION="Simple backup tool using duplicity back-end"
+HOMEPAGE="https://launchpad.net/deja-dup/"
+SRC_URI="http://launchpad.net/${PN}/${MAJORV}/${PV}/+download/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nautilus nls"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.26:2
+ >=x11-libs/gtk+-3:3
+ >=x11-libs/libnotify-0.7.1
+
+ >=app-backup/duplicity-0.6.14
+ gnome-base/libgnome-keyring
+
+ nautilus? ( >=gnome-base/nautilus-3 )"
+RDEPEND="${COMMON_DEPEND}
+ gnome-base/gvfs[fuse]"
+DEPEND="${COMMON_DEPEND}
+ dev-perl/Locale-gettext
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.40
+ >=sys-devel/gettext-0.17
+ dev-util/itstool
+ dev-libs/libxml2"
+
+pkg_setup() {
+ DOCS="NEWS AUTHORS"
+ G2CONF="${G2CONF}
+ $(use_enable nls)
+ $(use_with nautilus)
+ --without-unity
+ --disable-static
+ --disable-schemas-compile"
+ # FIXME: Broken man rules when LINGUAS != *
+ #use nls || { unset LINGUAS || export LINGUAS=""; }
+ export LINGUAS=""
+ use nls && export LINGUAS="*"
+}