summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2012-06-04 09:18:53 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2012-06-04 09:18:53 +0200
commit9d89034c5d012fafc9b2014170a3240b7f282cd8 (patch)
tree609d691388b01029649a43a683751681a60bb394 /dev-python
parentadd missing support files (diff)
downloadeva-9d89034c5d012fafc9b2014170a3240b7f282cd8.tar.gz
eva-9d89034c5d012fafc9b2014170a3240b7f282cd8.tar.bz2
eva-9d89034c5d012fafc9b2014170a3240b7f282cd8.zip
dev-python/readability-lxml: initial ebuild
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/readability-lxml/readability-lxml-9999.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/readability-lxml/readability-lxml-9999.ebuild b/dev-python/readability-lxml/readability-lxml-9999.ebuild
new file mode 100644
index 0000000..e451781
--- /dev/null
+++ b/dev-python/readability-lxml/readability-lxml-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="4"
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit git-2 distutils
+
+DESCRIPTION="Fast python port of arc90's readability tool"
+HOMEPAGE="https://github.com/buriy/python-readability"
+EGIT_REPO_URI="git://github.com/EvaSDK/python-readability.git"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-python/lxml
+ dev-python/chardet
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools
+"