summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2023-12-17 17:03:32 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2023-12-17 17:03:32 +0100
commit60e268670084ca405d86ea019730ce552950acc8 (patch)
tree60ac28ac1ec56168787fc33ed09310a92282eb7a
parentdropped zynaddsubfx as a new ebuild is going to be merged into the main tree (diff)
downloadfordfrog-60e268670084ca405d86ea019730ce552950acc8.tar.gz
fordfrog-60e268670084ca405d86ea019730ce552950acc8.tar.bz2
fordfrog-60e268670084ca405d86ea019730ce552950acc8.zip
dropped scripts
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
-rwxr-xr-xscripts/netbeans/check_binary_lists.sh34
-rwxr-xr-xscripts/netbeans/copy_to_tree.sh24
-rwxr-xr-xscripts/netbeans/create_new_release.sh24
-rwxr-xr-xscripts/netbeans/update_changelog.sh19
4 files changed, 0 insertions, 101 deletions
diff --git a/scripts/netbeans/check_binary_lists.sh b/scripts/netbeans/check_binary_lists.sh
deleted file mode 100755
index a77f5307b..000000000
--- a/scripts/netbeans/check_binary_lists.sh
+++ /dev/null
@@ -1,34 +0,0 @@
-#!/bin/bash
-
-OLD_DIR="${1}"
-NEW_DIR="${2}"
-
-if [[ -z "${OLD_DIR}" ]] || [[ -z "${NEW_DIR}" ]]; then
- echo "Usage: <old_dir> <new_dir>"
- exit 1
-fi
-
-if [ ! -d "${OLD_DIR}" ] ; then
- echo "ERROR: old_dir does not exist or is not directory!"
- exit 1
-fi
-
-if [ ! -d "${NEW_DIR}" ] ; then
- echo "ERROR: new_dir does not exist or is not directory!"
- exit 1
-fi
-
-pushd "${NEW_DIR}" >> /dev/null
-
-for file in `ls */external/binaries-list`; do
- RESULT=`diff "${OLD_DIR}"/$file $file`
-
- if [ -n "${RESULT}" ] ; then
- echo "${file}"
- diff "${OLD_DIR}"/$file $file
- fi
-done
-
-popd >> /dev/null
-
-echo "DONE."
diff --git a/scripts/netbeans/copy_to_tree.sh b/scripts/netbeans/copy_to_tree.sh
deleted file mode 100755
index 26162cc2b..000000000
--- a/scripts/netbeans/copy_to_tree.sh
+++ /dev/null
@@ -1,24 +0,0 @@
-#!/bin/bash
-
-ROOT=$(dirname $(dirname $(dirname $(readlink -f ${0}))))
-TREE=${1}
-VERSION=${2}
-MESSAGE=${3}
-
-if [ -z "${TREE}" -o -z "${VERSION}" -o -z "${MESSAGE}" ]; then
- echo "Usage: ${0} <tree> <version> <message>"
- exit 1
-fi
-
-pushd ${ROOT} &> /dev/null
-
-for file in */*/*${VERSION}*.ebuild; do
- cp ${file} ${TREE}${file}
- pushd ${TREE}$(dirname ${file}) &> /dev/null
- cvs add $(basename ${file})
- echangelog "${MESSAGE}"
- ebuild $(basename ${file}) manifest
- popd &> /dev/null
-done
-
-popd &> /dev/null
diff --git a/scripts/netbeans/create_new_release.sh b/scripts/netbeans/create_new_release.sh
deleted file mode 100755
index d6a145e5c..000000000
--- a/scripts/netbeans/create_new_release.sh
+++ /dev/null
@@ -1,24 +0,0 @@
-#!/bin/bash
-
-OLD=${1}
-NEW=${2}
-SOURCE_URL=${3}
-
-if [[ -z "${OLD}" ]] || [[ -z "${NEW}" ]] || [[ -z "${SOURCE_URL}" ]] ; then
- echo "Usage: <old_version_string> <new_version_string> <new_source_url>"
- exit 1
-fi
-
-pushd $(dirname $(dirname $(dirname $(readlink -f ${0})))) >/dev/null || exit 1
-
-for file in */*netbeans*/*${OLD}*.ebuild ; do
- cp ${file} $(echo ${file} | sed "s/${OLD}/${NEW}/" | sed -E "s/-r[[:digit:]]+//") || exit 1
-done
-
-sed -i "s%SOURCE_URL=.*%SOURCE_URL=\"${SOURCE_URL}\"%" */*/*${NEW}*.ebuild || exit 1
-
-for file in */*/*${NEW}*.ebuild ; do
- ebuild ${file} manifest
-done
-
-popd >/dev/null || exit 1
diff --git a/scripts/netbeans/update_changelog.sh b/scripts/netbeans/update_changelog.sh
deleted file mode 100755
index f304fa12c..000000000
--- a/scripts/netbeans/update_changelog.sh
+++ /dev/null
@@ -1,19 +0,0 @@
-#!/bin/bash
-DIR=${1}
-MESSAGE=${2}
-
-if [[ -z "${DIR}" ]] || [[ -z "${MESSAGE}" ]] ; then
- echo "Usage: <repo_root_directory> <message>"
- exit 1
-fi
-
-pushd "${1}" >/dev/null || exit 1
-for dir in dev-*/netbeans*; do
- pushd "${dir}"
- echangelog "${MESSAGE}"
- ebuild `ls *.ebuild | tail -n1` digest
- popd
-done
-popd >/dev/null || exit 1
-
-echo "DONE!"