summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2019-08-16 17:49:32 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2019-08-16 17:50:00 +0200
commit9deff9f98b7d982c0e331e3627f6ab11751323d5 (patch)
treecd9542f74784968c3c85ca3e3da42fc717743a06 /dev-util/netbeans-standalone/netbeans-standalone-9999.ebuild
parentdev-util/netbeans: added live ebuild + 11.1 (diff)
downloadfordfrog-9deff9f98b7d982c0e331e3627f6ab11751323d5.tar.gz
fordfrog-9deff9f98b7d982c0e331e3627f6ab11751323d5.tar.bz2
fordfrog-9deff9f98b7d982c0e331e3627f6ab11751323d5.zip
dev-util/netbeans-9999: ebuild cleanup and fixes
* cleanup and fixes provided by Marco Genasci <fedeliallalinea@gmail.com> * added some minor improvements in wording Bug: https://bugs.gentoo.org/685782 Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-util/netbeans-standalone/netbeans-standalone-9999.ebuild')
-rw-r--r--dev-util/netbeans-standalone/netbeans-standalone-9999.ebuild57
1 files changed, 48 insertions, 9 deletions
diff --git a/dev-util/netbeans-standalone/netbeans-standalone-9999.ebuild b/dev-util/netbeans-standalone/netbeans-standalone-9999.ebuild
index 989f263ec..bda59d1cf 100644
--- a/dev-util/netbeans-standalone/netbeans-standalone-9999.ebuild
+++ b/dev-util/netbeans-standalone/netbeans-standalone-9999.ebuild
@@ -10,6 +10,7 @@ if [ ${PV} = "9999" ]; then
EGIT_REPO_URI="https://github.com/apache/netbeans.git"
else
inherit java-pkg-2 java-ant-2 desktop
+ KEYWORDS="~amd64"
SRC_URI="https://github.com/apache/netbeans/archive/${PV}.zip -> ${P}.zip"
S=${WORKDIR}/netbeans-${PV}
fi
@@ -17,8 +18,7 @@ fi
DESCRIPTION="Apache Netbeans IDE"
HOMEPAGE="https://netbeans.apache.org/"
LICENSE="Apache-2.0"
-SLOT=$(ver_cut 1-1)
-KEYWORDS="~amd64"
+SLOT="$(ver_cut 1-1)"
IUSE=""
DEPEND=">=virtual/jdk-1.8:*"
@@ -27,28 +27,67 @@ RDEPEND=">=virtual/jdk-1.8:*"
JAVA_PKG_BSFIX="off"
INSTALL_DIR=/usr/share/${PN}-${SLOT}
+pkg_pretend() {
+ if has network-sandbox ${FEATURES}; then
+ eerror
+ eerror "Netbeans downloads a lot of dependencies during the build"
+ eerror "process, so you need to disable network-sandbox feature"
+ eerror "to make this ebuild proceed (FEATURES=-network-sandbox)."
+ eerror "You can also use package.env to disable this feature"
+ eerror "for the package, see:"
+ eerror
+ eerror " https://wiki.gentoo.org/wiki//etc/portage/package.env"
+ eerror
+ die "network-sandbox is enabled, disable it to proceed";
+ fi
+}
+
src_compile() {
eant -Dcluster.config=full -Dpermit.jdk9.builds=true -Dbinaries.cache="${S}"/.hgexternalcache || die "Failed to compile"
}
+QA_PREBUILT="
+ usr/share/netbeans-standalone-11/ide/bin/nativeexecution/Linux-x86_64/process_start
+ usr/share/netbeans-standalone-11/ide/bin/nativeexecution/Linux-x86_64/stat
+ usr/share/netbeans-standalone-11/ide/bin/nativeexecution/Linux-x86_64/pty_open
+ usr/share/netbeans-standalone-11/ide/bin/nativeexecution/Linux-x86_64/sigqueue
+ usr/share/netbeans-standalone-11/ide/bin/nativeexecution/Linux-x86_64/unbuffer.so
+ usr/share/netbeans-standalone-11/ide/bin/nativeexecution/Linux-x86_64/killall
+ usr/share/netbeans-standalone-11/ide/bin/nativeexecution/Linux-x86_64/pty
+ usr/share/netbeans-standalone-11/profiler/lib/deployed/jdk16/linux-amd64/libprofilerinterface.so
+ usr/share/netbeans-standalone-11/profiler/lib/deployed/jdk15/linux-amd64/libprofilerinterface.so
+ usr/share/netbeans-standalone-11/profiler/lib/deployed/cvm/linux/libprofilerinterface_g.so
+ usr/share/netbeans-standalone-11/profiler/lib/deployed/cvm/linux/libprofilerinterface.so
+ usr/share/netbeans-standalone-11/platform/modules/lib/amd64/linux/libjnidispatch-440.so
+ usr/share/netbeans-standalone-11/profiler/lib/deployed/jdk16/linux-amd64/libprofilerinterface.so
+"
+
src_install() {
pushd nbbuild/netbeans >/dev/null || die
insinto ${INSTALL_DIR}
doins -r .
+
+ rm -fr "${ED}"/${INSTALL_DIR}/ide/bin/nativeexecution/{Linux-{sparc_64,x86},MacOSX-{x86_64,x86},SunOS-{sparc,sparc_64,x86,x86_64},Windows-{x86,x86_64}} || die "Failed to remove unused binaries"
+ rm -fr "${ED}"/${INSTALL_DIR}/profiler/lib/deployed/jdk15/{hpux-pa_risc2.0{,w},linux,mac,solaris-{amd64,i386,sparc{,v9}},windows{,-amd64}} || die "Failed to remove unused libraries"
+ rm -fr "${ED}"/${INSTALL_DIR}/profiler/lib/deployed/jdk16/{hpux-pa_risc2.0{,w},linux{,-arm,-arm-vfp-hflt},mac,solaris-{amd64,i386,sparc{,v9}},windows{,-amd64}} || die "Failed to remove unused libraries"
+ rm -fr "${ED}"/${INSTALL_DIR}/profiler/lib/deployed/cvm/windows || die "Failed to remove unused libraries"
+ rm -fr "${ED}"/${INSTALL_DIR}/platform/modules/lib/{i386,x86} || die "Failed to remove unused libraries"
+ find "${ED}"/${INSTALL_DIR}/ \( -name *.exe -o -name *.dll \) -type f -exec rm {} + || die "Failed to remove unused libraries"
+
dodoc DEPENDENCIES NOTICE
dosym ${INSTALL_DIR}/bin/netbeans /usr/bin/${PN}-${SLOT}
fperms 755 ${INSTALL_DIR}/bin/netbeans
insinto /etc/${PN}-${SLOT}
doins etc/*
- rm -fr "${D}"/${INSTALL_DIR}/etc
+ rm -fr "${ED}"/${INSTALL_DIR}/etc
dosym ../../../../etc/${PN}-${SLOT} ${INSTALL_DIR}/etc
- sed -i -e "s/#netbeans_jdkhome.*/netbeans_jdkhome=\$\(java-config -O\)/g" "${D}"/etc/${PN}-${SLOT}/netbeans.conf || die "Failed to set set Netbeans JDK home"
+ sed -i -e "s/#netbeans_jdkhome.*/netbeans_jdkhome=\$\(java-config -O\)/g" "${ED}"/etc/${PN}-${SLOT}/netbeans.conf || die "Failed to set set Netbeans JDK home"
- if [[ -e "${D}"/${INSTALL_DIR}/bin/netbeans ]]; then
- sed -i -e "s:\"\$progdir\"/../etc/:/etc/${PN}-${SLOT}/:" "${D}"/${INSTALL_DIR}/bin/netbeans
- sed -i -e "s:\"\${userdir}\"/etc/:/etc/${PN}-${SLOT}/:" "${D}"/${INSTALL_DIR}/bin/netbeans
+ if [[ -e "${ED}"/${INSTALL_DIR}/bin/netbeans ]]; then
+ sed -i -e "s:\"\$progdir\"/../etc/:/etc/${PN}-${SLOT}/:" "${ED}"/${INSTALL_DIR}/bin/netbeans
+ sed -i -e "s:\"\${userdir}\"/etc/:/etc/${PN}-${SLOT}/:" "${ED}"/${INSTALL_DIR}/bin/netbeans
fi
dodir /usr/share/icons/hicolor/32x32/apps
@@ -58,6 +97,6 @@ src_install() {
make_desktop_entry ${PN}-${SLOT} "Netbeans ${PV}" ${PN}-${SLOT} Development
- mkdir -p "${D}"/${INSTALL_DIR}/nb/config || die
- echo "NBGNT" > "${D}"/${INSTALL_DIR}/nb/config/productid || die
+ mkdir -p "${ED}"/${INSTALL_DIR}/nb/config || die
+ echo "NBGNT" > "${ED}"/${INSTALL_DIR}/nb/config/productid || die
}