summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/wput/wput-0.6.ebuild')
-rw-r--r--net-misc/wput/wput-0.6.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-misc/wput/wput-0.6.ebuild b/net-misc/wput/wput-0.6.ebuild
new file mode 100644
index 0000000..952d6fc
--- /dev/null
+++ b/net-misc/wput/wput-0.6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wput/wput-0.5.ebuild,v 1.2 2005/01/12 11:56:21 ka0ttic Exp $
+
+inherit eutils
+
+DESCRIPTION="A tiny program that looks like wget and is designed to upload files or whole directories to remote ftp-servers"
+HOMEPAGE="http://wput.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ~ppc ~sparc ~amd64"
+IUSE="debug"
+
+DEPEND=""
+RDEPEND="$DEPEND"
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-gentoo.diff"
+ # Fix bug 126828
+ epatch "${FILESDIR}/wput-0.6-respectldflags.patch"
+}
+
+src_compile() {
+ local myconf
+ use debug && myconf="--enable-memdbg=yes" || myconf="--enable-g-switch=no"
+ econf ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc ChangeLog INSTALL TODO
+}