summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <hans@degraaff.org>2024-08-05 08:17:00 +0200
committerHans de Graaff <hans@degraaff.org>2024-08-05 08:17:00 +0200
commit506482f6db9af5634cf78275085f806b8d0e535f (patch)
treefdf0bf1019c705c5a82e279214365752f892329a
parentdev-ruby/inifile: enable ruby33 (diff)
downloadgraaff-506482f6db9af5634cf78275085f806b8d0e535f.tar.gz
graaff-506482f6db9af5634cf78275085f806b8d0e535f.tar.bz2
graaff-506482f6db9af5634cf78275085f806b8d0e535f.zip
dev-ruby/rubocop: add 1.65.1
Signed-off-by: Hans de Graaff <hans@degraaff.org>
-rw-r--r--dev-ruby/rubocop/Manifest1
-rw-r--r--dev-ruby/rubocop/rubocop-1.65.1.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/dev-ruby/rubocop/Manifest b/dev-ruby/rubocop/Manifest
index 1c20d001..9e4f3339 100644
--- a/dev-ruby/rubocop/Manifest
+++ b/dev-ruby/rubocop/Manifest
@@ -2,3 +2,4 @@ DIST rubocop-1.62.1.tar.gz 2484709 BLAKE2B 8a14e27a2b115b3a1f5f6bd7370216ad6722e
DIST rubocop-1.63.5.tar.gz 2496760 BLAKE2B ddbd0753f6126256e877a53c1bcf42216cf54926f2d2e69f02de67f1c6eec70913502feafed4d6d4669f145b155816d8f0b028f97ee468e688ca472d689c2b2f SHA512 8ae0d104f634ae7d5c06ab183893ed51f12edb0f73771c4bce0f685320a7385642b7fb46756268920e7358f0232c35633c73ef0690fdd1e5c7fd7a15f0ee27d7
DIST rubocop-1.64.1.tar.gz 2506128 BLAKE2B 27d98933f631d5a8f17fe6fe2fe14817122a5867b15fc39e0cfe51a802c978c40cd0e70d53a6e2cb2ae70dddae0f39139eb00f5e28c2ebaa55993ee00fa65ed2 SHA512 5298065d6f1052210f84d4e8ab5c2afd9042da7620f49afcdaae0ebb6831b1436861975238012185c9c639f4ab1bcc736e45cacfcc94ab2b1303b086581f8028
DIST rubocop-1.65.0.tar.gz 2510192 BLAKE2B c3f2919a97649dde552bc0867caac5698c0151943731ef54c9f62f557aa1412fc37d0ab017bff5509ab05048a5a21bdf73c910027ce282f54d2ed3af6d2450d6 SHA512 ccdf5a7081a9275f325c1d71716ce67d775b83b6fe1ad95d806121de4a6fd1fc9d66fd8d54c408eac74037bc3a980ebdc583539120ecdf39f3c9f895454e557a
+DIST rubocop-1.65.1.tar.gz 2511599 BLAKE2B 5ccbb26ed23cb04ffe469ea2c7dcba8571b5cb1e3528705f55d33236af5a2307c3da0909a613591b080ecaeb1f90b5c8d6f44b65ff62cf563e349df62644f0aa SHA512 09c4e2e1d9ababd4e8aa295f2acdc19dfe19fa6674eea85ab82a3d10f13a5edb8f62e1fee858f746dd1fd05f4b23ecf13dd510236d545c1ca70a7b4d9e665276
diff --git a/dev-ruby/rubocop/rubocop-1.65.1.ebuild b/dev-ruby/rubocop/rubocop-1.65.1.ebuild
new file mode 100644
index 00000000..c8eb5278
--- /dev/null
+++ b/dev-ruby/rubocop/rubocop-1.65.1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRAINSTALL="assets config"
+RUBY_FAKEGEM_BINDIR="exe"
+
+RUBY_FAKEGEM_GEMSPEC="rubocop.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Ruby static code analyzer"
+HOMEPAGE="https://github.com/rubocop/rubocop"
+SRC_URI="https://github.com/rubocop/rubocop/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+ruby_add_rdepend "
+ >=dev-ruby/json-2.3:2
+ >=dev-ruby/language_server-protocol-3.17.0
+ >=dev-ruby/parallel-1.10:1
+ >=dev-ruby/parser-3.3.0.2
+ dev-ruby/rainbow:3
+ dev-ruby/regexp_parser:2
+ >=dev-ruby/rexml-3.2.5:3
+ >=dev-ruby/rubocop-ast-1.31.1:1
+ >=dev-ruby/ruby-progressbar-1.7:0
+ >=dev-ruby/unicode-display_width-2.4.0:2"
+
+ruby_add_bdepend "test? ( dev-ruby/bundler dev-ruby/rubocop-performance dev-ruby/webmock )"
+
+all_ruby_prepare() {
+ sed -e '/pry/ s:^:#:' \
+ -i spec/spec_helper.rb || die
+ sed -i -e "s:_relative ': './:" ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Avoid bundler spec
+ sed -e '/and the gem is bundled/,/^ end/ s:^:#:' \
+ -e '/when a file inherits from \(a url inheriting from a gem\|an unknown gem\)/ s/context/xcontext/' \
+ -e '/returns values from the gem config with local overrides/ s/it/xit/' \
+ -i spec/rubocop/config_loader_spec.rb || die
+ sed -i -e '/gem_versions_in_target/ s/describe/xdescribe/' spec/rubocop/config_spec.rb || die
+ sed -e '/when the extensions are loaded via inherit_gem/ s/context/xcontext/' \
+ -i spec/rubocop/config_obsoletion_spec.rb || die
+ sed -i -e '/bundler integration/,/^ end/ s:^:#:' spec/rubocop/cli_spec.rb || die
+ rm -f spec/rubocop/cli_spec.rb spec/rubocop/cli/suggest_extensions_spec.rb spec/rubocop/lockfile_spec.rb || die
+
+ # Avoid specs requiring rubocop-rake
+ sed -i -e '/compliance with rubocop/,/^ end/ s:^:#:' spec/rubocop/cop/generator_spec.rb || die
+
+ # Avoid specs requiring many rubocop extensions
+ rm -f spec/rubocop/version_spec.rb || die
+
+ # Avoid specs that are not functional and break too often in releases
+ sed -i -e '/has a unique contributor name/askip "too fragile"' spec/project_spec.rb || die
+
+ # Avoid spec that breaks when YJIT is enabled
+ sed -i -e '/logs the RuboCop version/ s/it/xit/' spec/rubocop/lsp/server_spec.rb || die
+
+ sed -e 's:/tmp/example:'"${TMPDIR}"'/example:' \
+ -e 's:/tmp/Gemfile:'"${TMPDIR}"'/Gemfile:' \
+ -i spec/rubocop/cop/team_spec.rb || die
+ sed -e 's:/tmp:'"${TMPDIR}"':' -i spec/rubocop/server/cli_spec.rb || die
+
+ # Disable the strict warnings check since we will have additional dependencies with warnings.
+ sed -e '/StrictWarnings.enable/ s:^:#:' \
+ -i spec/spec_helper.rb || die
+}