summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/overcommit/overcommit-0.47.0.ebuild9
1 files changed, 9 insertions, 0 deletions
diff --git a/dev-vcs/overcommit/overcommit-0.47.0.ebuild b/dev-vcs/overcommit/overcommit-0.47.0.ebuild
index 7cd26428..db9be97b 100644
--- a/dev-vcs/overcommit/overcommit-0.47.0.ebuild
+++ b/dev-vcs/overcommit/overcommit-0.47.0.ebuild
@@ -25,3 +25,12 @@ ruby_add_rdepend "
>=dev-ruby/childprocess-0.6.3:2
>=dev-ruby/iniparse-1.4:1
"
+
+each_ruby_install() {
+ each_fakegem_install
+
+ local hooks
+ hooks="$(ruby_fakegem_gemsdir)/gems/${RUBY_FAKEGEM_NAME}-${RUBY_FAKEGEM_VERSION}/template-dir/hooks"
+
+ fperms 0755 "${hooks}"/*
+}