aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2014-04-01 11:07:24 +0200
committerJohannes Huber <johu@gentoo.org>2014-04-01 11:07:24 +0200
commit2f53357bfc4eb6e86790076fce6b5f6223d16423 (patch)
treee41034945b7886471e67d863ef45e76de5ef72fc /net-irc
parent[profiles/categories] Add net-irc (diff)
downloadjohu-2f53357bfc4eb6e86790076fce6b5f6223d16423.tar.gz
johu-2f53357bfc4eb6e86790076fce6b5f6223d16423.tar.bz2
johu-2f53357bfc4eb6e86790076fce6b5f6223d16423.zip
[net-irc/quassel] Import from tree for maintenance
Package-Manager: portage-2.2.10
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/quassel/files/quassel.logrotate9
-rw-r--r--net-irc/quassel/files/quasselcore.conf22
-rw-r--r--net-irc/quassel/files/quasselcore.init63
-rw-r--r--net-irc/quassel/metadata.xml49
-rw-r--r--net-irc/quassel/quassel-9999.ebuild178
5 files changed, 321 insertions, 0 deletions
diff --git a/net-irc/quassel/files/quassel.logrotate b/net-irc/quassel/files/quassel.logrotate
new file mode 100644
index 0000000..8e72083
--- /dev/null
+++ b/net-irc/quassel/files/quassel.logrotate
@@ -0,0 +1,9 @@
+/var/log/quassel.log {
+ compress
+ rotate 4
+ weekly
+ delaycompress
+ copytruncate
+ missingok
+ notifempty
+}
diff --git a/net-irc/quassel/files/quasselcore.conf b/net-irc/quassel/files/quasselcore.conf
new file mode 100644
index 0000000..6e1304d
--- /dev/null
+++ b/net-irc/quassel/files/quasselcore.conf
@@ -0,0 +1,22 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+# Loglevel Debug|Info|Warning|Error. Default is: Info
+# The logfile is located at /var/log/quassel.log.
+#LOGLEVEL="Info"
+
+# The address(es) quasselcore will listen on. Default is 0.0.0.0
+#LISTEN="0.0.0.0"
+
+# The port quasselcore will listen at. Default is: 4242
+#PORT="4242"
+
+# User we want our daemon to run under.
+#USER="quassel"
+
+# Directory we store all quasselcore content.
+#CONFIGDIR="/var/lib/quassel"
+
+# File quasselcore will log all its events into.
+#LOGFILE="/var/log/quassel.log" \ No newline at end of file
diff --git a/net-irc/quassel/files/quasselcore.init b/net-irc/quassel/files/quasselcore.init
new file mode 100644
index 0000000..06d73cb
--- /dev/null
+++ b/net-irc/quassel/files/quasselcore.init
@@ -0,0 +1,63 @@
+#!/sbin/runscript
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+depend() {
+ need localmount net
+ after bootmisc postgres
+}
+
+CORE="$(which quasselcore)"
+PID="/var/run/quassel.pid"
+LOGFILE=${LOGFILE:-"/var/log/quassel.log"}
+CONFIGDIR=${CONFIGDIR:-"/var/lib/quassel"}
+QUASSEL_USER=${QUASSEL_USER:-"quassel"}
+
+checkconfig() {
+ # set defaults
+ LOGLEVEL=${LOGLEVEL:-"Info"}
+
+ # check config folder
+ if [ ! -d "${CONFIGDIR}" ]; then
+ mkdir "${CONFIGDIR}" || return 1
+ fi
+ # permissions always changed just to avoid runtime issues
+ chown -R "${QUASSEL_USER}":"${QUASSEL_USER}" "${CONFIGDIR}" || return 1
+
+ # check log file
+ if [ ! -e "${LOGFILE}" ]; then
+ touch "${LOGFILE}" || return 1
+ fi
+ # permissions always changed just to avoid runtime issues
+ chown "${QUASSEL_USER}":"${QUASSEL_USER}" "${LOGFILE}" || return 1
+}
+
+start() {
+ checkconfig || return 1
+
+ ebegin "Starting Quassel Core"
+
+ if [ -n "${RC_UNAME}" ]; then
+ # running on baselayout-2/openrc
+ start-stop-daemon --start --user "${QUASSEL_USER}" --background --make-pidfile \
+ --pidfile "${PID}" \
+ --exec "${CORE}" -- --logfile="${LOGFILE}" --loglevel="${LOGLEVEL}" \
+ ${LISTEN:+--listen="${LISTEN}"} ${PORT:+--port="${PORT}"} \
+ --configdir="${CONFIGDIR}"
+ else
+ # running on baselayout-1
+ start-stop-daemon --start --chuid "${QUASSEL_USER}" --background --make-pidfile \
+ --pidfile "${PID}" --env HOME="${CONFIGDIR}" \
+ --exec "${CORE}" -- --logfile="${LOGFILE}" --loglevel="${LOGLEVEL}" \
+ ${LISTEN:+--listen="${LISTEN}"} ${PORT:+--port="${PORT}"} \
+ --configdir="${CONFIGDIR}"
+ fi
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping Quassel Core"
+ start-stop-daemon --stop --pidfile "${PID}" --exec "${CORE}"
+ eend $?
+}
diff --git a/net-irc/quassel/metadata.xml b/net-irc/quassel/metadata.xml
new file mode 100644
index 0000000..2703085
--- /dev/null
+++ b/net-irc/quassel/metadata.xml
@@ -0,0 +1,49 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-irc</herd>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>patrick@gentoo.org</email>
+ </maintainer>
+ <maintainer>
+ <email>johu@gentoo.org</email>
+ <name>Johannes Huber</name>
+ </maintainer>
+ <maintainer>
+ <email>sputnick@quassel-irc.org</email>
+ <description>Upstream author, please CC on bugs</description>
+ </maintainer>
+ <use>
+ <flag name="monolithic">
+ Build Standalone client with integrated core, no external
+ quasselcore needed. Only useful if you don't want to use quassels
+ client/server model. The server and X flags are not needed in this
+ case but it is possible to enable them too.
+ </flag>
+ <flag name="phonon">
+ Build client with phonon backend support. This enables sound
+ playback in client.
+ </flag>
+ <flag name="server">
+ Build the server binary. If this USE flag is disabled, the
+ 'core' server binary for quassel is not built, and cannot be
+ used. You need this enabled on the server, but you might want to
+ disable it on the client.
+ </flag>
+ <flag name="webkit">
+ Use qt-webkit rendering engine for showing URL thumbnails and
+ for other things that need web browser integration.
+ </flag>
+ <flag name="X">
+ Build the Qt 4 GUI client for quassel. If this USE flag is
+ disabled, the GUI is not built, and cannot be used. You might
+ want to disable this on the server, but you need it enabled on
+ the client.
+ </flag>
+ <flag name="crypt">
+ Support core->network per-channel and per-query blowfish
+ encryption via <pkg>app-crypt/qca:2</pkg>.
+ </flag>
+ </use>
+</pkgmetadata>
diff --git a/net-irc/quassel/quassel-9999.ebuild b/net-irc/quassel/quassel-9999.ebuild
new file mode 100644
index 0000000..b0c8647
--- /dev/null
+++ b/net-irc/quassel/quassel-9999.ebuild
@@ -0,0 +1,178 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/quassel-9999.ebuild,v 1.69 2014/03/27 00:44:32 mrueg Exp $
+
+EAPI=5
+
+inherit cmake-utils eutils pax-utils user versionator
+
+EGIT_REPO_URI="git://git.quassel-irc.org/quassel.git"
+EGIT_BRANCH="master"
+[[ "${PV}" == "9999" ]] && inherit git-2
+
+QT_MINIMAL="4.6.0"
+KDE_MINIMAL="4.4"
+
+DESCRIPTION="Qt4/KDE4 IRC client supporting a remote daemon for 24/7 connectivity."
+HOMEPAGE="http://quassel-irc.org/"
+[[ "${PV}" == "9999" ]] || SRC_URI="http://quassel-irc.org/pub/${P/_/-}.tar.bz2"
+
+LICENSE="GPL-3"
+KEYWORDS=""
+SLOT="0"
+IUSE="ayatana crypt dbus debug kde monolithic phonon postgres +server +ssl syslog webkit X"
+
+SERVER_RDEPEND="
+ >=dev-qt/qtscript-${QT_MINIMAL}:4
+ crypt? (
+ app-crypt/qca:2
+ app-crypt/qca-ossl
+ )
+ !postgres? ( >=dev-qt/qtsql-${QT_MINIMAL}:4[sqlite] dev-db/sqlite:3[threadsafe(+),-secure-delete] )
+ postgres? ( >=dev-qt/qtsql-${QT_MINIMAL}:4[postgres] )
+ syslog? ( virtual/logger )
+"
+
+GUI_RDEPEND="
+ >=dev-qt/qtgui-${QT_MINIMAL}:4
+ ayatana? ( dev-libs/libindicate-qt )
+ dbus? (
+ >=dev-qt/qtdbus-${QT_MINIMAL}:4
+ dev-libs/libdbusmenu-qt
+ )
+ kde? (
+ >=kde-base/kdelibs-${KDE_MINIMAL}
+ >=kde-base/oxygen-icons-${KDE_MINIMAL}
+ ayatana? ( kde-misc/plasma-widget-message-indicator )
+ )
+ phonon? ( || ( media-libs/phonon >=dev-qt/qtphonon-${QT_MINIMAL}:4 ) )
+ webkit? ( >=dev-qt/qtwebkit-${QT_MINIMAL}:4 )
+"
+
+RDEPEND="
+ >=dev-qt/qtcore-${QT_MINIMAL}:4[ssl?]
+ monolithic? (
+ ${SERVER_RDEPEND}
+ ${GUI_RDEPEND}
+ )
+ !monolithic? (
+ server? ( ${SERVER_RDEPEND} )
+ X? ( ${GUI_RDEPEND} )
+ )
+ "
+DEPEND="${RDEPEND}
+ kde? ( dev-util/automoc )"
+
+DOCS="AUTHORS ChangeLog README"
+
+S="${WORKDIR}/${P/_/-}"
+
+REQUIRED_USE="
+ || ( X server monolithic )
+ crypt? ( || ( server monolithic ) )
+ postgres? ( || ( server monolithic ) )
+ syslog? ( || ( server monolithic ) )
+ kde? ( || ( X monolithic ) )
+ phonon? ( || ( X monolithic ) )
+ dbus? ( || ( X monolithic ) )
+ ayatana? ( || ( X monolithic ) )
+ webkit? ( || ( X monolithic ) )
+"
+
+pkg_setup() {
+ if use server; then
+ QUASSEL_DIR=/var/lib/${PN}
+ QUASSEL_USER=${PN}
+ # create quassel:quassel user
+ enewgroup "${QUASSEL_USER}"
+ enewuser "${QUASSEL_USER}" -1 -1 "${QUASSEL_DIR}" "${QUASSEL_USER}"
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with ayatana LIBINDICATE)
+ $(cmake-utils_use_want X QTCLIENT)
+ $(cmake-utils_use_want server CORE)
+ $(cmake-utils_use_want monolithic MONO)
+ $(cmake-utils_use_with webkit)
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_with kde)
+ $(cmake-utils_use_with dbus)
+ $(cmake-utils_use_with ssl OPENSSL)
+ $(cmake-utils_use_with syslog)
+ $(cmake-utils_use_with !kde OXYGEN)
+ $(cmake-utils_use_with crypt)
+ "-DEMBED_DATA=OFF"
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ if use server ; then
+ # needs PAX marking wrt bug#346255
+ pax-mark m "${ED}/usr/bin/quasselcore"
+
+ # prepare folders in /var/
+ keepdir "${QUASSEL_DIR}"
+ fowners "${QUASSEL_USER}":"${QUASSEL_USER}" "${QUASSEL_DIR}"
+
+ # init scripts
+ newinitd "${FILESDIR}"/quasselcore.init quasselcore
+ newconfd "${FILESDIR}"/quasselcore.conf quasselcore
+
+ # logrotate
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/quassel.logrotate" quassel
+ fi
+}
+
+pkg_postinst() {
+ if use monolithic && use ssl ; then
+ elog "Information on how to enable SSL support for client/core connections"
+ elog "is available at http://bugs.quassel-irc.org/wiki/quassel-irc."
+ fi
+
+ if use server; then
+ einfo "If you want to generate SSL certificate remember to run:"
+ einfo " emerge --config =${CATEGORY}/${PF}"
+ fi
+
+ if use server || use monolithic ; then
+ einfo "Quassel can use net-misc/oidentd package if installed on your system."
+ einfo "Consider installing it if you want to run quassel within identd daemon."
+ fi
+
+ # temporary info mesage
+ if use server && [[ $(get_version_component_range 2 ${REPLACING_VERSIONS}) -lt 7 ]]; then
+ echo
+ ewarn "Please note that all configuration moved from"
+ ewarn "/home/\${QUASSEL_USER}/.config/quassel-irc.org/"
+ ewarn "to: ${QUASSEL_DIR}."
+ echo
+ ewarn "For migration, stop the core, move quasselcore files (pretty much"
+ ewarn "everything apart from quasselclient.conf and settings.qss) into"
+ ewarn "new location and then start server again."
+ fi
+}
+
+pkg_config() {
+ if use server && use ssl; then
+ # generate the pem file only when it does not already exist
+ if [ ! -f "${QUASSEL_DIR}/quasselCert.pem" ]; then
+ einfo "Generating QUASSEL SSL certificate to: \"${QUASSEL_DIR}/quasselCert.pem\""
+ openssl req -x509 -nodes -days 365 -newkey rsa:2048 \
+ -keyout "${QUASSEL_DIR}/quasselCert.pem" \
+ -out "${QUASSEL_DIR}/quasselCert.pem"
+ # permissions for the key
+ chown ${QUASSEL_USER}:${QUASSEL_USER} "${QUASSEL_DIR}/quasselCert.pem"
+ chmod 400 "${QUASSEL_DIR}/quasselCert.pem"
+ else
+ einfo "Certificate \"${QUASSEL_DIR}/quasselCert.pem\" already exists."
+ einfo "Remove it if you want to create new one."
+ fi
+ fi
+}