summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2014-07-14 16:36:26 +0300
committerMart Raudsepp <leio@gentoo.org>2014-07-14 16:36:26 +0300
commit662ea30bff4b5f17280158d776eff3b179715fe1 (patch)
treecca00bb82be5ebe19cb8c4c5b24d68d283df04b4
parentUpdate gstreamer bits to 1.3.91 RC (diff)
downloadleio-662ea30bff4b5f17280158d776eff3b179715fe1.tar.gz
leio-662ea30bff4b5f17280158d776eff3b179715fe1.tar.bz2
leio-662ea30bff4b5f17280158d776eff3b179715fe1.zip
Add media-libs/cogl tweaked to be buildable without mesa on RPi
Allows building cogl without virtual/opengl with USE="-opengl gles2" and adds USE=rpi for choosing raspberrypi-userland as gles2 provider. Not runtime tested. Probably should have a REQUIRED_USE on requiring either one of USE opengl, gles2 (or both)
-rw-r--r--media-libs/cogl/Manifest1
-rw-r--r--media-libs/cogl/cogl-1.18.2.ebuild119
-rw-r--r--media-libs/cogl/metadata.xml10
3 files changed, 130 insertions, 0 deletions
diff --git a/media-libs/cogl/Manifest b/media-libs/cogl/Manifest
new file mode 100644
index 0000000..5e289d7
--- /dev/null
+++ b/media-libs/cogl/Manifest
@@ -0,0 +1 @@
+DIST cogl-1.18.2.tar.xz 1635384 SHA256 9278e519d5480eb0379efd48db024e8fdbf93f01dff48a7e756b85b508a863aa SHA512 c8903a10c476850c77f71eba584854bccf26adae6f62a9232adf8baf728fe2b69273bd5cd5418e7cd72801a2c0e4c85ef8afc08e28ebd5016b81693aef2ecab8 WHIRLPOOL e7538b92af2efe2f3845fde5c97ba9744d53ddb7a05eadb3cf310c43a3536a41001e4a0596a593ae3cfede4a02115a1d9be8aa423e9c814675059f0f777ec4a5
diff --git a/media-libs/cogl/cogl-1.18.2.ebuild b/media-libs/cogl/cogl-1.18.2.ebuild
new file mode 100644
index 0000000..4e5fe81
--- /dev/null
+++ b/media-libs/cogl/cogl-1.18.2.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+CLUTTER_LA_PUNT="yes"
+
+# Inherit gnome2 after clutter to download sources from gnome.org
+inherit clutter gnome2 multilib virtualx
+
+DESCRIPTION="A library for using 3D graphics hardware to draw pretty pictures"
+HOMEPAGE="http://www.cogl3d.org/"
+
+LICENSE="MIT BSD"
+SLOT="1.0/20" # subslot = .so version
+# doc and profile disable for now due bugs #484750 and #483332
+IUSE="examples gles2 gstreamer +introspection +opengl +pango rpi test" # doc profile
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.32:2
+ x11-libs/cairo:=
+ >=x11-libs/gdk-pixbuf-2:2
+ x11-libs/libdrm:=
+ x11-libs/libX11
+ >=x11-libs/libXcomposite-0.4
+ x11-libs/libXdamage
+ x11-libs/libXext
+ >=x11-libs/libXfixes-3
+ >=x11-libs/libXrandr-1.2
+ opengl? ( virtual/opengl )
+ gles2? ( || ( rpi? ( media-libs/raspberrypi-userland ) media-libs/mesa[gles2] ) )
+ gstreamer? (
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0 )
+
+ introspection? ( >=dev-libs/gobject-introspection-1.34.2 )
+ pango? ( >=x11-libs/pango-1.20.0[introspection?] )
+"
+# before clutter-1.7, cogl was part of clutter
+RDEPEND="${COMMON_DEPEND}
+ !<media-libs/clutter-1.7"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/gtk-doc-am-1.13
+ sys-devel/gettext
+ virtual/pkgconfig
+ test? (
+ app-admin/eselect-opengl
+ media-libs/mesa[classic] )
+"
+
+# Need classic mesa swrast for tests, llvmpipe causes a test failure
+# Fox some reason GL3 conformance test all fails again...
+RESTRICT="test"
+
+src_prepare() {
+ # Do not build examples
+ sed -e "s/^\(SUBDIRS +=.*\)examples\(.*\)$/\1\2/" \
+ -i Makefile.am Makefile.in || die
+
+ if ! use test ; then
+ # For some reason the configure switch will not completely disable
+ # tests being built
+ sed -e "s/^\(SUBDIRS =.*\)test-fixtures\(.*\)$/\1\2/" \
+ -e "s/^\(SUBDIRS +=.*\)tests\(.*\)$/\1\2/" \
+ -e "s/^\(.*am__append.* \)tests\(.*\)$/\1\2/" \
+ -i Makefile.am Makefile.in || die
+ fi
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # TODO: think about kms-egl, quartz, sdl, wayland
+ # Prefer gl over gles2 if both are selected
+ # Profiling needs uprof, which is not available in portage yet, bug #484750
+ # FIXME: Doesn't provide prebuilt docs, but they can neither be rebuilt, bug #483332
+ gnome2_src_configure \
+ --disable-examples-install \
+ --disable-maintainer-flags \
+ --enable-cairo \
+ --enable-deprecated \
+ --enable-gdk-pixbuf \
+ --enable-glib \
+ $(use_enable opengl glx) \
+ $(use_enable opengl gl) \
+ $(use_enable gles2) \
+ $(use_enable gles2 cogl-gles2) \
+ $(use_enable gles2 xlib-egl-platform) \
+ $(usex gles2 --with-default-driver=$(usex opengl gl gles2)) \
+ $(use_enable gstreamer cogl-gst) \
+ $(use_enable introspection) \
+ $(use_enable pango cogl-pango) \
+ $(use_enable test unit-tests) \
+ --disable-profile
+# $(use_enable profile)
+}
+
+src_test() {
+ # Use swrast for tests, llvmpipe is incomplete and "test_sub_texture" fails
+ # NOTE: recheck if this is needed after every mesa bump
+ if [[ "$(eselect opengl show)" != "xorg-x11" ]]; then
+ ewarn "Skipping tests because a binary OpenGL library is enabled. To"
+ ewarn "run tests for ${PN}, you need to enable the Mesa library:"
+ ewarn "# eselect opengl set xorg-x11"
+ return
+ fi
+ LIBGL_DRIVERS_PATH="${EROOT}/usr/$(get_libdir)/mesa" Xemake check
+}
+
+src_install() {
+ DOCS="NEWS README"
+ EXAMPLES="examples/{*.c,*.jpg}"
+
+ clutter_src_install
+
+ # Remove silly examples-data directory
+ rm -rvf "${ED}/usr/share/cogl/examples-data/" || die
+}
diff --git a/media-libs/cogl/metadata.xml b/media-libs/cogl/metadata.xml
new file mode 100644
index 0000000..8ba9687
--- /dev/null
+++ b/media-libs/cogl/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+<use>
+ <flag name="gles2">Enable OpenGL ES 2.0 support</flag>
+ <flag name="pango">Build cogl-pango library for <pkg>x11-libs/pango</pkg>
+ integration</flag>
+</use>
+</pkgmetadata>