summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2015-01-04 11:58:12 +0200
committerMart Raudsepp <leio@gentoo.org>2015-01-05 14:32:06 +0200
commit90b68d24e60658d86da37024840cfd8420037abb (patch)
tree1c34a91679f15710a0b84ae22c39f001497d9a5b
parentRemove glib and gdbus-codegen - they reached main tree from gnome overlay (diff)
downloadleio-90b68d24e60658d86da37024840cfd8420037abb.tar.gz
leio-90b68d24e60658d86da37024840cfd8420037abb.tar.bz2
leio-90b68d24e60658d86da37024840cfd8420037abb.zip
gtk+: Bump to 3.14.6, sync with portage
-rw-r--r--x11-libs/gtk+/files/gtk+-non-bash-support.patch29
-rw-r--r--x11-libs/gtk+/gtk+-3.14.6.ebuild (renamed from x11-libs/gtk+/gtk+-3.14.5.ebuild)45
2 files changed, 59 insertions, 15 deletions
diff --git a/x11-libs/gtk+/files/gtk+-non-bash-support.patch b/x11-libs/gtk+/files/gtk+-non-bash-support.patch
new file mode 100644
index 0000000..efd13e6
--- /dev/null
+++ b/x11-libs/gtk+/files/gtk+-non-bash-support.patch
@@ -0,0 +1,29 @@
+From c8ef010024db794e25ca58ef3c02663de685f1bb Mon Sep 17 00:00:00 2001
+From: Alexander Tsoy <alexander@tsoy.me>
+Date: Sun, 26 Oct 2014 01:59:33 +0400
+Subject: [PATCH] gtk/Makefile.am: improve portability of ECHO
+
+---
+ gtk/Makefile.am | 6 +-----
+ 1 file changed, 1 insertion(+), 5 deletions(-)
+
+diff --git a/gtk/Makefile.am b/gtk/Makefile.am
+index f60bec8..e923940 100644
+--- a/gtk/Makefile.am
++++ b/gtk/Makefile.am
+@@ -19,11 +19,7 @@ GTK_PRINT_PREVIEW_COMMAND="evince --unlink-tempfile --preview --print-settings %
+ endif
+
+ SUBDIRS = inspector native .
+-if OS_DARWIN
+- ECHO="echo"
+-else
+- ECHO=echo -e
+-endif
++ECHO=printf '%b\n'
+
+ if HAVE_CLOUDPRINT
+ if HAVE_PAPI_CUPS
+--
+2.0.4
+
diff --git a/x11-libs/gtk+/gtk+-3.14.5.ebuild b/x11-libs/gtk+/gtk+-3.14.6.ebuild
index 074a076..88040d5 100644
--- a/x11-libs/gtk+/gtk+-3.14.5.ebuild
+++ b/x11-libs/gtk+/gtk+-3.14.6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -6,7 +6,7 @@ EAPI="5"
GCONF_DEBUG="no"
GNOME2_LA_PUNT="yes"
-inherit eutils flag-o-matic gnome2 multilib virtualx multilib-minimal
+inherit autotools eutils flag-o-matic gnome2 multilib virtualx multilib-minimal
DESCRIPTION="Gimp ToolKit +"
HOMEPAGE="http://www.gtk.org/"
@@ -69,7 +69,8 @@ DEPEND="${COMMON_DEPEND}
app-text/docbook-xsl-stylesheets
app-text/docbook-xml-dtd:4.1.2
dev-libs/libxslt
- dev-util/gdbus-codegen
+ dev-libs/gobject-introspection-common
+ >=dev-util/gdbus-codegen-2.38.2
>=dev-util/gtk-doc-am-1.20
sys-devel/gettext
virtual/pkgconfig[${MULTILIB_USEDEP}]
@@ -91,7 +92,12 @@ DEPEND="${COMMON_DEPEND}
RDEPEND="${COMMON_DEPEND}
!<gnome-base/gail-1000
!<x11-libs/vte-0.31.0:2.90
+ >=x11-themes/adwaita-icon-theme-3.14
X? ( !<x11-base/xorg-server-1.11.4 )
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-gtklibs-20140508-r3
+ !app-emulation/emul-linux-x86-gtklibs[-abi_x86_32(-)]
+ )
"
PDEPEND="vim-syntax? ( app-vim/gtk-syntax )"
@@ -109,26 +115,28 @@ strip_builddir() {
}
src_prepare() {
+ # see bug #525928
+ epatch "${FILESDIR}"/${PN}-non-bash-support.patch
+
# -O3 and company cause random crashes in applications. Bug #133469
replace-flags -O3 -O2
strip-flags
if ! use test ; then
# don't waste time building tests
- strip_builddir SRC_SUBDIRS testsuite Makefile.am
- strip_builddir SRC_SUBDIRS testsuite Makefile.in
- strip_builddir SRC_SUBDIRS tests Makefile.am
- strip_builddir SRC_SUBDIRS tests Makefile.in
+ strip_builddir SRC_SUBDIRS testsuite Makefile.{am,in}
+ strip_builddir SRC_SUBDIRS tests Makefile.{am,in}
fi
if ! use examples; then
# don't waste time building demos
- strip_builddir SRC_SUBDIRS demos Makefile.am
- strip_builddir SRC_SUBDIRS demos Makefile.in
- strip_builddir SRC_SUBDIRS examples Makefile.am
- strip_builddir SRC_SUBDIRS examples Makefile.in
+ strip_builddir SRC_SUBDIRS demos Makefile.{am,in}
+ strip_builddir SRC_SUBDIRS examples Makefile.{am,in}
fi
+ epatch_user
+
+ eautoreconf
gnome2_src_prepare
}
@@ -156,7 +164,8 @@ multilib_src_configure() {
--enable-man \
$(use_enable !gtk3-only gtk2-dependency) \
--with-xml-catalog="${EPREFIX}"/etc/xml/catalog \
- --libdir="${EPREFIX}"/usr/$(get_libdir)
+ --libdir="${EPREFIX}"/usr/$(get_libdir) \
+ CUPS_CONFIG="${EPREFIX}/usr/bin/${CHOST}-cups-config"
# work-around gtk-doc out-of-source brokedness
if multilib_is_native_abi; then
@@ -182,6 +191,7 @@ multilib_src_test() {
"${EROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/gtk" || die
unset DBUS_SESSION_BUS_ADDRESS
+ unset DISPLAY #527682
GSETTINGS_SCHEMA_DIR="${S}/gtk" Xemake check
}
@@ -192,7 +202,7 @@ multilib_src_install() {
if use aqua ; then
for i in gtk+-3.0.pc gtk+-quartz-3.0.pc gtk+-unix-print-3.0.pc; do
sed -e "s:Libs\: :Libs\: -framework Carbon :" \
- -i "${ED}"usr/$(get_libdir)/pkgconfig/$i || die "sed failed"
+ -i "${ED%/}"/usr/$(get_libdir)/pkgconfig/$i || die "sed failed"
done
fi
}
@@ -208,7 +218,7 @@ pkg_preinst() {
gnome2_pkg_preinst
multilib_pkg_preinst() {
- # Make sure loaders.cache belongs to gdk-pixbuf alone
+ # Make immodules.cache belongs to gtk+ alone
local cache="usr/$(get_libdir)/gtk-3.0/3.0.0/immodules.cache"
if [[ -e ${EROOT}${cache} ]]; then
@@ -222,7 +232,12 @@ pkg_preinst() {
pkg_postinst() {
gnome2_pkg_postinst
- gnome2_query_immodules_gtk3
+
+ multilib_pkg_postinst() {
+ gnome2_query_immodules_gtk3 \
+ || die "Update immodules cache failed (for ${ABI})"
+ }
+ multilib_parallel_foreach_abi multilib_pkg_postinst
if ! has_version "app-text/evince"; then
elog "Please install app-text/evince for print preview functionality."