summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2014-06-26 08:10:56 +0300
committerMart Raudsepp <leio@gentoo.org>2014-06-26 08:10:56 +0300
commitb985d09515dbb5833978ff065efb6724724ba9b8 (patch)
treecd3d89da06601677bd6fa3230eb00851e92e5f23
parentAdd metadata/layout.conf overlay setup (diff)
downloadleio-b985d09515dbb5833978ff065efb6724724ba9b8.tar.gz
leio-b985d09515dbb5833978ff065efb6724724ba9b8.tar.bz2
leio-b985d09515dbb5833978ff065efb6724724ba9b8.zip
Add weston-1.5.0 ebuild hacked to be more suitable on Raspberry-Pi (RPi) with USE=rpi
-rw-r--r--dev-libs/weston/Manifest1
-rw-r--r--dev-libs/weston/files/README.gentoo9
-rw-r--r--dev-libs/weston/metadata.xml26
-rw-r--r--dev-libs/weston/weston-1.5.0.ebuild167
4 files changed, 203 insertions, 0 deletions
diff --git a/dev-libs/weston/Manifest b/dev-libs/weston/Manifest
new file mode 100644
index 0000000..e7d0775
--- /dev/null
+++ b/dev-libs/weston/Manifest
@@ -0,0 +1 @@
+DIST weston-1.5.0.tar.xz 722616 SHA256 06388ba04ac79aa72d685cc1a8e646ddb2b8cfe11fcc742294f9addac48b7684 SHA512 25230a2d2d0242fecfb35426d538ffe65bec1c984ef3529569d5aa97afd47058785227567ee80bd46cfaa2e914191eee24351a7fe5442f72d1cc32ff646c50e9 WHIRLPOOL 487f8e8d31ea6ceeca13e89bc0da227f9d88b48c3b0aff25763fa869e661cd32dc91a2a0eec416f726222b2c057f843137c7c3a4856727573e9e02844bb70aa0
diff --git a/dev-libs/weston/files/README.gentoo b/dev-libs/weston/files/README.gentoo
new file mode 100644
index 0000000..ed8c5c3
--- /dev/null
+++ b/dev-libs/weston/files/README.gentoo
@@ -0,0 +1,9 @@
+For running Weston you need to have $XDG_RUNTIME_DIR in your environment,
+directory must exist and have correct permissions. If you are not using systemd,
+it will not be created automatically, you can create it using your shell,
+add these lines to ~/.bash_profile:
+
+# wayland
+export XDG_RUNTIME_DIR=/tmp/.runtime-${USER}
+mkdir -p "${XDG_RUNTIME_DIR}"
+chmod 0700 "${XDG_RUNTIME_DIR}"
diff --git a/dev-libs/weston/metadata.xml b/dev-libs/weston/metadata.xml
new file mode 100644
index 0000000..0bf8f98
--- /dev/null
+++ b/dev-libs/weston/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>x11</herd>
+<use>
+ <flag name='clients'>Enable support for clients</flag>
+ <flag name='colord'>Allow setting color managment</flag>
+ <flag name='drm'>Enable drm compositor support</flag>
+ <flag name='editor'>Install wayland-editor example application</flag>
+ <flag name='egl'>Enable egl acceleration</flag>
+ <flag name='fbdev'>Enable fbdev compositor support</flag>
+ <flag name='gles2'>Use GLESv2 cairo instead of full GL</flag>
+ <flag name='headless'>Headless backend and a noop renderer, mainly for testing purposes</flag>
+ <flag name='launch'>Install weston-launch utility</flag>
+ <flag name='rdp'>Enable Remote Desktop Protocol compositor support</flag>
+ <flag name='resize-optimization'>Increase performance, allocate more RAM. Recommended to disable on Raspberry Pi</flag>
+ <flag name='rpi'>Raspberry Pi GPU support</flag>
+ <flag name='simple-clients'>Enable simple-clients</flag>
+ <flag name='tablet'>Enable interface for tablets</flag>
+ <flag name='unwind'>Enable libunwind usage for backtraces</flag>
+ <flag name='view'>Install wayland-view example application</flag>
+ <flag name='wayland-compositor'>Enable Wayland compositor support</flag>
+ <flag name='x11'>Enable X11 compositor support</flag>
+ <flag name='xwayland'>Enable ability support native X11 applications</flag>
+</use>
+</pkgmetadata>
diff --git a/dev-libs/weston/weston-1.5.0.ebuild b/dev-libs/weston/weston-1.5.0.ebuild
new file mode 100644
index 0000000..019b8e3
--- /dev/null
+++ b/dev-libs/weston/weston-1.5.0.ebuild
@@ -0,0 +1,167 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="git://anongit.freedesktop.org/git/wayland/${PN}"
+ GIT_ECLASS="git-r3"
+ EXPERIMENTAL="true"
+fi
+VIRTUALX_REQUIRED="test"
+RESTRICT="test"
+
+inherit autotools readme.gentoo toolchain-funcs virtualx $GIT_ECLASS
+
+DESCRIPTION="Wayland reference compositor"
+HOMEPAGE="http://wayland.freedesktop.org/"
+
+if [[ $PV = 9999* ]]; then
+ SRC_URI="${SRC_PATCHES}"
+else
+ SRC_URI="http://wayland.freedesktop.org/releases/${P}.tar.xz"
+fi
+
+LICENSE="MIT CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~arm-linux"
+IUSE="colord dbus +drm +egl editor examples fbdev gles2 headless +opengl rdp +resize-optimization rpi +launch screen-sharing static-libs +suid systemd test unwind wayland-compositor +X xwayland"
+
+REQUIRED_USE="
+ drm? ( egl )
+ egl? ( !rpi? ( || ( gles2 opengl ) ) )
+ gles2? ( !opengl )
+ rpi? ( !opengl )
+ screen-sharing? ( rdp )
+ test? ( X )
+ wayland-compositor? ( egl )
+"
+
+RDEPEND="
+ >=dev-libs/wayland-1.4.0
+ media-libs/lcms:2
+ media-libs/libpng:0=
+ media-libs/libwebp:0=
+ virtual/jpeg
+ >=x11-libs/cairo-1.11.3[gles2(-)?,opengl?]
+ >=x11-libs/libdrm-2.4.30
+ x11-libs/libxkbcommon
+ x11-libs/pixman
+ x11-misc/xkeyboard-config
+ fbdev? (
+ >=sys-libs/mtdev-1.1.0
+ >=virtual/udev-136
+ )
+ colord? ( >=x11-misc/colord-0.1.27 )
+ dbus? ( sys-apps/dbus )
+ drm? (
+ media-libs/mesa[gbm]
+ >=sys-libs/mtdev-1.1.0
+ >=virtual/udev-136
+ )
+ egl? (
+ media-libs/glu
+ rpi? ( media-libs/raspberrypi-userland )
+ !rpi? ( media-libs/mesa[gles2,wayland] )
+ )
+ editor? ( x11-libs/pango )
+ gles2? (
+ rpi? ( media-libs/raspberrypi-userland )
+ !rpi? ( media-libs/mesa[wayland] )
+ )
+ opengl? (
+ media-libs/mesa[wayland]
+ )
+ rdp? ( >=net-misc/freerdp-1.1.0_beta1_p20130710 )
+ rpi? (
+ >=sys-libs/mtdev-1.1.0
+ >=virtual/udev-136
+ )
+ systemd? (
+ sys-auth/pambase[systemd]
+ sys-apps/systemd[pam]
+ )
+ launch? ( sys-auth/pambase )
+ unwind? ( sys-libs/libunwind )
+ X? (
+ x11-libs/libxcb
+ x11-libs/libX11
+ )
+ xwayland? (
+ x11-base/xorg-server[wayland]
+ x11-libs/cairo[xcb]
+ x11-libs/libxcb
+ x11-libs/libXcursor
+ )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ if [[ ${PV} = 9999* ]]; then
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ local myconf
+ if use examples || use gles2 || use test; then
+ myconf="--enable-simple-clients
+ $(use_enable egl simple-egl-clients)"
+ else
+ myconf="--disable-simple-clients
+ --disable-simple-egl-clients"
+ fi
+
+ if use gles2; then
+ myconf+=" --with-cairo=glesv2"
+ elif use opengl; then
+ myconf+=" --with-cairo=gl"
+ else
+ myconf+=" --with-cairo=image"
+ fi
+
+ if use rpi; then
+ # Set the default backend to probably desired RPi one, to work without a weston.ini
+ export WESTON_NATIVE_BACKEND="rpi-backend.so"
+ fi
+
+ econf \
+ $(use_enable examples demo-clients-install) \
+ $(use_enable fbdev fbdev-compositor) \
+ $(use_enable dbus) \
+ $(use_enable drm drm-compositor) \
+ $(use_enable headless headless-compositor) \
+ $(use_enable rdp rdp-compositor) \
+ $(use_enable rpi rpi-compositor) \
+ $(use_enable wayland-compositor) \
+ $(use_enable X x11-compositor) \
+ $(use_enable launch weston-launch) \
+ $(use_enable colord) \
+ $(use_enable egl) \
+ $(use_enable unwind libunwind) \
+ $(use_enable resize-optimization) \
+ $(use_enable screen-sharing) \
+ $(use_enable suid setuid-install) \
+ $(use_enable xwayland) \
+ $(use_enable xwayland xwayland-test) \
+ --disable-libinput-backend \
+ ${myconf}
+}
+
+src_test() {
+ export XDG_RUNTIME_DIR="${T}/runtime-dir"
+ mkdir "${XDG_RUNTIME_DIR}" || die
+ chmod 0700 "${XDG_RUNTIME_DIR}" || die
+
+ cd "${BUILD_DIR}" || die
+ Xemake check
+}
+
+src_install() {
+ default
+
+ readme.gentoo_src_install
+}