summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2014-11-10 23:01:06 +0200
committerMart Raudsepp <leio@gentoo.org>2014-11-10 23:01:06 +0200
commitc77205993eb7bf6d00f052a822f36edf0707c455 (patch)
tree867208210872bf1d9334968c1cc2656616977e28
parentUpdate gstreamer bits to 1.4.4 (diff)
downloadleio-c77205993eb7bf6d00f052a822f36edf0707c455.tar.gz
leio-c77205993eb7bf6d00f052a822f36edf0707c455.tar.bz2
leio-c77205993eb7bf6d00f052a822f36edf0707c455.zip
Add a gst-plugins-omx-1.2.0 that can play 1080p video
Use something like this to play on the console: GST_GL_PLATFORM=egl GST_GL_API=gles2 GST_GL_WINDOW=dispmanx gst-play-1.0 media.mkv See http://gstreamer.freedesktop.org/data/doc/gstreamer/head/gst-plugins-bad-libs/html/GstGLDisplay.html for other values (x11 or wayland for GST_GL_WINDOW mostly; but dispmanx might be good on X11 too)
-rw-r--r--media-plugins/gst-plugins-omx/Manifest1
-rw-r--r--media-plugins/gst-plugins-omx/gst-plugins-omx-1.2.0.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/media-plugins/gst-plugins-omx/Manifest b/media-plugins/gst-plugins-omx/Manifest
new file mode 100644
index 0000000..0505ff7
--- /dev/null
+++ b/media-plugins/gst-plugins-omx/Manifest
@@ -0,0 +1 @@
+DIST gst-omx-1.2.0.tar.xz 463384 SHA256 0b4874961e6488ad9e5808114bd486ea981c540907262caab1419355fd82d745 SHA512 a904ed83dcfda1646a040204d0712c861860e575bda7caf36d50ca49ecd23844bf80abaebcf30583f0f35d215c1a01212f4b513169a5d738ba7e6a7b57ee7cc8 WHIRLPOOL 243f0ce3825f2119ef0a561acc9c57557895c114d4aa9a5a41a0906c67dbb38bcc8362f28e98ff3afd8bee9f722b6a18e3c8377d4df8ed9b51432638376df5f9
diff --git a/media-plugins/gst-plugins-omx/gst-plugins-omx-1.2.0.ebuild b/media-plugins/gst-plugins-omx/gst-plugins-omx-1.2.0.ebuild
new file mode 100644
index 0000000..3a74b19
--- /dev/null
+++ b/media-plugins/gst-plugins-omx/gst-plugins-omx-1.2.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/gst-plugins-libav/gst-plugins-libav-1.2.0.ebuild,v 1.3 2014/01/21 21:56:59 eva Exp $
+
+EAPI="5"
+
+inherit eutils flag-o-matic
+
+MY_PN="gst-omx"
+DESCRIPTION="GStreamer OpenMAX IL wrapper plugin"
+HOMEPAGE="http://gstreamer.freedesktop.org/modules/gst-omx.html"
+SRC_URI="http://gstreamer.freedesktop.org/src/${MY_PN}/${MY_PN}-${PV}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="1.0"
+KEYWORDS="~arm"
+IUSE="rpi"
+
+# FIXME: What >=media-libs/gst-plugins-bad-1.4.0:1.0[gl] stuff for non-rpi?
+RDEPEND="
+ >=media-libs/gstreamer-1.2.2:1.0
+ >=media-libs/gst-plugins-base-1.2.2:1.0
+ rpi? (
+ media-libs/raspberrypi-userland
+ >=media-libs/gst-plugins-bad-1.4.0:1.0[egl,gles2,rpi]
+ )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.3
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_configure() {
+ GST_PLUGINS_BUILD=""
+ local myconf
+ if use rpi; then
+ myconf="${myconf} --with-omx-target=rpi --with-omx-header-path=/opt/vc/include/IL"
+ fi
+ econf \
+ --disable-maintainer-mode \
+ --with-package-name="Gentoo GStreamer ebuild" \
+ --with-package-origin="http://www.gentoo.org" \
+ ${myconf}
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog NEWS README RELEASE"
+ default
+ prune_libtool_files --modules
+}