summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2009-10-06 14:12:01 +0300
committerMart Raudsepp <leio@gentoo.org>2009-10-06 14:12:01 +0300
commit155d266ebb7b73e247ebc5b732f9c87f8f7b8eb6 (patch)
tree74b216cfe95ea39ed104b912d731a5dd90310e37 /dev-util
parentUpdate sysprof live ebuild to upstream move from GNOME SVN to freedesktop git (diff)
downloadleio-155d266ebb7b73e247ebc5b732f9c87f8f7b8eb6.tar.gz
leio-155d266ebb7b73e247ebc5b732f9c87f8f7b8eb6.tar.bz2
leio-155d266ebb7b73e247ebc5b732f9c87f8f7b8eb6.zip
Initial ebuild for OProfileUI.
Based on an ebuild from Gilles Dartiguelongue
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/oprofileui/Manifest3
-rw-r--r--dev-util/oprofileui/metadata.xml13
-rw-r--r--dev-util/oprofileui/oprofileui-0.2.0.ebuild40
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-util/oprofileui/Manifest b/dev-util/oprofileui/Manifest
new file mode 100644
index 0000000..6b04de7
--- /dev/null
+++ b/dev-util/oprofileui/Manifest
@@ -0,0 +1,3 @@
+DIST oprofileui-0.2.0.tar.gz 243145 RMD160 59b6f491267e3b00d75e9be931c8a110930da032 SHA1 6bde2b0ec1d3397f493d0ff1566c71b9cb5c4e59 SHA256 5b0e7d1d538c4339401b3e19b555137e0b5a4e0d21578e227604d58b64970d7f
+EBUILD oprofileui-0.2.0.ebuild 864 RMD160 17e7b16b8a87c8a10601a78023d10f1a96a8429c SHA1 8f95dba72ad53684ae21274563d60e9c53ea09e4 SHA256 fd1fd1d5fbb77c95e571dd4e7c45efac0aac40bbe0dacd2a98bbcd31f7d6bea4
+MISC metadata.xml 478 RMD160 6253acb32aa88890a37566fe71005e9f1ba18a4d SHA1 a2271699fb4b716200fd41ce664a871563bc0bc2 SHA256 3d80ab8e0c4f3012603e63d85f490b923a25fd062c2136f366ec31184038c36c
diff --git a/dev-util/oprofileui/metadata.xml b/dev-util/oprofileui/metadata.xml
new file mode 100644
index 0000000..9ee11ee
--- /dev/null
+++ b/dev-util/oprofileui/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+<email>leio@gentoo.org</email>
+</maintainer>
+<longdescription lang="en">
+ OProfileUI is a graphical user interface to the stochastic system profiler OProfile,
+ providing application developers and system integrators with a graphical view of
+ hotspots in their applications and systems.
+</longdescription>
+</pkgmetadata>
diff --git a/dev-util/oprofileui/oprofileui-0.2.0.ebuild b/dev-util/oprofileui/oprofileui-0.2.0.ebuild
new file mode 100644
index 0000000..2ce613e
--- /dev/null
+++ b/dev-util/oprofileui/oprofileui-0.2.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=1
+
+DESCRIPTION="User interface for system profiler OProfile"
+HOMEPAGE="http://labs.o-hand.com/oprofileui/"
+SRC_URI="http://labs.o-hand.com/sources/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="avahi +gtk +server"
+
+RDEPEND=">=dev-libs/glib-2
+ client? (
+ >=x11-libs/gtk+-2
+ >=gnome-base/libglade-2
+ >=gnome-base/gnome-vfs-2
+ >=gnome-base/gconf-2
+ >=dev-libs/libxml2-2
+ )
+ avahi? ( net-dns/avahi )"
+RDEPEND="${DEPEND}
+ dev-util/oprofile
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.35"
+
+src_compile() {
+ econf $(use_with avahi)
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+
+ dodoc NEWS ChangeLog AUTHORS README
+ rm -rf "${D}/usr/share/doc/${PN}"
+}