aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/lensfun/lensfun-0.3.4_rc1.ebuild')
-rw-r--r--media-libs/lensfun/lensfun-0.3.4_rc1.ebuild8
1 files changed, 3 insertions, 5 deletions
diff --git a/media-libs/lensfun/lensfun-0.3.4_rc1.ebuild b/media-libs/lensfun/lensfun-0.3.4_rc1.ebuild
index 77c69c8..d6fb35d 100644
--- a/media-libs/lensfun/lensfun-0.3.4_rc1.ebuild
+++ b/media-libs/lensfun/lensfun-0.3.4_rc1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -28,17 +28,17 @@ RDEPEND="${PYTHON_DEPS}
DEPEND="${RDEPEND}"
BDEPEND="
doc? (
- app-doc/doxygen
+ app-text/doxygen
dev-python/docutils
)
"
DOCS=( README.md docs/mounts.txt ChangeLog )
-PATCHES=( "${FILESDIR}/${P}_python.patch" )
src_configure() {
local mycmakeargs=(
-DCMAKE_INSTALL_DOCDIR="${EPREFIX}"/usr/share/doc/${PF}/html
+ -DSETUP_PY_INSTALL_PREFIX=/usr
-DBUILD_LENSTOOL=ON
-DBUILD_STATIC=OFF
-DBUILD_DOC=$(usex doc)
@@ -58,7 +58,5 @@ src_test() {
src_install() {
cmake_src_install
- python_moduleinto lensfun
- python_domodule "${BUILD_DIR}"/apps/lensfun/__init__.py
python_optimize
}