aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'scripts/subslotted-packages.sh')
-rwxr-xr-xscripts/subslotted-packages.sh16
1 files changed, 0 insertions, 16 deletions
diff --git a/scripts/subslotted-packages.sh b/scripts/subslotted-packages.sh
deleted file mode 100755
index c34ced2..0000000
--- a/scripts/subslotted-packages.sh
+++ /dev/null
@@ -1,16 +0,0 @@
-#!/bin/bash
-# find packages with subslots
-
-PORTDIR="${HOME}/cvs/gentoo-x86"
-
-pushd "${PORTDIR}" > /dev/null
-
-for pkg in $(find . -mindepth 2 -maxdepth 2 -type d | sort) ; do
- pushd ${pkg} > /dev/null
- if [[ -n $(find . -name '*.ebuild') ]] ; then
- [[ -n $(egrep "SLOT=\"?[0-9]*\/" *.ebuild) ]] && echo ${pkg/\.\//}
- fi
- popd > /dev/null # ${pkg}
-done
-
-popd > /dev/null # ${PORTDIR}