summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMATSUU Takuto <matsuu@gentoo.org>2010-09-19 20:02:34 +0900
committerMATSUU Takuto <matsuu@gentoo.org>2010-09-19 20:02:34 +0900
commit18acba2a90c5d276ce621e5f6977267a92c951a9 (patch)
tree9b13984ec1e5152ed8cd15210d35a2cb3ab8c4a0
parentdev-ruby/rubytter: Version bumped. (diff)
downloadmatsuu-18acba2a90c5d276ce621e5f6977267a92c951a9.tar.gz
matsuu-18acba2a90c5d276ce621e5f6977267a92c951a9.tar.bz2
matsuu-18acba2a90c5d276ce621e5f6977267a92c951a9.zip
app-text/groonga: Initial import
-rw-r--r--app-text/groonga/Manifest2
-rw-r--r--app-text/groonga/groonga-1.0.2.ebuild48
2 files changed, 50 insertions, 0 deletions
diff --git a/app-text/groonga/Manifest b/app-text/groonga/Manifest
new file mode 100644
index 0000000..de2e599
--- /dev/null
+++ b/app-text/groonga/Manifest
@@ -0,0 +1,2 @@
+DIST groonga-1.0.2.tar.gz 1605491 RMD160 551fd06e6d5a03eddcc21603f2eaca9e51202ea2 SHA1 5a6f081d79fd56d55a42de9275656040875c8baf SHA256 d6a97e491e2076d8ea3411586ab99afc9cc73074cbf223e53617559ec2be3568
+EBUILD groonga-1.0.2.ebuild 1126 RMD160 7f115651989526379025c4da4891fbcd244f7c26 SHA1 2dfecc0d9049a88bdd4758ceae94ae0899142b12 SHA256 859d2392e4bcb7730a9c044afaf5608983c64fde6327fc827d2182ba674ae374
diff --git a/app-text/groonga/groonga-1.0.2.ebuild b/app-text/groonga/groonga-1.0.2.ebuild
new file mode 100644
index 0000000..a2ef3de
--- /dev/null
+++ b/app-text/groonga/groonga-1.0.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+DESCRIPTION="An Embeddable Fulltext Search Engine"
+HOMEPAGE="http://groonga.org/"
+SRC_URI="http://groonga.org/files/groonga/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+#IUSE="abort aio cutter fmalloc futex libedit lzo mecab +nfkc ruby sphinx uyield zlib"
+IUSE="libedit lzo mecab ruby sphinx zlib"
+
+RDEPEND="libedit? ( dev-libs/libedit )
+ lzo? ( dev-libs/lzo )
+ mecab? ( >=app-text/mecab-0.80 )
+ ruby? ( dev-lang/ruby )
+ sphinx? ( >=dev-python/sphinx-1.0.1 )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+# cutter? ( >=cutter-1.1.3 )
+#>=glib-2.8
+#ruby
+#lzo
+# libedit? ( >=dev-libs/libedit-3.0 )
+
+src_configure() {
+ econf \
+ $(use_with ruby) \
+ $(use_with libedit) \
+ $(use_with lzo) \
+ $(use_with sphinx sphinx-build) \
+ $(use_with mecab) \
+ $(use_with zlib) || die
+# $(use_with cutter) \
+# $(use_enable libedit) \
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ keepdir /var/log/${PN} || die
+ dodoc AUTHORS ChangeLog NEWS README || die
+}