summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMATSUU Takuto <matsuu@gentoo.org>2008-10-29 00:03:25 +0900
committerMATSUU Takuto <matsuu@gentoo.org>2008-10-29 00:03:25 +0900
commite2a64648d9f5a0ee6e6334763c56d52c815926ad (patch)
tree06cd537ff613cfb10442a9347c5fc26dfda55b44 /media-gfx
parentAdded net-wireless/broadcom-sta and netwireless/ndiswrapper for DELL Inspiron... (diff)
downloadmatsuu-e2a64648d9f5a0ee6e6334763c56d52c815926ad.tar.gz
matsuu-e2a64648d9f5a0ee6e6334763c56d52c815926ad.tar.bz2
matsuu-e2a64648d9f5a0ee6e6334763c56d52c815926ad.zip
Removed subdirectories.
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/action-coding/Manifest1
-rw-r--r--media-gfx/action-coding/action-coding-9999.ebuild35
-rw-r--r--media-gfx/processing/Manifest2
-rw-r--r--media-gfx/processing/processing-1.0_beta0148.ebuild42
4 files changed, 80 insertions, 0 deletions
diff --git a/media-gfx/action-coding/Manifest b/media-gfx/action-coding/Manifest
new file mode 100644
index 0000000..4875bb9
--- /dev/null
+++ b/media-gfx/action-coding/Manifest
@@ -0,0 +1 @@
+EBUILD action-coding-9999.ebuild 698 RMD160 38942444e6eefa7e4723002eb77873a618354b6a SHA1 0bc69714c46810d9a4502fa3e4f17d6e97655e3f SHA256 e96a1ff83753ceb06b1492f24e3ad29013e618eb05272b22a400582800d2cf8d
diff --git a/media-gfx/action-coding/action-coding-9999.ebuild b/media-gfx/action-coding/action-coding-9999.ebuild
new file mode 100644
index 0000000..3ae4d33
--- /dev/null
+++ b/media-gfx/action-coding/action-coding-9999.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils subversion
+
+ESVN_REPO_URI="http://action-coding.googlecode.com/svn/trunk"
+
+DESCRIPTION="Ruby + Processing"
+HOMEPAGE="http://code.google.com/p/action-coding/"
+SRC_URI=""
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# java-overlay
+RDEPEND=">=dev-java/jruby-1.1
+ media-gfx/processing"
+
+OPTDIR="/opt/${PN}"
+
+src_unpack() {
+ subversion_src_unpack
+ cd "${S}"
+ sed -i -e '/^p5home/s|: .*|: /opt/processing|' config.yaml || die
+}
+
+src_install() {
+ insinto "${OPTDIR}"
+ cp -pPR * "${D}${OPTDIR}" || die
+
+ make_wrapper ${PN} ./run.command "${OPTDIR}" || die
+}
diff --git a/media-gfx/processing/Manifest b/media-gfx/processing/Manifest
new file mode 100644
index 0000000..556843c
--- /dev/null
+++ b/media-gfx/processing/Manifest
@@ -0,0 +1,2 @@
+DIST processing-0148.tgz 55425463 RMD160 dfd273c215b15aa86a0ba593135dfa397977cc37 SHA1 b22d35685ff34e351e50c691b8accc94f48a4c0e SHA256 152a93cd18ce9ee8f56be13f1087712b7c08a84cb35d88672ff712918f5da3cc
+EBUILD processing-1.0_beta0148.ebuild 967 RMD160 ad7ccabf2d8c660b026d399b6bd0be990ac3f35f SHA1 f03df542d047b844dafd3940e806e87fdf4270a7 SHA256 6277b1152966410101c81a9d3c77e2fb1f48219e70f70d246036a0837d18c9d2
diff --git a/media-gfx/processing/processing-1.0_beta0148.ebuild b/media-gfx/processing/processing-1.0_beta0148.ebuild
new file mode 100644
index 0000000..2362c9f
--- /dev/null
+++ b/media-gfx/processing/processing-1.0_beta0148.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+MY_P="${P/-*_beta/-}"
+DESCRIPTION="an open source programming language and environment for people who want to program images, animation, and sound"
+HOMEPAGE="http://processing.org/"
+SRC_URI="http://processing.org/download/${MY_P}.tgz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=virtual/jdk-1.5
+ x11-misc/xdg-utils
+ amd64? (
+ app-emulation/emul-linux-x86-soundlibs
+ app-emulation/emul-linux-x86-xlibs
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+OPTDIR="/opt/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i -e '/^browser.linux/s|mozilla|xdg-open|' lib/preferences.txt || die
+}
+
+src_install() {
+ insinto "${OPTDIR}"
+ cp -pPR * "${D}${OPTDIR}" || die
+ make_wrapper ${PN} ./processing "${OPTDIR}" || die
+
+ dodoc revisions.txt
+ dohtml -r reference/*
+ dosym /usr/share/doc/${PF}/html "${OPTDIR}"/reference
+}