summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-misc/freespace2/freespace2-20040510.ebuild')
-rwxr-xr-xgames-misc/freespace2/freespace2-20040510.ebuild72
1 files changed, 0 insertions, 72 deletions
diff --git a/games-misc/freespace2/freespace2-20040510.ebuild b/games-misc/freespace2/freespace2-20040510.ebuild
deleted file mode 100755
index f0facf3..0000000
--- a/games-misc/freespace2/freespace2-20040510.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2004 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header$
-
-inherit eutils games
-
-DESCRIPTION="port of the original FreeSpace2"
-HOMEPAGE="http://icculus.org/projects/freespace2/"
-SRC_URI="mirror://gentoo/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE="debug mve"
-
-RDEPEND="virtual/x11
- media-libs/libsdl
- media-libs/openal
- virtual/opengl"
-DEPEND="${RDEPEND}
- >=sys-apps/sed-4"
-
-src_unpack() {
- unpack ${A}
-
- # configure
- cd ${S}
-
- # disable debug
- if !(use debug); then
- einfo "Disabling debug..."
- sed -i \
- -e "s/^#CFLAGS+=-DNDEBUG/CFLAGS+=-DNDEBUG/" \
- Makefile
- fi
-
- # enable movie playing codes
- if (use mve); then
- einfo "Enabling movies..."
- sed -i \
- -e "s/^MVE=false/MVE=true/" \
- Makefile
- fi
-}
-
-src_compile() {
- emake || die "make error"
-}
-
-src_install() {
- dir=${GAMES_PREFIX_OPT}/${PN}
-
- dodir ${dir}
- exeinto ${dir}
- docinto ${dir}
-
- doexe freespace2
- dodoc README
- games_make_wrapper freespace2 ./freespace2 ${dir}
-
- prepgamesdirs
-}
-
-pkg_postinst() {
- games_pkg_postinst
- einfo "Copy the data files from a FreeSpace2 Windows full installation"
- einfo "into ${dir}"
- einfo " Example: cp -r /mnt/winc/Games/FreeSpace2/* ${dir}"
- echo
- einfo "You can change resolution from 640x480 to 1024x768 if you edit"
- einfo " ~/.freespace2/FreeSpace2.ini (created on the first run)"
-}