summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heim <phreak@gentoo.org>2007-03-07 08:49:23 +0000
committerChristian Heim <phreak@gentoo.org>2007-03-07 08:49:23 +0000
commit3094854a7ebcc2692a44e9857edc24f082c10886 (patch)
treeb62ad21b61399551178748ef117d41f3cf802077 /bugfixes
parentbugfixes/net-misc: Pruning net-misc/cisco-vpnclient-3des. (diff)
downloadphreak-3094854a7ebcc2692a44e9857edc24f082c10886.tar.gz
phreak-3094854a7ebcc2692a44e9857edc24f082c10886.tar.bz2
phreak-3094854a7ebcc2692a44e9857edc24f082c10886.zip
dev-libs/apr-util: Hopefully fixing the build failures with db-4.5*, thanks to Michael Edenfield for pointing me at a patch (from UPSTREAM).
svn path=/; revision=282
Diffstat (limited to 'bugfixes')
-rw-r--r--bugfixes/dev-libs/apr-util/Manifest16
-rw-r--r--bugfixes/dev-libs/apr-util/apr-util-0.9.12.ebuild77
-rw-r--r--bugfixes/dev-libs/apr-util/files/apr-util-0.9.12-db-4.5.patch115
-rw-r--r--bugfixes/dev-libs/apr-util/files/apr-util-0.9.12-linking.patch13
-rw-r--r--bugfixes/dev-libs/apr-util/files/digest-apr-util-0.9.123
5 files changed, 224 insertions, 0 deletions
diff --git a/bugfixes/dev-libs/apr-util/Manifest b/bugfixes/dev-libs/apr-util/Manifest
new file mode 100644
index 0000000..017171f
--- /dev/null
+++ b/bugfixes/dev-libs/apr-util/Manifest
@@ -0,0 +1,16 @@
+AUX apr-util-0.9.12-db-4.5.patch 3700 RMD160 bf230d5e84cb1ed09645f37ce73e803c5ac0c7ff SHA1 e03eef45265ecd0510d6e15118403bd2ef956b32 SHA256 e77d59dfe8289d3ad6e96d12651534e6634c629b91723c43583b7171308f99d3
+MD5 e04ae5a7ef56703daed38416e3e75a64 files/apr-util-0.9.12-db-4.5.patch 3700
+RMD160 bf230d5e84cb1ed09645f37ce73e803c5ac0c7ff files/apr-util-0.9.12-db-4.5.patch 3700
+SHA256 e77d59dfe8289d3ad6e96d12651534e6634c629b91723c43583b7171308f99d3 files/apr-util-0.9.12-db-4.5.patch 3700
+AUX apr-util-0.9.12-linking.patch 552 RMD160 b989add276da33dc37d94b443b34f006033321e8 SHA1 e24be832134302352472f49515450db1082d2e81 SHA256 57c40f62214094ab36b5e940e07bfbee5555ad6a08ab63947fd7f8e5c5875472
+MD5 5dc0176e66c29e58c1c49e52a3292e87 files/apr-util-0.9.12-linking.patch 552
+RMD160 b989add276da33dc37d94b443b34f006033321e8 files/apr-util-0.9.12-linking.patch 552
+SHA256 57c40f62214094ab36b5e940e07bfbee5555ad6a08ab63947fd7f8e5c5875472 files/apr-util-0.9.12-linking.patch 552
+DIST apr-util-0.9.12.tar.gz 592364 RMD160 a4554def22f29f56aab34cacddc7fa65c412f446 SHA1 402969874b301d11252acd6eaf0bb01aad3e2908 SHA256 5768fcc4d38fa6f811b0a89e2ef450d0f52688ff9263e548819adb096fbfc9c3
+EBUILD apr-util-0.9.12.ebuild 1932 RMD160 9be91e7e9316dc1053e63fb676f3145160ac94be SHA1 1f2de7530eb2943e9b0e342f8fffaf380a04e5a5 SHA256 03379302e3da651e979f367a4b228cd3036c7291d9a1979566789d83da9343ab
+MD5 00c0da25e3d1e8f8b7d242d429d75d67 apr-util-0.9.12.ebuild 1932
+RMD160 9be91e7e9316dc1053e63fb676f3145160ac94be apr-util-0.9.12.ebuild 1932
+SHA256 03379302e3da651e979f367a4b228cd3036c7291d9a1979566789d83da9343ab apr-util-0.9.12.ebuild 1932
+MD5 537f6952f094fa8eeaa7a554c6eedb6d files/digest-apr-util-0.9.12 247
+RMD160 b240c0c4d2dcb011148569f97f233d826c76876b files/digest-apr-util-0.9.12 247
+SHA256 c4de35e77ddfa5d48a08e9f231f723f01e67c5c560b2198595ccae73fddd1f9a files/digest-apr-util-0.9.12 247
diff --git a/bugfixes/dev-libs/apr-util/apr-util-0.9.12.ebuild b/bugfixes/dev-libs/apr-util/apr-util-0.9.12.ebuild
new file mode 100644
index 0000000..b67a588
--- /dev/null
+++ b/bugfixes/dev-libs/apr-util/apr-util-0.9.12.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit autotools eutils flag-o-matic libtool db-use
+
+DESCRIPTION="Apache Portable Runtime Library"
+HOMEPAGE="http://apr.apache.org/"
+SRC_URI="mirror://apache/apr/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
+IUSE="berkdb gdbm ldap"
+RESTRICT="test"
+
+DEPEND="dev-libs/expat
+ ~dev-libs/apr-${PV}
+ berkdb? ( =sys-libs/db-4* )
+ gdbm? ( sys-libs/gdbm )
+ ldap? ( =net-nds/openldap-2* )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-linking.patch
+ epatch "${FILESDIR}"/${P}-db-4.5.patch
+ eautoreconf
+# elibtoolize || die "elibtoolize failed"
+}
+
+
+src_compile() {
+
+ local myconf=""
+
+ use ldap && myconf="${myconf} --with-ldap"
+ myconf="${myconf} $(use_with gdbm)"
+
+ if use berkdb; then
+ dbver="$(db_findver sys-libs/db)" || die "Unable to find db version"
+ dbver="$(db_ver_to_slot "$dbver")"
+ dbver="${dbver/\./}"
+ myconf="${myconf} --with-dbm=db${dbver}
+ --with-berkeley-db=$(db_includedir):/usr/$(get_libdir)"
+ else
+ myconf="${myconf} --without-berkeley-db"
+ fi
+
+ econf \
+ --datadir=/usr/share/apr-util-0 \
+ --with-apr=/usr \
+ --with-expat=/usr \
+ $myconf || die
+
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" installbuilddir=/usr/share/apr-util-0/build install || die
+
+ #bogus values pointing at /var/tmp/portage
+ sed -i -e 's:APU_SOURCE_DIR=.*:APU_SOURCE_DIR=:g' "${D}"/usr/bin/apu-config
+ sed -i -e 's:APU_BUILD_DIR=.*:APU_BUILD_DIR=/usr/share/apr-util-0/build:g' \
+ "${D}"/usr/bin/apu-config
+
+ dodoc CHANGES NOTICE
+
+ # Will install as portage user when using userpriv. Fixing
+ chown -R root:0 "${D}"/usr/include/apr-0/
+
+ # This file is only used on AIX systems, which gentoo is not,
+ # and causes collisions between the SLOTs, so kill it
+ rm "${D}"/usr/$(get_libdir)/aprutil.exp
+
+}
diff --git a/bugfixes/dev-libs/apr-util/files/apr-util-0.9.12-db-4.5.patch b/bugfixes/dev-libs/apr-util/files/apr-util-0.9.12-db-4.5.patch
new file mode 100644
index 0000000..09e60b2
--- /dev/null
+++ b/bugfixes/dev-libs/apr-util/files/apr-util-0.9.12-db-4.5.patch
@@ -0,0 +1,115 @@
+--- apr/apr-util/trunk/build/dbm.m4 2006/02/09 04:13:19 376178
++++ apr/apr-util/trunk/build/dbm.m4 2006/11/08 20:45:12 472635
+@@ -464,7 +464,25 @@
+ apu_db_version=4
+ fi
+ ])
+-
++dnl
++dnl APU_CHECK_DB45: is DB4.5 present?
++dnl
++dnl if present: sets apu_db_header, apu_db_lib, and apu_db_version
++dnl
++AC_DEFUN([APU_CHECK_DB45], [
++ places=$1
++ if test -z "$places"; then
++ places="std /usr/local/BerkeleyDB.4.5 /boot/home/config"
++ fi
++ APU_CHECK_BERKELEY_DB("4", "5", "-1",
++ "$places",
++ "db45/db.h db4/db.h db.h",
++ "db-4.5 db4-4.5 db45 db4 db"
++ )
++ if test "$apu_have_db" = "1"; then
++ apu_db_version=4
++ fi
++])
+
+ AC_DEFUN([APU_CHECK_DB], [
+ requested=$1
+@@ -531,6 +549,12 @@
+ AC_MSG_ERROR(Berkeley db4 not found)
+ fi
+ ;;
++ db45)
++ APU_CHECK_DB44("$check_places")
++ if test "$apu_db_version" != "4"; then
++ AC_MSG_ERROR(Berkeley db4 not found)
++ fi
++ ;;
+ default)
+ APU_CHECK_DB_ALL("$check_places")
+ ;;
+@@ -543,23 +567,26 @@
+ AC_DEFUN([APU_CHECK_DB_ALL], [
+ all_places=$1
+
+- APU_CHECK_DB44("$all_places")
++ APU_CHECK_DB45("$all_places")
+ if test "$apu_db_version" != "4"; then
+- APU_CHECK_DB43("$all_places")
++ APU_CHECK_DB44("$all_places")
+ if test "$apu_db_version" != "4"; then
+- APU_CHECK_DB42("$all_places")
++ APU_CHECK_DB43("$all_places")
+ if test "$apu_db_version" != "4"; then
+- APU_CHECK_DB41("$all_places")
++ APU_CHECK_DB42("$all_places")
+ if test "$apu_db_version" != "4"; then
+- APU_CHECK_DB4("$all_places")
++ APU_CHECK_DB41("$all_places")
+ if test "$apu_db_version" != "4"; then
+- APU_CHECK_DB3("$all_places")
+- if test "$apu_db_version" != "3"; then
+- APU_CHECK_DB2("$all_places")
+- if test "$apu_db_version" != "2"; then
+- APU_CHECK_DB1("$all_places")
+- if test "$apu_db_version" != "1"; then
+- APU_CHECK_DB185("$all_places")
++ APU_CHECK_DB4("$all_places")
++ if test "$apu_db_version" != "4"; then
++ APU_CHECK_DB3("$all_places")
++ if test "$apu_db_version" != "3"; then
++ APU_CHECK_DB2("$all_places")
++ if test "$apu_db_version" != "2"; then
++ APU_CHECK_DB1("$all_places")
++ if test "$apu_db_version" != "1"; then
++ APU_CHECK_DB185("$all_places")
++ fi
+ fi
+ fi
+ fi
+@@ -596,11 +623,11 @@
+
+ AC_ARG_WITH(dbm, [
+ --with-dbm=DBM choose the DBM type to use.
+- DBM={sdbm,gdbm,ndbm,db,db1,db185,db2,db3,db4,db41,db42,db43,db44}
++ DBM={sdbm,gdbm,ndbm,db,db1,db185,db2,db3,db4,db41,db42,db43,db44,db45}
+ ], [
+ if test "$withval" = "yes"; then
+ AC_MSG_ERROR([--with-dbm needs to specify a DBM type to use.
+- One of: sdbm, gdbm, ndbm, db, db1, db185, db2, db3, db4, db41, db42, db43, db44])
++ One of: sdbm, gdbm, ndbm, db, db1, db185, db2, db3, db4, db41, db42, db43, db44, db45])
+ fi
+ requested="$withval"
+ ], [
+@@ -786,6 +813,10 @@
+ apu_use_db=1
+ apu_default_dbm=db4
+ ;;
++ db45)
++ apu_use_db=1
++ apu_default_dbm=db4
++ ;;
+ default)
+ dnl ### use more sophisticated DBMs for the default?
+ apu_default_dbm="sdbm (default)"
+@@ -793,7 +824,7 @@
+ ;;
+ *)
+ AC_MSG_ERROR([--with-dbm=$look_for is an unknown DBM type.
+- Use one of: sdbm, gdbm, ndbm, db, db1, db185, db2, db3, db4, db41, db42, db43, db44])
++ Use one of: sdbm, gdbm, ndbm, db, db1, db185, db2, db3, db4, db41, db42, db43, db44 db45])
+ ;;
+ esac
+
diff --git a/bugfixes/dev-libs/apr-util/files/apr-util-0.9.12-linking.patch b/bugfixes/dev-libs/apr-util/files/apr-util-0.9.12-linking.patch
new file mode 100644
index 0000000..87524c3
--- /dev/null
+++ b/bugfixes/dev-libs/apr-util/files/apr-util-0.9.12-linking.patch
@@ -0,0 +1,13 @@
+Index: apr-util-0.9.12/Makefile.in
+===================================================================
+--- apr-util-0.9.12.orig/Makefile.in
++++ apr-util-0.9.12/Makefile.in
+@@ -81,7 +81,7 @@ install: $(TARGET_LIB)
+
+ $(TARGET_LIB):
+ @objects="`find $(SUBDIRS) -name expat -prune -o -name 'gen_uri_delims.@so_ext@' -prune -o -name '*.@so_ext@' -print`"; \
+- tmpcmd="$(LINK) @lib_target@ @EXTRA_OS_LINK@"; \
++ tmpcmd="$(LINK) $(APRUTIL_LDFLAGS) @lib_target@ @EXTRA_OS_LINK@ $(APRUTIL_LIBS)"; \
+ echo $$tmpcmd; \
+ $$tmpcmd && touch $@
+
diff --git a/bugfixes/dev-libs/apr-util/files/digest-apr-util-0.9.12 b/bugfixes/dev-libs/apr-util/files/digest-apr-util-0.9.12
new file mode 100644
index 0000000..c395888
--- /dev/null
+++ b/bugfixes/dev-libs/apr-util/files/digest-apr-util-0.9.12
@@ -0,0 +1,3 @@
+MD5 8e9cc71a1303b67b3278fbeab9799f2e apr-util-0.9.12.tar.gz 592364
+RMD160 a4554def22f29f56aab34cacddc7fa65c412f446 apr-util-0.9.12.tar.gz 592364
+SHA256 5768fcc4d38fa6f811b0a89e2ef450d0f52688ff9263e548819adb096fbfc9c3 apr-util-0.9.12.tar.gz 592364