summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRadoslaw Stachowiak <radek@gentoo.org>2007-01-06 22:13:01 +0000
committerRadoslaw Stachowiak <radek@gentoo.org>2007-01-06 22:13:01 +0000
commit3416f368195e25355169631eeecf93f10a0c22b5 (patch)
tree892c11af3cea02f68bc892764a695d092417234d
parentpyinotify-0.6.3 version bump on x86 and old ebuilds cleaning (diff)
downloadradek-3416f368195e25355169631eeecf93f10a0c22b5.tar.gz
radek-3416f368195e25355169631eeecf93f10a0c22b5.tar.bz2
radek-3416f368195e25355169631eeecf93f10a0c22b5.zip
pyinotify-0.6.3 version bump on x86
svn path=/radek-portage/; revision=12
-rw-r--r--dev-python/pyinotify/files/digest-pyinotify-0.6.33
-rw-r--r--dev-python/pyinotify/pyinotify-0.6.3.ebuild38
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/pyinotify/files/digest-pyinotify-0.6.3 b/dev-python/pyinotify/files/digest-pyinotify-0.6.3
new file mode 100644
index 0000000..3834604
--- /dev/null
+++ b/dev-python/pyinotify/files/digest-pyinotify-0.6.3
@@ -0,0 +1,3 @@
+MD5 acf97c325faa41f889cdab3d7a1f2f01 pyinotify-0.6.3.tar.bz2 81782
+RMD160 389978e5a7b8502cce6e7049504b102dcb029303 pyinotify-0.6.3.tar.bz2 81782
+SHA256 e1728aeef6daa699da3f289b9624cc169d1be58c47f34d745793145eebe5dddf pyinotify-0.6.3.tar.bz2 81782
diff --git a/dev-python/pyinotify/pyinotify-0.6.3.ebuild b/dev-python/pyinotify/pyinotify-0.6.3.ebuild
new file mode 100644
index 0000000..7a4c708
--- /dev/null
+++ b/dev-python/pyinotify/pyinotify-0.6.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: Exp $
+
+inherit distutils
+
+RESTRICT="primaryuri"
+
+DESCRIPTION="Python Linux kernel inotify extension"
+HOMEPAGE="http://pyinotify.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+IUSE="doc"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+PYTHON_MODNAME="pyinotify"
+
+DOCS="README TODO AUTHORS NEWS ChangeLog PKG-INFO"
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+
+ insinto /usr/share/doc/${P}
+ # api documentation
+ doins -r doc
+ # www page
+ doins -r www
+
+ insinto /usr/share/${PN}
+ doins -r src/examples
+ doins -r src/tests
+ fi
+}
+