summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@orbis-terrarum.net>2010-06-15 11:06:02 -0700
committerRobin H. Johnson <robbat2@orbis-terrarum.net>2010-06-15 11:06:02 -0700
commita48a3491815b45873e24c1bdcc5968b52fcfc154 (patch)
tree2797263d35853ceff7e1ca64518609c5b424a861
parentNew pidgin plugins to mature. (diff)
downloadrobbat2-a48a3491815b45873e24c1bdcc5968b52fcfc154.tar.gz
robbat2-a48a3491815b45873e24c1bdcc5968b52fcfc154.tar.bz2
robbat2-a48a3491815b45873e24c1bdcc5968b52fcfc154.zip
Add Xcoral for unixronin.
-rw-r--r--x11-misc/xcoral/Manifest2
-rw-r--r--x11-misc/xcoral/xcoral-3.47.ebuild40
2 files changed, 42 insertions, 0 deletions
diff --git a/x11-misc/xcoral/Manifest b/x11-misc/xcoral/Manifest
new file mode 100644
index 0000000..2b69c38
--- /dev/null
+++ b/x11-misc/xcoral/Manifest
@@ -0,0 +1,2 @@
+DIST xcoral-3.47.tar.gz 2760763 RMD160 57bef4965c17c616ce02f1e33455e7288893eeca SHA1 fc8231fde5a6f42c2c67498f818241c85db4f28d SHA256 886e02eeb96e494d32969fcf41dcd09133896b717b714eb42affed1f460af3dd
+EBUILD xcoral-3.47.ebuild 760 RMD160 0016e6e6f4032ef2e2b53fe34a695a8f56a934d8 SHA1 4a14810fd92b2a2ffe99f83723b096c74799ebc0 SHA256 c531a41737598749685bc83f195a765dd18abdab1a6de4d0e36f23f880092342
diff --git a/x11-misc/xcoral/xcoral-3.47.ebuild b/x11-misc/xcoral/xcoral-3.47.ebuild
new file mode 100644
index 0000000..5cd9994
--- /dev/null
+++ b/x11-misc/xcoral/xcoral-3.47.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+inherit eutils multilib
+
+DESCRIPTION="multiwindow mouse-based text editor for Unix and X Window System"
+HOMEPAGE="http://xcoral.free.fr/"
+SRC_URI="http://xcoral.free.fr/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf --with-x || die
+}
+
+XCORAL_SHAREDIR=/usr/share/xcoral
+
+src_compile() {
+ local makeopts="XCORALLIBDIR=\\\"${XCORAL_SHAREDIR}\\\""
+ pushd "${S}/Smac"
+ emake -j1 word.h y.tab.c || die
+ emake all ${makeopts} || die
+ popd
+ emake ${makeopts} || die
+}
+
+src_install() {
+ dobin xcoral
+ dodoc README
+ insinto ${XCORAL_SHAREDIR}
+ doins SmacLib/*
+}