summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-print/lexmark-ppd-common/lexmark-ppd-common-20130617.ebuild')
-rw-r--r--net-print/lexmark-ppd-common/lexmark-ppd-common-20130617.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-print/lexmark-ppd-common/lexmark-ppd-common-20130617.ebuild b/net-print/lexmark-ppd-common/lexmark-ppd-common-20130617.ebuild
new file mode 100644
index 0000000..5ebf8e5
--- /dev/null
+++ b/net-print/lexmark-ppd-common/lexmark-ppd-common-20130617.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+# any of LMADH/LMADG/LMADE for the latest version of pdfcontone
+MODEL_CODE=LMADH
+
+inherit cups-lexmark
+DESCRIPTION="CUPS files common to Lexmark drivers"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_prepare() {
+ cups-lexmark_src_prepare
+ cd "${S2}"
+ sed -i \
+ -e 's/GEYMYUSERNAME/GE[YT]MYUSERNAME/' \
+ "$SRCDIR"/fax-pnh-filter \
+ || die "sed of fax-pnh-filter failed"
+ sed -i.orig \
+ -e '/<url>/,/<\/url>/d' \
+ -e '/<\/name>/a<url>http://www.lexmark.com</url>' \
+ "${S}"/foomatic/UTF-8/driver/Lexmark_PPD.xml \
+ || die "sed of Lexmark_PPD.xml failed"
+}