summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gnome-boxes/Manifest3
-rw-r--r--gnome-extra/gnome-boxes/gnome-boxes-3.5.2.ebuild85
-rw-r--r--gnome-extra/gnome-boxes/gnome-boxes-9999.ebuild84
-rw-r--r--gnome-extra/gnome-color-manager/Manifest2
-rw-r--r--gnome-extra/gnome-color-manager/gnome-color-manager-3.5.1.ebuild73
5 files changed, 247 insertions, 0 deletions
diff --git a/gnome-extra/gnome-boxes/Manifest b/gnome-extra/gnome-boxes/Manifest
new file mode 100644
index 0000000..66a9af6
--- /dev/null
+++ b/gnome-extra/gnome-boxes/Manifest
@@ -0,0 +1,3 @@
+DIST gnome-boxes-3.5.2.tar.xz 807496 RMD160 416d6964b916ce4ccea1580a44ff155204502b5e SHA1 7492471e5ac656f3d94a8dea509a0101518bccb1 SHA256 e0afe0f517acf0fdadba3b91eb5a938e585aca914d9801813b221b4e2a725ac8
+EBUILD gnome-boxes-3.5.2.ebuild 2090 RMD160 f914480c48bd129a6e2eee4f71f66ddcf6d57f9f SHA1 f5d519da1a2eff916cf9318e7f736a9aa59119de SHA256 5577cf81dc40e0ccaa7410c18e9a78b729d3b1183b8720695acb47994e176a1b
+EBUILD gnome-boxes-9999.ebuild 2069 RMD160 f2aed9e1093e4540e7819364f21d531317ccfbbd SHA1 c3e5ac48162d985b0d13f55ea0851e07d982c52b SHA256 1fea93a222e6d27d09f1498617be2beaa67b9bb0c98f89dfd32c96507013df4f
diff --git a/gnome-extra/gnome-boxes/gnome-boxes-3.5.2.ebuild b/gnome-extra/gnome-boxes/gnome-boxes-3.5.2.ebuild
new file mode 100644
index 0000000..da1fd28
--- /dev/null
+++ b/gnome-extra/gnome-boxes/gnome-boxes-3.5.2.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="4"
+GCONF_DEBUG="no"
+
+inherit linux-info gnome2
+if [[ ${PV} = 9999 ]]; then
+ inherit gnome2-live
+fi
+
+DESCRIPTION="Simple GNOME 3 application to access remote or virtual systems"
+HOMEPAGE="https://live.gnome.org/Design/Apps/Boxes"
+
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="bindist"
+if [[ ${PV} = 9999 ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64" # qemu-kvm[spice] is 64bit-only
+fi
+
+# CHECK: We're hard-depending on qemu-kvm[spice]. Does app-emulation/qemu
+# support spice or not?
+# NOTE: sys-fs/* stuff is called via exec()
+RDEPEND="
+ >=dev-libs/libxml2-2.7.8:2
+ >=sys-fs/udev-165[gudev]
+ >=dev-libs/glib-2.29.90:2
+ >=dev-libs/gobject-introspection-0.9.6
+ >=sys-libs/libosinfo-0.1.1
+ app-emulation/qemu-kvm[spice]
+ >=app-emulation/libvirt-0.9.3[libvirtd,qemu]
+ >=app-emulation/libvirt-glib-0.0.8
+ >=x11-libs/gtk+-3.3.5:3
+ >=net-libs/gtk-vnc-0.4.4[gtk3]
+ >=net-misc/spice-gtk-0.9[gtk3]
+ >=app-misc/tracker-0.14[iso]
+ >=gnome-base/libgnomekbd-3
+
+ sys-fs/fuse
+ sys-fs/fuseiso
+ sys-fs/mtools"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig"
+
+if [[ ${PV} = 9999 ]]; then
+ DEPEND="${DEPEND}
+ >=dev-lang/vala-0.14.0:0.14
+ sys-libs/libosinfo[introspection,vala]
+ app-emulation/libvirt-glib[introspection,vala]
+ net-libs/gtk-vnc[introspection,vala]
+ net-misc/spice-gtk[introspection,vala]"
+fi
+
+pkg_pretend() {
+ linux_config_exists
+
+ if ! { linux_chkconfig_present KVM_AMD || \
+ linux_chkconfig_present KVM_INTEL; }; then
+ ewarn "You need KVM support in your kernel to use GNOME Boxes!"
+ fi
+}
+
+pkg_setup() {
+ DOCS="AUTHORS README NEWS THANKS TODO"
+ G2CONF="--disable-schemas-compile
+ --disable-strict-cc
+ $(use_enable !bindist logos)
+ VALAC=$(type -P valac-0.14)"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ elog "Before running gnome-boxes, you will need to load the KVM modules"
+ elog "If you have an Intel Processor, run:"
+ elog " modprobe kvm-intel"
+ einfo
+ elog "If you have an AMD Processor, run:"
+ elog " modprobe kvm-amd"
+}
diff --git a/gnome-extra/gnome-boxes/gnome-boxes-9999.ebuild b/gnome-extra/gnome-boxes/gnome-boxes-9999.ebuild
new file mode 100644
index 0000000..57fac3c
--- /dev/null
+++ b/gnome-extra/gnome-boxes/gnome-boxes-9999.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="4"
+GCONF_DEBUG="no"
+
+inherit linux-info gnome2
+if [[ ${PV} = 9999 ]]; then
+ inherit gnome2-live
+fi
+
+DESCRIPTION="Simple GNOME 3 application to access remote or virtual systems"
+HOMEPAGE="https://live.gnome.org/Design/Apps/Boxes"
+
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="bindist"
+if [[ ${PV} = 9999 ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64" # qemu-kvm[spice] is 64bit-only
+fi
+
+# CHECK: We're hard-depending on qemu-kvm[spice]. Does app-emulation/qemu
+# support spice or not?
+# NOTE: sys-fs/* stuff is called via exec()
+RDEPEND="
+ >=dev-libs/libxml2-2.7.8:2
+ >=sys-fs/udev-165[gudev]
+ >=dev-libs/glib-2.29.90:2
+ >=dev-libs/gobject-introspection-0.9.6
+ >=sys-libs/libosinfo-0.1.1
+ app-emulation/qemu-kvm[spice]
+ >=app-emulation/libvirt-0.9.3[libvirtd,qemu]
+ >=app-emulation/libvirt-glib-0.0.7
+ >=x11-libs/gtk+-3.3.5:3
+ >=net-libs/gtk-vnc-0.4.4[gtk3]
+ >=net-misc/spice-gtk-0.9[gtk3]
+ >=app-misc/tracker-0.14[iso]
+ >=gnome-base/libgnomekbd-3
+
+ sys-fs/fuse
+ sys-fs/fuseiso
+ sys-fs/mtools"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig"
+
+if [[ ${PV} = 9999 ]]; then
+ DEPEND="${DEPEND}
+ >=dev-lang/vala-0.14.0:0.14
+ sys-libs/libosinfo[introspection,vala]
+ app-emulation/libvirt-glib[introspection,vala]
+ net-libs/gtk-vnc[introspection,vala]
+ net-misc/spice-gtk[introspection,vala]"
+fi
+
+pkg_pretend() {
+ linux_config_exists
+
+ if ! { linux_chkconfig_present KVM_AMD || \
+ linux_chkconfig_present KVM_INTEL; }; then
+ ewarn "You need KVM support in your kernel to use GNOME Boxes!"
+ fi
+}
+
+pkg_setup() {
+ DOCS="AUTHORS README NEWS THANKS TODO"
+ G2CONF="--disable-schemas-compile
+ --disable-strict-cc
+ $(use_enable !bindist logos)
+ VALAC=$(type -P valac-0.14)"
+}
+
+pkg_postinst() {
+ elog "Before running gnome-boxes, you will need to load the KVM modules"
+ elog "If you have an Intel Processor, run:"
+ elog " modprobe kvm-intel"
+ einfo
+ elog "If you have an AMD Processor, run:"
+ elog " modprobe kvm-amd"
+}
diff --git a/gnome-extra/gnome-color-manager/Manifest b/gnome-extra/gnome-color-manager/Manifest
new file mode 100644
index 0000000..422b160
--- /dev/null
+++ b/gnome-extra/gnome-color-manager/Manifest
@@ -0,0 +1,2 @@
+DIST gnome-color-manager-3.5.1.tar.xz 2535212 RMD160 aceef2ef0731f87e2dcb643764935286651d2f8e SHA1 6854ccf4a53aa92eddd4f2316852d65b014da2ab SHA256 0851dd97493401a1f4856432e0ffcd3565864377a9ad23255c6122dee9b4fdf6
+EBUILD gnome-color-manager-3.5.1.ebuild 1787 RMD160 01ce562dde41fb57569b5363c8487d98d55ad712 SHA1 0cd0132c869ce2a4a793a9a8b33cad52a0795790 SHA256 6d1cdb6dd75a958456951d51f0aadab12e48660b2398c83ae12d68656952813b
diff --git a/gnome-extra/gnome-color-manager/gnome-color-manager-3.5.1.ebuild b/gnome-extra/gnome-color-manager/gnome-color-manager-3.5.1.ebuild
new file mode 100644
index 0000000..0e443c5
--- /dev/null
+++ b/gnome-extra/gnome-color-manager/gnome-color-manager-3.5.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-color-manager/gnome-color-manager-3.4.0.ebuild,v 1.1 2012/05/13 23:36:49 tetromino Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="Color profile manager for the GNOME desktop"
+HOMEPAGE="http://projects.gnome.org/gnome-color-manager/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="clutter packagekit raw"
+
+# FIXME: fix detection of docbook2man
+COMMON_DEPEND=">=dev-libs/glib-2.31.10:2
+ gnome-base/gnome-desktop:3
+ >=media-libs/lcms-2.2:2
+ >=media-libs/libcanberra-0.10[gtk3]
+ media-libs/libexif
+ media-libs/tiff
+
+ x11-libs/libX11
+ x11-libs/libXrandr
+ >=x11-libs/gtk+-2.91:3
+ >=x11-libs/vte-0.25.1:2.90
+ >=x11-misc/colord-0.1.12
+
+ clutter? (
+ >=media-libs/clutter-1.9.11:1.0
+ media-libs/clutter-gtk:1.0
+ media-libs/mash:0.2 )
+ packagekit? ( app-admin/packagekit-base )
+ raw? ( media-gfx/exiv2 )
+"
+RDEPEND="${COMMON_DEPEND}
+ media-gfx/shared-color-profiles
+"
+# docbook-sgml-{utils,dtd:4.1} needed to generate man pages
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-sgml-dtd:4.1
+ app-text/docbook-sgml-utils
+ app-text/gnome-doc-utils
+ dev-libs/libxslt
+ >=dev-util/intltool-0.35
+ virtual/pkgconfig
+"
+
+# FIXME: run test-suite with files on live file-system
+RESTRICT="test"
+
+pkg_setup() {
+ # Always enable tests since they are check_PROGRAMS anyway
+ G2CONF="${G2CONF}
+ --disable-static
+ --disable-schemas-compile
+ --disable-scrollkeeper
+ --enable-tests
+ $(use_enable clutter)
+ $(use_enable packagekit)
+ $(use_enable raw exiv)"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ elog "If you want to do display or scanner calibration, you will need to"
+ elog "install media-gfx/argyllcms"
+}