summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/openrc/openrc-9999.ebuild')
-rw-r--r--sys-apps/openrc/openrc-9999.ebuild24
1 files changed, 8 insertions, 16 deletions
diff --git a/sys-apps/openrc/openrc-9999.ebuild b/sys-apps/openrc/openrc-9999.ebuild
index 58f664f..ca8a31d 100644
--- a/sys-apps/openrc/openrc-9999.ebuild
+++ b/sys-apps/openrc/openrc-9999.ebuild
@@ -62,23 +62,7 @@ pkg_setup() {
MAKE_ARGS="${MAKE_ARGS} CC=$(tc-getCC)"
}
-# Massage the git repo a little
-if [ "${PV}" = "9999" ]; then
-src_unpack() {
- git_src_unpack
- cd "${S}"
-
- # GIT has this rpath for testing, but we need to disable it as it's
- # a potential security risk
- #sed -i.bak -e '/LDFLAGS += -Wl,-rpath ./ s/^/#/' src/Makefile
-
- # Ensure a .depend always exists as it should not be in GIT
- #[ -e src/.depend ] || touch -r / src/.depend
-}
-fi
-
src_compile() {
- #emake ${MAKE_ARGS} depend || die
emake ${MAKE_ARGS} || die
}
@@ -93,6 +77,14 @@ src_install() {
if use unicode; then
sed -i -e '/^unicode=/s:NO:YES:' "${D}"/etc/rc.conf
fi
+
+ # Fix portage bitching about libs and symlinks
+ rm "${D}"/usr/"${LIBDIR}"/libeinfo.so
+ rm "${D}"/usr/"${LIBDIR}"/librc.so
+ ln -s libeinfo.so.1 "${D}"/"${LIBDIR}"/libeinfo.so
+ ln -s librc.so.1 "${D}"/"${LIBDIR}"/librc.so
+ gen_usr_ldscript libeinfo.so
+ gen_usr_ldscript librc.so
}
pkg_preinst() {