summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/hwsetup/hwsetup-1.2.ebuild')
-rw-r--r--sys-apps/hwsetup/hwsetup-1.2.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/sys-apps/hwsetup/hwsetup-1.2.ebuild b/sys-apps/hwsetup/hwsetup-1.2.ebuild
new file mode 100644
index 0000000..0903ed9
--- /dev/null
+++ b/sys-apps/hwsetup/hwsetup-1.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwsetup/hwsetup-1.2.ebuild,v 1.9 2008/04/03 00:27:01 wolf31o2 Exp $
+
+inherit eutils toolchain-funcs flag-o-matic
+
+MY_PV=${PV}-3
+DESCRIPTION="Hardware setup program from Knoppix - used only on LiveCD"
+HOMEPAGE="http://www.knopper.net/"
+SRC_URI="http://debian-knoppix.alioth.debian.org/sources/${PN}_${MY_PV}.tar.gz"
+#http://developer.linuxtag.net/knoppix/sources/${PN}_${MY_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ia64 -mips ppc ppc64 sparc x86"
+IUSE="zlib"
+
+COMMON_DEPEND="zlib? ( sys-libs/zlib )
+ sys-apps/pciutils"
+DEPEND="${COMMON_DEPEND}
+ sys-libs/libkudzu"
+RDEPEND="${COMMON_DEPEND}
+ sys-apps/hwdata-gentoo"
+
+src_unpack() {
+ unpack ${A}
+ epatch \
+ "${FILESDIR}"/${P}-dyn_blacklist.patch \
+ "${FILESDIR}"/${P}-fastprobe.patch \
+ "${FILESDIR}"/${P}-gentoo.patch
+}
+
+src_compile() {
+ append-ldflags -s
+ filter-ldflags -Wl,--as-needed --as-needed
+ if use zlib
+ then
+ append-ldflags -lz
+ elif built_with_use --missing false sys-apps/pciutils zlib
+ then
+ die "You need to build with USE=zlib to match sys-apps/pcituils"
+ fi
+ emake LDFLAGS="${LDFLAGS}" OPT="${CFLAGS}" CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install() {
+ einstall DESTDIR="${D}" PREFIX=/usr MANDIR=/usr/share/man || die "Install failed"
+ keepdir /etc/sysconfig
+}
+
+pkg_postinst() {
+ ewarn "This package is intended for usage on the Gentoo release media. If"
+ ewarn "you are not building a CD, remove this package. It will not work"
+ ewarn "properly on a running system, as Gentoo does not use any of the"
+ ewarn "Knoppix-style detection except for CD builds."
+}