summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGunnar Wrobel <wrobel@gentoo.org>2005-08-01 20:45:43 +0000
committerGunnar Wrobel <wrobel@gentoo.org>2005-08-01 20:45:43 +0000
commita6f3b92031fbd874258c9c1c04b89d49f2cb027f (patch)
treea720d1989b9d45a778e46c6c321ce1c6f38c74fc /www-apps
parentFixes on the outreach ebuild (diff)
downloadoverlay-a6f3b92031fbd874258c9c1c04b89d49f2cb027f.tar.gz
overlay-a6f3b92031fbd874258c9c1c04b89d49f2cb027f.tar.bz2
overlay-a6f3b92031fbd874258c9c1c04b89d49f2cb027f.zip
Fixes on the outreach ebuild
svn path=/; revision=258
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/openwebstats/files/config.php46
-rw-r--r--www-apps/openwebstats/files/postinstall-en.txt19
-rw-r--r--www-apps/openwebstats/openwebstats-1.1.ebuild1
3 files changed, 61 insertions, 5 deletions
diff --git a/www-apps/openwebstats/files/config.php b/www-apps/openwebstats/files/config.php
new file mode 100644
index 0000000..5523397
--- /dev/null
+++ b/www-apps/openwebstats/files/config.php
@@ -0,0 +1,46 @@
+<?php
+################################################################################
+## OpenWebStats Version 1.0 ##
+## ##
+## (c)2005 mathews_dm - <Davidmathews@open-creations.com> ##
+## ##
+################################################################################
+## Please read the README! ##
+################################################################################
+
+##########################################
+## Define Globals for OpenWebStats ##
+##########################################
+global $openstats_web_dir, $databasename;
+
+if (!defined("logformat_combined"))
+{
+ define("logformat_combined", "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"", TRUE);
+ define("logformat_combined_vhost", "%v %h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"", TRUE);
+ define("logformat_common" , "%h %l %u %t \"%r\" %>s %b", TRUE);
+ define("logformat_referer" , "%{Referer}i -> %U", TRUE);
+ define("logformat_agent" , "%{User-agent}i", TRUE);
+}
+
+##########################################
+## Database information below here ##
+##########################################
+$databaselocation = 'localhost';
+$databaseport = '3306';
+$databasename = 'ows';
+$databaseuser = 'ows';
+$databasepass = 'pass';
+$db_connect = mysql_connect($databaselocation, $databaseuser, $databasepass);
+mysql_select_db($databasename, $db_connect);
+
+##########################################
+## Logfile and Logformat are for the db ##
+## import in the class_apache file. ##
+## $openstatsdir is the install dir on ##
+## your system. ##
+##########################################
+$openstats_web_dir = '/openwebstats'; // Remember to include the stats dir
+$logfile = "/var/log/apache2/access_log";
+$logformat = logformat_combined; //example: $logformat = logformat_combined_vhost;
+
+?>
diff --git a/www-apps/openwebstats/files/postinstall-en.txt b/www-apps/openwebstats/files/postinstall-en.txt
index d0e3752..14fa54b 100644
--- a/www-apps/openwebstats/files/postinstall-en.txt
+++ b/www-apps/openwebstats/files/postinstall-en.txt
@@ -6,8 +6,8 @@ you will have to create a database for the apache log records.
You can do this using the following commands as the mysql root user:
-> mysql -u root -p -e "CREATE DATABASE openwebstats;
- GRANT SELECT, INSERT, UPDATE, DELETE ON ows.* TO 'ows'@'localhost'
+> mysql -u root -p -e "CREATE DATABASE ows;
+ GRANT CREATE, SELECT, INSERT, UPDATE, DELETE ON ows.* TO 'ows'@'localhost'
IDENTIFIED BY 'pass';
FLUSH PRIVILEGES;"
@@ -16,10 +16,19 @@ Please do not forget to choose a password that is more sensible than
Now as user "ows":
-> mysql -u ows -ppass openwebstats < ${MY_HTDOCSDIR}/sql/mysql/install/openwebstats.sql
+> mysql -u ows -ppass openwebstats < ${MY_SQLSCRIPTS-DIR}/mysql/${PV}_create.sql
-You also need to set the MySQL passwords for the dms and dmsadmin user in
-the ${MY_INSTALLDIR}/config.php file so that openwebstats can access the database.
+You also need to set the MySQL passwords for the ows user in
+the ${MY_INSTALLDIR}/config.php file
+so that openwebstats can access the database.
+
+If you use a special logfile format for your web server you should
+also modify the log format in the config.php file.
+
+Make sure your access_log is readable if you want to use the update
+function of the web frontend.
+
+> chmod 644 /var/log/apache2/access_log
Now you can go to http://${VHOST_HOSTNAME}${VHOST_APPDIR} and use the
application.
diff --git a/www-apps/openwebstats/openwebstats-1.1.ebuild b/www-apps/openwebstats/openwebstats-1.1.ebuild
index b139d84..6263dc6 100644
--- a/www-apps/openwebstats/openwebstats-1.1.ebuild
+++ b/www-apps/openwebstats/openwebstats-1.1.ebuild
@@ -26,6 +26,7 @@ src_install() {
## Main application
cp -r . ${D}${MY_HTDOCSDIR}
+ cp ${FILESDIR}/ ${D}${MY_HTDOCSDIR}/
## Docs installed, remove unnecessary files
rm -f ${D}${MY_HTDOCSDIR}/README