summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-wm/i3/Manifest3
-rw-r--r--x11-wm/i3/files/i3-9999-build.patch113
-rw-r--r--x11-wm/i3/i3-9999.ebuild60
3 files changed, 148 insertions, 28 deletions
diff --git a/x11-wm/i3/Manifest b/x11-wm/i3/Manifest
index 7b9c832..4c06165 100644
--- a/x11-wm/i3/Manifest
+++ b/x11-wm/i3/Manifest
@@ -1,5 +1,6 @@
+AUX i3-9999-build.patch 3212 RMD160 11687098d9be7fe3e87765a25970ee8bf2147c34 SHA1 7001c2e00120ded08ffee7ca5ecf9d081b0975f7 SHA256 334a55f9c949d3b3d489d265948d57aaea34f7fff3844a590cd8f80d23a5a6dc
AUX i3-gentoo.diff 5219 RMD160 d592d6e12f1983be50a78d43a65c1380f5366413 SHA1 8899a886209d30c21ab5f81f82f9e6a5fe487371 SHA256 a21e3f877eab4c2068f0fa7447765aa642cdf8a7756e495ef947da5118787897
DIST i3-3.e-bf3.tar.bz2 360704 RMD160 858d92020e251b3afd34bcb0008d7ccc25d04669 SHA1 7c35f49fa14a21b606bb102b41c5f0cead4e93a3 SHA256 e0a7b030ebbad0ebf2ac39f235dd5e0ad34ef0ff5b83e31501a361f92e85c68f
EBUILD i3-3e_p3.ebuild 1047 RMD160 66f5d82c72f8652fcf5dadb3446f1a9a27320f12 SHA1 e422b3ceae77a9dffe78d7c2ab7ab0948fb1a4fe SHA256 69bdfdbd358c00ec7acf5063eb95ac9a312dbe7f3f58aa372ad1c9b44ce6131f
-EBUILD i3-9999.ebuild 1286 RMD160 34a9e79d7fb7db82437e2b4e75c0f4b279b45f9a SHA1 2ec6440b308c80af1329855dc5f978b885205afd SHA256 ab4bd9e0ab8d5b3dc5c745fa743176a355d10b055d5a141c71a0d68c56e01fe7
+EBUILD i3-9999.ebuild 1171 RMD160 1de18ad68c0cbf6d7b1416bc5fab40d7dc999ebb SHA1 8649aa04e76924e477af9a43ab77047c8627e3da SHA256 0e1121dcc643ea6212f70a43b2eb37f566e1350af75fc0c2be53d1a6cf7e98bd
MISC metadata.xml 262 RMD160 5fa004a3927201d509adf4583c80fcea57d845cb SHA1 7d07024bbe476df939b23a4552ec9a403ec8fff7 SHA256 9efce27cc1c3955b252cc5b7272629cd5b66260849fd9e5a5fae9e420a1829d9
diff --git a/x11-wm/i3/files/i3-9999-build.patch b/x11-wm/i3/files/i3-9999-build.patch
new file mode 100644
index 0000000..6c13460
--- /dev/null
+++ b/x11-wm/i3/files/i3-9999-build.patch
@@ -0,0 +1,113 @@
+diff --git a/Makefile b/Makefile
+index 10af73b..b96e64e 100644
+--- a/Makefile
++++ b/Makefile
+@@ -18,14 +18,22 @@ else
+ UNUSED:=$(shell $(MAKE) loglevels.h)
+ endif
+
++SUBDIRS=i3-msg i3-input i3-nagbar i3-config-wizard
++
+ # Depend on the specific file (.c for each .o) and on all headers
+ src/%.o: src/%.c ${HEADERS}
+ echo "CC $<"
+ $(CC) $(CPPFLAGS) $(CFLAGS) -DLOGLEVEL="((uint64_t)1 << $(shell awk '/$(shell basename $< .c)/ { print NR; exit 0; }' loglevels.tmp))" -c -o $@ $<
+
+-all: src/cfgparse.y.o src/cfgparse.yy.o src/cmdparse.y.o src/cmdparse.yy.o ${FILES}
+- echo "LINK i3"
+- $(CC) $(LDFLAGS) -o i3 $^ $(LIBS)
++all: i3 subdirs
++
++i3: src/cfgparse.y.o src/cfgparse.yy.o src/cmdparse.y.o src/cmdparse.yy.o ${FILES}
++ $(CC) $(LDFLAGS) -o $@ $^ $(LIBS)
++
++subdirs:
++ for dir in $(SUBDIRS); do \
++ $(MAKE) -C $$dir; \
++ done
+
+ loglevels.h:
+ echo "LOGLEVELS"
+@@ -74,10 +82,9 @@ install: all
+ $(INSTALL) -m 0644 i3.welcome $(DESTDIR)$(SYSCONFDIR)/i3/welcome
+ $(INSTALL) -m 0644 i3.desktop $(DESTDIR)$(PREFIX)/share/xsessions/
+ $(INSTALL) -m 0644 include/i3/ipc.h $(DESTDIR)$(PREFIX)/include/i3/
+- $(MAKE) TOPDIR=$(TOPDIR) -C i3-msg install
+- $(MAKE) TOPDIR=$(TOPDIR) -C i3-input install
+- $(MAKE) TOPDIR=$(TOPDIR) -C i3-nagbar install
+- $(MAKE) TOPDIR=$(TOPDIR) -C i3-config-wizard install
++ for dir in $(SUBDIRS); do \
++ $(MAKE) -C $$dir install; \
++ done
+
+ dist: distclean
+ [ ! -d i3-${VERSION} ] || rm -rf i3-${VERSION}
+diff --git a/i3-config-wizard/Makefile b/i3-config-wizard/Makefile
+index 688df11..690fc0f 100644
+--- a/i3-config-wizard/Makefile
++++ b/i3-config-wizard/Makefile
+@@ -13,9 +13,11 @@ HEADERS:=$(wildcard *.h)
+ echo "CC $<"
+ $(CC) $(CPPFLAGS) $(CFLAGS) -c -o $@ $<
+
+-all: cfgparse.y.o cfgparse.yy.o ${FILES}
++all: i3-config-wizard
++
++i3-config-wizard: cfgparse.y.o cfgparse.yy.o ${FILES}
+ echo "LINK i3-config-wizard"
+- $(CC) $(LDFLAGS) -o i3-config-wizard $^ $(LIBS)
++ $(CC) $(LDFLAGS) -o $@ $^ $(LIBS)
+
+ cfgparse.yy.o: cfgparse.l cfgparse.y.o ${HEADERS}
+ echo "LEX $<"
+diff --git a/i3-input/Makefile b/i3-input/Makefile
+index 498cfb5..45653da 100644
+--- a/i3-input/Makefile
++++ b/i3-input/Makefile
+@@ -12,9 +12,11 @@ HEADERS=$(wildcard *.h)
+ echo "CC $<"
+ $(CC) $(CPPFLAGS) $(CFLAGS) -c -o $@ $<
+
+-all: ${FILES}
++all: i3-input
++
++i3-input: ${FILES}
+ echo "LINK i3-input"
+- $(CC) $(LDFLAGS) -o i3-input ${FILES} $(LIBS)
++ $(CC) $(LDFLAGS) -o $@ ${FILES} $(LIBS)
+
+ install: all
+ echo "INSTALL"
+diff --git a/i3-msg/Makefile b/i3-msg/Makefile
+index 7ea19e6..1b7c1c0 100644
+--- a/i3-msg/Makefile
++++ b/i3-msg/Makefile
+@@ -14,7 +14,9 @@ HEADERS=$(wildcard *.h)
+ echo "CC $<"
+ $(CC) $(CPPFLAGS) $(CFLAGS) -c -o $@ $<
+
+-all: ${FILES}
++all: i3-msg
++
++i3-msg: ${FILES}
+ echo "LINK i3-msg"
+ $(CC) $(LDFLAGS) -o i3-msg ${FILES} $(LIBS)
+
+diff --git a/i3-nagbar/Makefile b/i3-nagbar/Makefile
+index c9eec44..933ae76 100644
+--- a/i3-nagbar/Makefile
++++ b/i3-nagbar/Makefile
+@@ -12,9 +12,11 @@ HEADERS=$(wildcard *.h)
+ echo "CC $<"
+ $(CC) $(CPPFLAGS) $(CFLAGS) -c -o $@ $<
+
+-all: ${FILES}
++all: i3-nagbar
++
++i3-nagbar: ${FILES}
+ echo "LINK i3-nagbar"
+- $(CC) $(LDFLAGS) -o i3-nagbar ${FILES} $(LIBS)
++ $(CC) $(LDFLAGS) -o $@ ${FILES} $(LIBS)
+
+ install: all
+ echo "INSTALL"
diff --git a/x11-wm/i3/i3-9999.ebuild b/x11-wm/i3/i3-9999.ebuild
index 9294c03..8abb5b1 100644
--- a/x11-wm/i3/i3-9999.ebuild
+++ b/x11-wm/i3/i3-9999.ebuild
@@ -2,55 +2,61 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI="2"
+EAPI=4
EGIT_REPO_URI="git://code.stapelberg.de/i3"
-EGIT_BRANCH="next"
+EGIT_BRANCH="tree"
-inherit git multilib
+inherit eutils git-2 toolchain-funcs
DESCRIPTION="An improved dynamic tiling window manager"
-HOMEPAGE="http://i3.zekjur.net/"
+HOMEPAGE="http://i3wm.org/"
SRC_URI=""
LICENSE="BSD"
SLOT="0"
KEYWORDS=""
-IUSE="debug doc"
+IUSE="doc"
-RDEPEND=">=x11-libs/libxcb-1.1.93
- >=x11-libs/xcb-util-0.3.3
+CDEPEND="dev-libs/libev
+ dev-libs/yajl
+ x11-libs/libxcb
x11-libs/libX11
- dev-libs/libev
- dev-libs/yajl"
-DEPEND="${RDEPEND}
- >=x11-proto/xcb-proto-1.3
- >=app-text/asciidoc-8.3
+ x11-libs/xcb-util"
+DEPEND="${CDEPEND}
+ sys-devel/flex
+ sys-devel/bison
+ app-text/asciidoc
app-text/xmlto
app-text/docbook-xml-dtd
- sys-devel/bison
- sys-devel/flex"
+ x11-proto/xcb-proto"
+RDEPEND="${CDEPEND}
+ x11-apps/xmessage"
+
+pkg_setup() {
+ tc-export CC
+}
src_prepare() {
- use debug || { sed -i -e "s:DEBUG=1:DEBUG=0:" common.mk || die "sed die - debug" ; }
- sed -i \
- -e "s:/usr/local/include:/usr/include:" \
- -e "s:/usr/local/lib:/usr/$(get_libdir):" \
- common.mk || die "sed die"
+ epatch "${FILESDIR}"/${P}-build.patch
+ sed -e "/SILENT/d" -e "/DEBUG=/d" \
+ -e '/ifeq ($(DEBUG),1)/,/endif/d' \
+ -i common.mk || die
+ sed -e '/echo "\([[:upper:]]\)/d' \
+ -i Makefile i3-{msg,nagbar,config-wizard}/Makefile || die
}
src_compile() {
- emake || die "emake compile die"
- emake -C man || die "emake man die"
- use doc && { emake -C docs || die "emake docs die" ; }
+ emake || die
+ emake -C man || die
+ use doc && { emake -C docs || die ; }
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install die"
- dodoc GOALS TODO CMDMODE || die "dodoc die"
- doman man/*.1 || die "doman die"
+ emake DESTDIR="${D}" install || die
+ dodoc GOALS TODO CMDMODE RELEASE-*
+ doman man/*.1
if use doc; then
- dohtml -r docs/*.html || die "dohtml die"
- elog "Documentation in html is in /etc/share/doc/${P}"
+ dohtml -r docs/*.html
fi
}