summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/neovim/neovim-0.0.0_pre20150221.ebuild')
-rw-r--r--app-editors/neovim/neovim-0.0.0_pre20150221.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-editors/neovim/neovim-0.0.0_pre20150221.ebuild b/app-editors/neovim/neovim-0.0.0_pre20150221.ebuild
new file mode 100644
index 0000000..bf39ac3
--- /dev/null
+++ b/app-editors/neovim/neovim-0.0.0_pre20150221.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+inherit cmake-utils flag-o-matic
+
+DESCRIPTION="Vim's rebirth for the 21st century"
+HOMEPAGE="https://github.com/neovim/neovim"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://github.com/neovim/neovim.git"
+ KEYWORDS=""
+else
+ inherit vcs-snapshot
+ COMMIT="e9c5f96964b1dcc7d7a013ffd056b97f2674f509"
+ SRC_URI="https://github.com/${PN}/${PN}/tarball/${COMMIT} -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="Apache-2.0 vim"
+SLOT="0"
+IUSE="perl python"
+
+CDEPEND="dev-lang/luajit
+ >=dev-libs/libtermkey-0.17
+ >=dev-libs/unibilium-1.1.1
+ >=dev-libs/libuv-1.2.0
+ >=dev-libs/msgpack-0.6.0_pre20150220
+ dev-lua/LuaBitOp
+ dev-lua/lpeg
+ dev-lua/lua-MessagePack"
+DEPEND="${CDEPEND}
+ virtual/libiconv
+ virtual/libintl"
+RDEPEND="${CDEPEND}
+ perl? ( dev-lang/perl )
+ python? ( dev-python/neovim-python-client )"
+
+src_configure() {
+ append-cflags "-Wno-error"
+ append-cppflags "-DNDEBUG -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=1"
+ local mycmakeargs=( -DCMAKE_BUILD_TYPE=Release )
+ cmake-utils_src_configure
+}