summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/neovim/neovim-9999.ebuild')
-rw-r--r--app-editors/neovim/neovim-9999.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/app-editors/neovim/neovim-9999.ebuild b/app-editors/neovim/neovim-9999.ebuild
index 0580e56..7c8bb7d 100644
--- a/app-editors/neovim/neovim-9999.ebuild
+++ b/app-editors/neovim/neovim-9999.ebuild
@@ -13,14 +13,14 @@ if [[ ${PV} == 9999 ]]; then
KEYWORDS=""
else
inherit vcs-snapshot
- COMMIT="866da6d65e5078ac5aa91af5b4e78caf07853379"
+ COMMIT="8efb3607a7f6cefce450953c7f8d5e3299347bae"
SRC_URI="https://github.com/${PN}/${PN}/tarball/${COMMIT} -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi
LICENSE="Apache-2.0 vim"
SLOT="0"
-IUSE="perl"
+IUSE="perl python"
CDEPEND="dev-lang/luajit
>=dev-libs/libtermkey-0.17
@@ -34,10 +34,12 @@ DEPEND="${CDEPEND}
virtual/libiconv
virtual/libintl"
RDEPEND="${CDEPEND}
- perl? ( dev-lang/perl )"
+ perl? ( dev-lang/perl )
+ python? ( dev-python/neovim-python-client )"
src_configure() {
- append-flags "-Wno-error -DNDEBUG -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=1"
+ append-cflags "-Wno-error"
+ append-cppflags "-DNDEBUG -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=1"
local mycmakeargs=( -DCMAKE_BUILD_TYPE=Release )
cmake-utils_src_configure
}