summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/msgpack/msgpack-9999.ebuild')
-rw-r--r--dev-libs/msgpack/msgpack-9999.ebuild18
1 files changed, 13 insertions, 5 deletions
diff --git a/dev-libs/msgpack/msgpack-9999.ebuild b/dev-libs/msgpack/msgpack-9999.ebuild
index cd13056..3497fef 100644
--- a/dev-libs/msgpack/msgpack-9999.ebuild
+++ b/dev-libs/msgpack/msgpack-9999.ebuild
@@ -1,17 +1,25 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/msgpack/msgpack-0.5.9.ebuild,v 1.1 2014/07/09 04:54:50 radhermit Exp $
+# $Header: $
EAPI=5
-inherit cmake-utils git-r3
+inherit cmake-utils
DESCRIPTION="MessagePack is a binary-based efficient data interchange format"
HOMEPAGE="http://msgpack.org/ https://github.com/msgpack/msgpack-c/"
-EGIT_REPO_URI="https://github.com/${PN}/${PN}-c.git"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}-c.git"
+ KEYWORDS=""
+else
+ inherit vcs-snapshot
+ COMMIT="f6d0cd9a4ba46f4341014a199e3d352fad76b215"
+ SRC_URI="https://github.com/${PN}/${PN}-c/tarball/${COMMIT} -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS=""
IUSE="static-libs test"
DEPEND="test? ( >=dev-cpp/gtest-1.6.0-r2 )"