summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/neovim-python-client/neovim-python-client-0.0.28.ebuild')
-rw-r--r--dev-python/neovim-python-client/neovim-python-client-0.0.28.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/neovim-python-client/neovim-python-client-0.0.28.ebuild b/dev-python/neovim-python-client/neovim-python-client-0.0.28.ebuild
new file mode 100644
index 0000000..0c68887
--- /dev/null
+++ b/dev-python/neovim-python-client/neovim-python-client-0.0.28.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+inherit distutils-r1
+
+DESCRIPTION="Python client to connect to Neovim thru its msgpack-rpc API"
+HOMEPAGE="https://github.com/neovim/python-client"
+SRC_URI="https://github.com/neovim/python-client/archive/0.0.28.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-python/click-3.0
+ >=dev-python/msgpack-0.4.0
+ !python_targets_pypy? ( dev-python/greenlet )
+ !python_targets_python3_4? ( dev-python/trollius )"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${P/neovim-/}